update to 2.6.33

disable 2 patches, one merged for sure so nuke
orig taball generation without changes.

svn path=/dists/trunk/linux-2.6/; revision=15270
This commit is contained in:
Maximilian Attems 2010-02-24 20:44:15 +00:00
parent 4b24757ebe
commit c027d2347c
3 changed files with 3 additions and 57 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (2.6.33~rc8-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (2.6.33-1~experimental.1) UNRELEASED; urgency=low
* New upstream release.

View File

@ -1,54 +0,0 @@
From: Marcin Slusarz <marcin.slusarz@gmail.com>
Subject: [PATCH] efifb: fix framebuffer handoff
Commit 4410f3910947dcea8672280b3adecd53cec4e85e
(fbdev: add support for handoff from firmware to hw framebuffers)
for unknown reason didn't add fb_destroy operation to efifb.
Change aperture_size to match size passed to request_mem_region.
See: http://bugzilla.kernel.org/show_bug.cgi?id=15151
Reported-by: Alex Zhavnerchik <alex.vizor@gmail.com>
Tested-by: Alex Zhavnerchik <alex.vizor@gmail.com>
Cc: Dave Airlie <airlied@redhat.com>
Cc: linux-fbdev@vger.kernel.org
Cc: dri-devel@lists.sourceforge.net
Signed-off-by: Marcin Slusarz <marcin.slusarz@gmail.com>
---
drivers/video/efifb.c | 11 ++++++++++-
1 files changed, 10 insertions(+), 1 deletions(-)
diff --git a/drivers/video/efifb.c b/drivers/video/efifb.c
index eb12182..d25df51 100644
--- a/drivers/video/efifb.c
+++ b/drivers/video/efifb.c
@@ -161,8 +161,17 @@ static int efifb_setcolreg(unsigned regno, unsigned red, unsigned green,
return 0;
}
+static void efifb_destroy(struct fb_info *info)
+{
+ if (info->screen_base)
+ iounmap(info->screen_base);
+ release_mem_region(info->aperture_base, info->aperture_size);
+ framebuffer_release(info);
+}
+
static struct fb_ops efifb_ops = {
.owner = THIS_MODULE,
+ .fb_destroy = efifb_destroy,
.fb_setcolreg = efifb_setcolreg,
.fb_fillrect = cfb_fillrect,
.fb_copyarea = cfb_copyarea,
@@ -281,7 +290,7 @@ static int __init efifb_probe(struct platform_device *dev)
info->par = NULL;
info->aperture_base = efifb_fix.smem_start;
- info->aperture_size = size_total;
+ info->aperture_size = size_remap;
info->screen_base = ioremap(efifb_fix.smem_start, efifb_fix.smem_len);
if (!info->screen_base) {
--
1.6.6

View File

@ -45,7 +45,8 @@
+ bugfix/ia64/ia64-Include-linux-personality.h-header-in-asm-fcntl.patch
+ bugfix/all/cxusb-Select-all-required-frontend-and-tuner-modules.patch
# FIXME: check
#+ bugfix/all/cxusb-Select-all-required-frontend-and-tuner-modules.patch
+ bugfix/x86/kvm-fix-memory-access-during-x86-emulation.patch
+ bugfix/x86/kvm-Check-IOPL-level-during-io-instruction-emulation.patch
@ -53,4 +54,3 @@
+ bugfix/x86/kvm-Check-CPL-level-during-privilege-instruction-emulation.patch
+ debian/sysrq-mask.patch
+ bugfix/all/efifb_fix_v2.patch