ext4: fix retry handling in ext4_ext_truncate()

svn path=/dists/sid/linux/; revision=20446
This commit is contained in:
Ben Hutchings 2013-08-07 12:38:44 +00:00
parent 4bbd0a0969
commit c02187d4c4
3 changed files with 23 additions and 0 deletions

1
debian/changelog vendored
View File

@ -76,6 +76,7 @@ linux (3.10.5-1) UNRELEASED; urgency=low
* [hppa] udeb: Add core-modules package (Closes: #718270)
* nl80211: fix another nl80211_fam.attrbuf race
* Bump ABI to 2
* ext4: fix retry handling in ext4_ext_truncate()
-- Ben Hutchings <ben@decadent.org.uk> Tue, 30 Jul 2013 18:09:20 +0200

View File

@ -0,0 +1,21 @@
From: Theodore Ts'o <tytso@mit.edu>
Date: Mon, 29 Jul 2013 16:12:56 +0000
Subject: ext4: fix retry handling in ext4_ext_truncate()
Origin: https://git.kernel.org/cgit/linux/kernel/git/tytso/ext4.git/commit/?id=94eec0fc3520c759831763d866421b4d60b599b4
We tested for ENOMEM instead of -ENOMEM. Oops.
Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
Cc: stable@vger.kernel.org
---
--- a/fs/ext4/extents.c
+++ b/fs/ext4/extents.c
@@ -4389,7 +4389,7 @@ void ext4_ext_truncate(handle_t *handle,
retry:
err = ext4_es_remove_extent(inode, last_block,
EXT_MAX_BLOCKS - last_block);
- if (err == ENOMEM) {
+ if (err == -ENOMEM) {
cond_resched();
congestion_wait(BLK_RW_ASYNC, HZ/50);
goto retry;

View File

@ -112,3 +112,4 @@ bugfix/m68k/ethernat-kconfig.patch
debian/sparc-cpufreq-convince-genksyms-that-the-abi-didnt-change.patch
bugfix/all/nl80211-fix-another-nl80211_fam-attrbuf-race.patch
bugfix/all/ext4-fix-retry-handling-in-ext4_ext_truncate.patch