aufs: Update support patchset to aufs4.9-20170206

This commit is contained in:
Ben Hutchings 2017-02-07 00:48:26 +00:00
parent 6dfab36dd8
commit bfd586db54
4 changed files with 51 additions and 17 deletions

1
debian/changelog vendored
View File

@ -117,6 +117,7 @@ linux (4.9.8-1) UNRELEASED; urgency=medium
USB_CONFIGFS_F_{LB_SS,LS,UAC1,UAC2,MIDI,HID,UVC,PRINTER}, USB_ETH_RNDIS,
USB_FUNCTIONFS_{ETH,RNDIS,GENERIC} (thanks to Riku Voipio)
* [ppc64el] Disable IBMEBUS; this bus does not exist on POWER8 systems
* aufs: Update support patchset to aufs4.9-20170206
[ Roger Shimizu ]
* [armel] ARM: dts: orion5x-lschl: Fix model name

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Dec 16 21:28:57 2016 +0900
Date: Sat Feb 4 13:13:07 2017 +0900
Subject: aufs4.9 base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/0d8e71c28da317ec6371b6b95b46a70cefe13777
Origin: https://github.com/sfjro/aufs4-standalone/tree/ecd2bfe6f46f36658c9aef74fc43ac40e47f8438
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -100,7 +100,7 @@ diff --git a/fs/inode.c b/fs/inode.c
index 88110fd..9a9ba3a 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -1642,7 +1642,7 @@ int generic_update_time(struct inode *inode, struct timespec *time, int flags)
@@ -1642,7 +1642,7 @@ EXPORT_SYMBOL(generic_update_time);
* This does the actual work of updating an inodes time or version. Must have
* had called mnt_want_write() before calling this.
*/
@ -146,7 +146,7 @@ diff --git a/fs/splice.c b/fs/splice.c
index 5a7750b..28160a7 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -855,8 +855,8 @@ ssize_t generic_splice_sendpage(struct pipe_inode_info *pipe, struct file *out,
@@ -855,8 +855,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -170,11 +170,24 @@ index 5a7750b..28160a7 100644
{
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/fs/sync.c b/fs/sync.c
index 2a54c1f..7a5fa3f 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -27,7 +27,7 @@
* wait == 1 case since in that case write_inode() functions do
* sync_dirty_buffer() and thus effectively write one block at a time.
*/
-static int __sync_filesystem(struct super_block *sb, int wait)
+int __sync_filesystem(struct super_block *sb, int wait)
{
if (wait)
sync_inodes_sb(sb);
diff --git a/include/linux/file.h b/include/linux/file.h
index 7444f5f..bdac0be 100644
--- a/include/linux/file.h
+++ b/include/linux/file.h
@@ -19,6 +19,7 @@
@@ -19,6 +19,7 @@ struct dentry;
struct path;
extern struct file *alloc_file(struct path *, fmode_t mode,
const struct file_operations *fop);
@ -183,10 +196,10 @@ index 7444f5f..bdac0be 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index dc0478c..27c05e7 100644
index dc0478c..a02be40d 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1291,6 +1291,7 @@ struct fasync_struct {
@@ -1291,6 +1291,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -215,7 +228,7 @@ index dc0478c..27c05e7 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t __vfs_write(struct file *, const char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
@@ -2140,6 +2148,7 @@ extern int iterate_mounts(int (*)(struct vfsmount *, void *), void *,
@@ -2140,6 +2148,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
@ -223,11 +236,19 @@ index dc0478c..27c05e7 100644
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2419,6 +2428,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif
+extern int __sync_filesystem(struct super_block *, int);
extern int sync_filesystem(struct super_block *);
extern const struct file_operations def_blk_fops;
extern const struct file_operations def_chr_fops;
diff --git a/include/linux/splice.h b/include/linux/splice.h
index 00a2116..1f0a4a2 100644
--- a/include/linux/splice.h
+++ b/include/linux/splice.h
@@ -86,4 +86,10 @@ extern ssize_t splice_direct_to_actor(struct file *, struct splice_desc *,
@@ -86,4 +86,10 @@ extern void spd_release_page(struct splice_pipe_desc *, unsigned int);
extern const struct pipe_buf_operations page_cache_pipe_buf_ops;
extern const struct pipe_buf_operations default_pipe_buf_ops;

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Dec 16 21:28:57 2016 +0900
Date: Sat Jan 28 00:46:14 2017 +0900
Subject: aufs4.9 mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/0d8e71c28da317ec6371b6b95b46a70cefe13777
Origin: https://github.com/sfjro/aufs4-standalone/tree/ecd2bfe6f46f36658c9aef74fc43ac40e47f8438
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -41,7 +41,7 @@ diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index 35b92d8..5b981db 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -291,7 +291,10 @@ static int is_stack(struct proc_maps_private *priv,
@@ -291,7 +291,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -233,7 +233,7 @@ index 1af87c1..95b0ff4 100644
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2703,7 +2703,7 @@ int vm_munmap(unsigned long start, size_t len)
@@ -2703,7 +2703,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -242,7 +242,7 @@ index 1af87c1..95b0ff4 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2778,10 +2778,27 @@ int vm_munmap(unsigned long start, size_t len)
@@ -2778,10 +2778,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri Dec 16 21:28:57 2016 +0900
Date: Sat Feb 4 13:13:07 2017 +0900
Subject: aufs4.9 standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/0d8e71c28da317ec6371b6b95b46a70cefe13777
Origin: https://github.com/sfjro/aufs4-standalone/tree/ecd2bfe6f46f36658c9aef74fc43ac40e47f8438
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -252,11 +252,23 @@ index 28160a7..98c1902 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/sync.c b/fs/sync.c
index 7a5fa3f..c9b9d46 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -38,6 +38,7 @@ int __sync_filesystem(struct super_block *sb, int wait)
sb->s_op->sync_fs(sb, wait);
return __sync_blockdev(sb->s_bdev, wait);
}
+EXPORT_SYMBOL_GPL(__sync_filesystem);
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index 2d13b4e..41c2bcd 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -296,6 +296,7 @@ int __vfs_setxattr_noperm(struct dentry *dentry, const char *name,
@@ -296,6 +296,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,
*xattr_value = value;
return error;
}