[rt] random: Restore interrupt randomness dropped in 3.14.10-rt6

svn path=/dists/sid/linux/; revision=21527
This commit is contained in:
Ben Hutchings 2014-07-11 16:55:20 +00:00
parent 55480603b6
commit be84d813a5
2 changed files with 19 additions and 2 deletions

2
debian/changelog vendored
View File

@ -79,10 +79,10 @@ linux (3.14.12-1) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* [rt] Update to 3.14.10-rt7:
- random: Do not add randomness from threaded interrupts
- rtmutex: Resolve conflicts with changes in 3.14.10
- sched: Do not clear PF_NO_SETAFFINITY flag in select_fallback_rq()
- workqueue: Prevent deadlock/stall on RT
* [rt] random: Restore interrupt randomness dropped in 3.14.10-rt6
* [s390,s390x] Ignore ABI change in lowcore structure (fixes FTBFS)
* [m68k] block: Change IOSCHED_CFQ to built-in and make it the default
I/O scheduler, consistent with other architectures

View File

@ -10,7 +10,9 @@ entropy.
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Cc: stable-rt@vger.kernel.org
[bwh: Adjust context to apply on top of Debian ABI-maintaining patches]
[bwh:
- Adjust context to apply on top of Debian ABI-maintaining patches
- Restore interrupt randomness dropped in 3.14.10-rt6]
---
drivers/char/random.c | 11 +++++++----
include/linux/irqdesc.h | 1 +
@ -102,3 +104,18 @@ Cc: stable-rt@vger.kernel.org
if (!noirqdebug)
note_interrupt(irq, desc, retval);
--- a/kernel/irq/manage.c
+++ b/kernel/irq/manage.c
@@ -942,6 +942,12 @@ static int irq_thread(void *data)
if (action_ret == IRQ_HANDLED)
atomic_inc(&desc->threads_handled);
+#ifdef CONFIG_PREEMPT_RT_FULL
+ migrate_disable();
+ add_interrupt_randomness(action->irq, 0,
+ desc->random_ip ^ (unsigned long) action);
+ migrate_enable();
+#endif
wake_threads_waitq(desc);
}