aufs: Update support patchset to aufs4.x-rcN-20170410

This commit is contained in:
Ben Hutchings 2017-04-20 01:48:49 +01:00
parent 327c328b54
commit be339ddfdd
4 changed files with 92 additions and 89 deletions

3
debian/changelog vendored
View File

@ -3,6 +3,9 @@ linux (4.11~rc7-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate (thanks to Lukas Wunner for rebasing
up to 4.11-rc6)
[ Ben Hutchings ]
* aufs: Update support patchset to aufs4.x-rcN-20170410
-- Lukas Wunner <lukas@wunner.de> Sun, 16 Apr 2017 16:09:27 +0200
linux (4.10.7-1~exp1) experimental; urgency=medium

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Feb 4 13:13:44 2017 +0900
Date: Sun Apr 9 15:04:59 2017 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/6c73f3b7652b011dfd536a99fd130b68e29fda72
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b79654aa362e9dad036a99ccf5880bbea6d6db8
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -9,10 +9,10 @@ Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 5f10c28..3fc9d68 100644
index 1b0a87f..76fd7cc 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2308,6 +2308,19 @@ F: include/linux/audit.h
@@ -2319,6 +2319,19 @@ F: include/linux/audit.h
F: include/uapi/linux/audit.h
F: kernel/audit*
@ -33,7 +33,7 @@ index 5f10c28..3fc9d68 100644
M: Miguel Ojeda Sandonis <miguel.ojeda.sandonis@gmail.com>
W: http://miguelojeda.es/auxdisplay.htm
diff --git a/drivers/block/loop.c b/drivers/block/loop.c
index f347285..b63f68b 100644
index 0ecb646..cf39138 100644
--- a/drivers/block/loop.c
+++ b/drivers/block/loop.c
@@ -701,6 +701,24 @@ static inline int is_loop_device(struct file *file)
@ -75,10 +75,10 @@ index 95d71ed..8ca5f09 100644
void (*finish)(void *))
{
diff --git a/fs/fcntl.c b/fs/fcntl.c
index e1c54f2..9f07008 100644
index be8fbe2..f5f4f94 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -29,7 +29,7 @@
@@ -30,7 +30,7 @@
#define SETFL_MASK (O_APPEND | O_NONBLOCK | O_NDELAY | O_DIRECT | O_NOATIME)
@ -87,7 +87,7 @@ index e1c54f2..9f07008 100644
{
struct inode * inode = file_inode(filp);
int error = 0;
@@ -60,6 +60,8 @@ static int setfl(int fd, struct file * filp, unsigned long arg)
@@ -61,6 +61,8 @@ static int setfl(int fd, struct file * filp, unsigned long arg)
if (filp->f_op->check_flags)
error = filp->f_op->check_flags(arg);
@ -110,10 +110,10 @@ index 88110fd..9a9ba3a 100644
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/read_write.c b/fs/read_write.c
index 5816d4c..670b365 100644
index c4f88af..ac71b96 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -515,6 +515,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@@ -513,6 +513,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
}
EXPORT_SYMBOL(__vfs_write);
@ -143,10 +143,10 @@ index 5816d4c..670b365 100644
{
mm_segment_t old_fs;
diff --git a/fs/splice.c b/fs/splice.c
index 873d831..7899532 100644
index 006ba50..46c87af 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -856,8 +856,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@@ -859,8 +859,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
/*
* Attempt to initiate a splice from pipe to file.
*/
@ -157,7 +157,7 @@ index 873d831..7899532 100644
{
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *,
loff_t *, size_t, unsigned int);
@@ -873,9 +873,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -876,9 +876,9 @@ static long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
/*
* Attempt to initiate a splice from a file to a pipe.
*/
@ -171,7 +171,7 @@ index 873d831..7899532 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/fs/sync.c b/fs/sync.c
index 2a54c1f..7a5fa3f 100644
index 11ba023..abf6a5d 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -27,7 +27,7 @@
@ -196,10 +196,10 @@ index 61eb82c..e700888 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 2ba0743..d1c583b 100644
index 7251f7b..3668627 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1240,6 +1240,7 @@ extern void fasync_free(struct fasync_struct *);
@@ -1246,6 +1246,7 @@ extern void fasync_free(struct fasync_struct *);
/* can be called from interrupts */
extern void kill_fasync(struct fasync_struct **, int, int);
@ -207,7 +207,7 @@ index 2ba0743..d1c583b 100644
extern void __f_setown(struct file *filp, struct pid *, enum pid_type, int force);
extern void f_setown(struct file *filp, unsigned long arg, int force);
extern void f_delown(struct file *filp);
@@ -1664,6 +1665,7 @@ struct file_operations {
@@ -1673,6 +1674,7 @@ struct file_operations {
ssize_t (*sendpage) (struct file *, struct page *, int, size_t, loff_t *, int);
unsigned long (*get_unmapped_area)(struct file *, unsigned long, unsigned long, unsigned long, unsigned long);
int (*check_flags)(int);
@ -215,7 +215,7 @@ index 2ba0743..d1c583b 100644
int (*flock) (struct file *, int, struct file_lock *);
ssize_t (*splice_write)(struct pipe_inode_info *, struct file *, loff_t *, size_t, unsigned int);
ssize_t (*splice_read)(struct file *, loff_t *, struct pipe_inode_info *, size_t, unsigned int);
@@ -1717,6 +1719,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
@@ -1749,6 +1751,12 @@ ssize_t rw_copy_check_uvector(int type, const struct iovec __user * uvector,
struct iovec *fast_pointer,
struct iovec **ret_pointer);
@ -228,7 +228,7 @@ index 2ba0743..d1c583b 100644
extern ssize_t __vfs_read(struct file *, char __user *, size_t, loff_t *);
extern ssize_t __vfs_write(struct file *, const char __user *, size_t, loff_t *);
extern ssize_t vfs_read(struct file *, char __user *, size_t, loff_t *);
@@ -2108,6 +2116,7 @@ extern int current_umask(void);
@@ -2127,6 +2135,7 @@ extern int current_umask(void);
extern void ihold(struct inode * inode);
extern void iput(struct inode *);
extern int generic_update_time(struct inode *, struct timespec *, int);
@ -236,7 +236,7 @@ index 2ba0743..d1c583b 100644
/* /sys/fs */
extern struct kobject *fs_kobj;
@@ -2387,6 +2396,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
@@ -2407,6 +2416,7 @@ static inline bool sb_is_blkdev_sb(struct super_block *sb)
return false;
}
#endif

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Feb 4 13:13:44 2017 +0900
Date: Sun Apr 9 15:04:59 2017 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/6c73f3b7652b011dfd536a99fd130b68e29fda72
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b79654aa362e9dad036a99ccf5880bbea6d6db8
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -9,10 +9,10 @@ Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index 87c9a9a..a0196f0 100644
index c87b6b9..6b71643 100644
--- a/fs/proc/base.c
+++ b/fs/proc/base.c
@@ -1958,7 +1958,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
@@ -1946,7 +1946,7 @@ static int map_files_get_link(struct dentry *dentry, struct path *path)
down_read(&mm->mmap_sem);
vma = find_exact_vma(mm, vm_start, vm_end);
if (vma && vma->vm_file) {
@ -38,10 +38,10 @@ index 7563437..7c0dc0f 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index 8f96a49..0d10404 100644
index f08bd31..e1b9a37 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -291,7 +291,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@@ -292,7 +292,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
const char *name = NULL;
if (file) {
@ -53,7 +53,7 @@ index 8f96a49..0d10404 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1628,7 +1631,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1629,7 +1632,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -63,10 +63,10 @@ index 8f96a49..0d10404 100644
struct mm_walk walk = {
.hugetlb_entry = gather_hugetlb_stats,
diff --git a/fs/proc/task_nommu.c b/fs/proc/task_nommu.c
index 3717562..6a328f1 100644
index 23266694..58e59b6 100644
--- a/fs/proc/task_nommu.c
+++ b/fs/proc/task_nommu.c
@@ -155,7 +155,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
@@ -157,7 +157,10 @@ static int nommu_vma_show(struct seq_file *m, struct vm_area_struct *vma,
file = vma->vm_file;
if (file) {
@ -79,10 +79,10 @@ index 3717562..6a328f1 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index b84615b..3978a35 100644
index 00a8fa7..a90742b 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1257,6 +1257,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
@@ -1294,6 +1294,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
}
#endif
@ -112,10 +112,10 @@ index b84615b..3978a35 100644
unsigned int gup_flags);
extern int access_remote_vm(struct mm_struct *mm, unsigned long addr,
diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
index 808751d..66fc765 100644
index f60f45f..38c5f76 100644
--- a/include/linux/mm_types.h
+++ b/include/linux/mm_types.h
@@ -275,6 +275,7 @@ struct vm_region {
@@ -259,6 +259,7 @@ struct vm_region {
unsigned long vm_top; /* region allocated to here */
unsigned long vm_pgoff; /* the offset in vm_file corresponding to vm_start */
struct file *vm_file; /* the backing file or NULL */
@ -123,7 +123,7 @@ index 808751d..66fc765 100644
int vm_usage; /* region usage count (access under nommu_region_sem) */
bool vm_icache_flushed : 1; /* true if the icache has been flushed for
@@ -349,6 +350,7 @@ struct vm_area_struct {
@@ -333,6 +334,7 @@ struct vm_area_struct {
unsigned long vm_pgoff; /* Offset (within vm_file) in PAGE_SIZE
units */
struct file * vm_file; /* File we map to (can be NULL). */
@ -132,10 +132,10 @@ index 808751d..66fc765 100644
#ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index 11c5c8a..48e7ef7 100644
index 6c463c80..24ae37c 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -626,7 +626,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
@@ -641,7 +641,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
struct inode *inode = file_inode(file);
struct address_space *mapping = file->f_mapping;
@ -145,10 +145,10 @@ index 11c5c8a..48e7ef7 100644
atomic_dec(&inode->i_writecount);
i_mmap_lock_write(mapping);
diff --git a/mm/Makefile b/mm/Makefile
index 295bd7a..14fa1c8 100644
index 026f6a8..723da17 100644
--- a/mm/Makefile
+++ b/mm/Makefile
@@ -37,7 +37,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
@@ -39,7 +39,7 @@ obj-y := filemap.o mempool.o oom_kill.o \
mm_init.o mmu_context.o percpu.o slab_common.o \
compaction.o vmacache.o swap_slots.o \
interval_tree.o list_lru.o workingset.o \
@ -158,10 +158,10 @@ index 295bd7a..14fa1c8 100644
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index b772a33..1c11f45 100644
index 1694623..68cd758 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2392,7 +2392,7 @@ int filemap_page_mkwrite(struct vm_area_struct *vma, struct vm_fault *vmf)
@@ -2406,7 +2406,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
int ret = VM_FAULT_LOCKED;
sb_start_pagefault(inode->i_sb);
@ -171,7 +171,7 @@ index b772a33..1c11f45 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index dc4291d..4b3a2aa 100644
index bfbe885..8bd32f9 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -170,7 +170,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
@ -183,7 +183,7 @@ index dc4291d..4b3a2aa 100644
mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma);
return next;
@@ -879,7 +879,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
@@ -881,7 +881,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -192,7 +192,7 @@ index dc4291d..4b3a2aa 100644
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1727,8 +1727,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
@@ -1731,8 +1731,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
return addr;
unmap_and_free_vma:
@ -202,7 +202,7 @@ index dc4291d..4b3a2aa 100644
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2533,7 +2533,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2537,7 +2537,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -211,7 +211,7 @@ index dc4291d..4b3a2aa 100644
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2552,7 +2552,7 @@ static int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2556,7 +2556,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -220,7 +220,7 @@ index dc4291d..4b3a2aa 100644
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2703,7 +2703,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2710,7 +2710,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -229,7 +229,7 @@ index dc4291d..4b3a2aa 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2778,10 +2778,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2785,10 +2785,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -258,7 +258,7 @@ index dc4291d..4b3a2aa 100644
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3056,7 +3073,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
@@ -3079,7 +3096,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -268,10 +268,10 @@ index dc4291d..4b3a2aa 100644
new_vma->vm_ops->open(new_vma);
vma_link(mm, new_vma, prev, rb_link, rb_parent);
diff --git a/mm/nommu.c b/mm/nommu.c
index 24f9f5f..ac0d37a 100644
index 2d131b9..5dc9a19 100644
--- a/mm/nommu.c
+++ b/mm/nommu.c
@@ -636,7 +636,7 @@ static void __put_nommu_region(struct vm_region *region)
@@ -637,7 +637,7 @@ static void __put_nommu_region(struct vm_region *region)
up_write(&nommu_region_sem);
if (region->vm_file)
@ -280,7 +280,7 @@ index 24f9f5f..ac0d37a 100644
/* IO memory and memory shared directly out of the pagecache
* from ramfs/tmpfs mustn't be released here */
@@ -794,7 +794,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
@@ -795,7 +795,7 @@ static void delete_vma(struct mm_struct *mm, struct vm_area_struct *vma)
if (vma->vm_ops && vma->vm_ops->close)
vma->vm_ops->close(vma);
if (vma->vm_file)
@ -289,7 +289,7 @@ index 24f9f5f..ac0d37a 100644
put_nommu_region(vma->vm_region);
kmem_cache_free(vm_area_cachep, vma);
}
@@ -1320,7 +1320,7 @@ unsigned long do_mmap(struct file *file,
@@ -1322,7 +1322,7 @@ unsigned long do_mmap(struct file *file,
goto error_just_free;
}
}
@ -298,7 +298,7 @@ index 24f9f5f..ac0d37a 100644
kmem_cache_free(vm_region_jar, region);
region = pregion;
result = start;
@@ -1395,10 +1395,10 @@ unsigned long do_mmap(struct file *file,
@@ -1397,10 +1397,10 @@ unsigned long do_mmap(struct file *file,
up_write(&nommu_region_sem);
error:
if (region->vm_file)

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat Feb 4 13:13:44 2017 +0900
Date: Wed Mar 8 01:39:21 2017 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/6c73f3b7652b011dfd536a99fd130b68e29fda72
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b79654aa362e9dad036a99ccf5880bbea6d6db8
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
@ -29,10 +29,10 @@ index 8ca5f09..b1ff5be 100644
/**
* d_ancestor - search for an ancestor
diff --git a/fs/exec.c b/fs/exec.c
index e579466..2566b16 100644
index 65145a3..8d35776 100644
--- a/fs/exec.c
+++ b/fs/exec.c
@@ -104,6 +104,7 @@ bool path_noexec(const struct path *path)
@@ -109,6 +109,7 @@ bool path_noexec(const struct path *path)
return (path->mnt->mnt_flags & MNT_NOEXEC) ||
(path->mnt->mnt_sb->s_iflags & SB_I_NOEXEC);
}
@ -41,10 +41,10 @@ index e579466..2566b16 100644
#ifdef CONFIG_USELIB
/*
diff --git a/fs/fcntl.c b/fs/fcntl.c
index 9f07008..d60b682 100644
index f5f4f94..c671660 100644
--- a/fs/fcntl.c
+++ b/fs/fcntl.c
@@ -82,6 +82,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
@@ -83,6 +83,7 @@ int setfl(int fd, struct file * filp, unsigned long arg)
out:
return error;
}
@ -53,10 +53,10 @@ index 9f07008..d60b682 100644
static void f_modown(struct file *filp, struct pid *pid, enum pid_type type,
int force)
diff --git a/fs/file_table.c b/fs/file_table.c
index 6d982b5..9a3c6c8 100644
index 954d510..4fb5b10 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -147,6 +147,7 @@ struct file *get_empty_filp(void)
@@ -148,6 +148,7 @@ struct file *get_empty_filp(void)
}
return ERR_PTR(-ENFILE);
}
@ -64,7 +64,7 @@ index 6d982b5..9a3c6c8 100644
/**
* alloc_file - allocate and initialize a 'struct file'
@@ -258,6 +259,7 @@ void flush_delayed_fput(void)
@@ -259,6 +260,7 @@ void flush_delayed_fput(void)
{
delayed_fput(NULL);
}
@ -72,7 +72,7 @@ index 6d982b5..9a3c6c8 100644
static DECLARE_DELAYED_WORK(delayed_fput_work, delayed_fput);
@@ -300,6 +302,7 @@ void __fput_sync(struct file *file)
@@ -301,6 +303,7 @@ void __fput_sync(struct file *file)
}
EXPORT_SYMBOL(fput);
@ -80,7 +80,7 @@ index 6d982b5..9a3c6c8 100644
void put_filp(struct file *file)
{
@@ -308,6 +311,7 @@ void put_filp(struct file *file)
@@ -309,6 +312,7 @@ void put_filp(struct file *file)
file_free(file);
}
}
@ -101,10 +101,10 @@ index 9a9ba3a..a3a18d8 100644
/**
* touch_atime - update the access time
diff --git a/fs/namespace.c b/fs/namespace.c
index 487ba30..642069d 100644
index cc1375ef..9b4c67c 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -462,6 +462,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
@@ -465,6 +465,7 @@ void __mnt_drop_write(struct vfsmount *mnt)
mnt_dec_writers(real_mount(mnt));
preempt_enable();
}
@ -112,7 +112,7 @@ index 487ba30..642069d 100644
/**
* mnt_drop_write - give up write access to a mount
@@ -1872,6 +1873,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1884,6 +1885,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -193,7 +193,7 @@ index 6043306..fdb50e4 100644
/*
* Destroy all marks in destroy_list, waits for SRCU period to finish before
diff --git a/fs/open.c b/fs/open.c
index 9921f70..80d94c0 100644
index 949cef2..9a892fb8 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -64,6 +64,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -204,7 +204,7 @@ index 9921f70..80d94c0 100644
long vfs_truncate(const struct path *path, loff_t length)
{
@@ -695,6 +696,7 @@ int open_check_o_direct(struct file *f)
@@ -693,6 +694,7 @@ int open_check_o_direct(struct file *f)
}
return 0;
}
@ -213,10 +213,10 @@ index 9921f70..80d94c0 100644
static int do_dentry_open(struct file *f,
struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index 670b365..f9f8bb1 100644
index ac71b96..b69e687 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -525,6 +525,7 @@ vfs_readf_t vfs_readf(struct file *file)
@@ -523,6 +523,7 @@ vfs_readf_t vfs_readf(struct file *file)
return new_sync_read;
return ERR_PTR(-ENOSYS);
}
@ -224,7 +224,7 @@ index 670b365..f9f8bb1 100644
vfs_writef_t vfs_writef(struct file *file)
{
@@ -536,6 +537,7 @@ vfs_writef_t vfs_writef(struct file *file)
@@ -534,6 +535,7 @@ vfs_writef_t vfs_writef(struct file *file)
return new_sync_write;
return ERR_PTR(-ENOSYS);
}
@ -233,10 +233,10 @@ index 670b365..f9f8bb1 100644
ssize_t __kernel_write(struct file *file, const char *buf, size_t count, loff_t *pos)
{
diff --git a/fs/splice.c b/fs/splice.c
index 7899532..c0df111 100644
index 46c87af..0efa652 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -869,6 +869,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@@ -872,6 +872,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
return splice_write(pipe, out, ppos, len, flags);
}
@ -244,7 +244,7 @@ index 7899532..c0df111 100644
/*
* Attempt to initiate a splice from a file to a pipe.
@@ -898,6 +899,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
@@ -901,6 +902,7 @@ long do_splice_to(struct file *in, loff_t *ppos,
return splice_read(in, ppos, pipe, len, flags);
}
@ -253,7 +253,7 @@ index 7899532..c0df111 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/fs/sync.c b/fs/sync.c
index 7a5fa3f..c9b9d46 100644
index abf6a5d..c86fe9c 100644
--- a/fs/sync.c
+++ b/fs/sync.c
@@ -38,6 +38,7 @@ int __sync_filesystem(struct super_block *sb, int wait)
@ -286,10 +286,10 @@ index d513051..e056d54 100644
}
+EXPORT_SYMBOL_GPL(task_work_run);
diff --git a/security/commoncap.c b/security/commoncap.c
index 8df676f..6b5cc07 100644
index 78b3783..c8b3e88 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -1061,12 +1061,14 @@ int cap_mmap_addr(unsigned long addr)
@@ -1062,12 +1062,14 @@ int cap_mmap_addr(unsigned long addr)
}
return ret;
}
@ -325,10 +325,10 @@ index 03c1652..f88c84b 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index f825304..8dd441d 100644
index d0e07f2..5e323b0 100644
--- a/security/security.c
+++ b/security/security.c
@@ -443,6 +443,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
@@ -481,6 +481,7 @@ int security_path_rmdir(const struct path *dir, struct dentry *dentry)
return 0;
return call_int_hook(path_rmdir, 0, dir, dentry);
}
@ -336,7 +336,7 @@ index f825304..8dd441d 100644
int security_path_unlink(const struct path *dir, struct dentry *dentry)
{
@@ -459,6 +460,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
@@ -497,6 +498,7 @@ int security_path_symlink(const struct path *dir, struct dentry *dentry,
return 0;
return call_int_hook(path_symlink, 0, dir, dentry, old_name);
}
@ -344,7 +344,7 @@ index f825304..8dd441d 100644
int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
struct dentry *new_dentry)
@@ -467,6 +469,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
@@ -505,6 +507,7 @@ int security_path_link(struct dentry *old_dentry, const struct path *new_dir,
return 0;
return call_int_hook(path_link, 0, old_dentry, new_dir, new_dentry);
}
@ -352,7 +352,7 @@ index f825304..8dd441d 100644
int security_path_rename(const struct path *old_dir, struct dentry *old_dentry,
const struct path *new_dir, struct dentry *new_dentry,
@@ -494,6 +497,7 @@ int security_path_truncate(const struct path *path)
@@ -532,6 +535,7 @@ int security_path_truncate(const struct path *path)
return 0;
return call_int_hook(path_truncate, 0, path);
}
@ -360,7 +360,7 @@ index f825304..8dd441d 100644
int security_path_chmod(const struct path *path, umode_t mode)
{
@@ -501,6 +505,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
@@ -539,6 +543,7 @@ int security_path_chmod(const struct path *path, umode_t mode)
return 0;
return call_int_hook(path_chmod, 0, path, mode);
}
@ -368,7 +368,7 @@ index f825304..8dd441d 100644
int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
{
@@ -508,6 +513,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
@@ -546,6 +551,7 @@ int security_path_chown(const struct path *path, kuid_t uid, kgid_t gid)
return 0;
return call_int_hook(path_chown, 0, path, uid, gid);
}
@ -376,7 +376,7 @@ index f825304..8dd441d 100644
int security_path_chroot(const struct path *path)
{
@@ -593,6 +599,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -631,6 +637,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return call_int_hook(inode_readlink, 0, dentry);
}
@ -384,7 +384,7 @@ index f825304..8dd441d 100644
int security_inode_follow_link(struct dentry *dentry, struct inode *inode,
bool rcu)
@@ -608,6 +615,7 @@ int security_inode_permission(struct inode *inode, int mask)
@@ -646,6 +653,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return call_int_hook(inode_permission, 0, inode, mask);
}
@ -392,7 +392,7 @@ index f825304..8dd441d 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -779,6 +787,7 @@ int security_file_permission(struct file *file, int mask)
@@ -817,6 +825,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -400,7 +400,7 @@ index f825304..8dd441d 100644
int security_file_alloc(struct file *file)
{
@@ -838,6 +847,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
@@ -876,6 +885,7 @@ int security_mmap_file(struct file *file, unsigned long prot,
return ret;
return ima_file_mmap(file, prot);
}