[arm64] Enable reboot on the Xgene platform.

svn path=/dists/sid/linux/; revision=22088
This commit is contained in:
Ian Campbell 2014-11-27 10:16:00 +00:00
parent 8b698c4c58
commit bdd670cb8d
4 changed files with 76 additions and 0 deletions

1
debian/changelog vendored
View File

@ -20,6 +20,7 @@ linux (3.16.7-3) UNRELEASED; urgency=medium
Vagrant Cascadian (Closes: #770635)
* [device-tree] Reserve memreserve regions even if they partially overlap
with an existing reservation. Fixes boot on Midway.
* [arm64] Enable reboot on the Xgene platform.
-- Ben Hutchings <ben@decadent.org.uk> Sun, 09 Nov 2014 10:13:09 +0000

View File

@ -0,0 +1,36 @@
From 2d209a4c68627218140f29ca31ee1f01ce476b89 Mon Sep 17 00:00:00 2001
From: Ian Campbell <ijc@hellion.org.uk>
Date: Wed, 26 Nov 2014 15:30:03 +0000
Subject: [PATCH 1/2] arm64: add missing dts entry for X-Gene platform.
Origin: http://lists.infradead.org/pipermail/linux-arm-kernel/2013-December/216347.html
This add missing dts entry for X-Gene reboot driver.
Signed-off-by: Feng Kan <fkan at apm.com>
ijc -- obsoleted by upstream syscon-reboot driver reworking, but that is too
big to backport.
---
arch/arm64/boot/dts/apm-storm.dtsi | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/arch/arm64/boot/dts/apm-storm.dtsi b/arch/arm64/boot/dts/apm-storm.dtsi
index e2af321..0d796ad 100644
--- a/arch/arm64/boot/dts/apm-storm.dtsi
+++ b/arch/arm64/boot/dts/apm-storm.dtsi
@@ -302,6 +302,11 @@
interrupts = <0x0 0x4c 0x4>;
};
+ reboot@17000014 {
+ compatible = "apm,xgene-reboot";
+ reg = <0x0 0x17000014 0x0 0x4>;
+ };
+
serial1: serial@1c021000 {
status = "disabled";
device_type = "serial";
--
2.1.3

View File

@ -0,0 +1,37 @@
From b2553d6241a68e991e59c0a99857ae6ac21a67a8 Mon Sep 17 00:00:00 2001
From: Ian Campbell <ijc@hellion.org.uk>
Date: Wed, 26 Nov 2014 15:31:50 +0000
Subject: [PATCH 2/2] arm64: removed using of the mask attribute in the dts for
reset bit.
Origin: http://lists.infradead.org/pipermail/linux-arm-kernel/2013-December/216350.html
Remove the use of the mask attribute from original reboot driver. The use
of the mask attribute provided unneeded complexity and security risk. Also
fix minor compilation warning.
Signed-off-by: Feng Kan <fkan at apm.com>
ijc -- obsoleted by upstream syscon-reboot driver reworking, but that is too
big to backport.
---
drivers/power/reset/xgene-reboot.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/power/reset/xgene-reboot.c b/drivers/power/reset/xgene-reboot.c
index ecd55f8..4a63f8f 100644
--- a/drivers/power/reset/xgene-reboot.c
+++ b/drivers/power/reset/xgene-reboot.c
@@ -73,8 +73,7 @@ static int xgene_reboot_probe(struct platform_device *pdev)
return -ENODEV;
}
- if (of_property_read_u32(pdev->dev.of_node, "mask", &ctx->mask))
- ctx->mask = 0xFFFFFFFF;
+ ctx->mask = 0x1;
ctx->pdev = pdev;
arm_pm_restart = xgene_restart;
--
2.1.3

View File

@ -68,6 +68,8 @@ bugfix/x86/KVM-x86-Emulator-fixes-for-eip-canonical-checks-on-n.patch
bugfix/x86/KVM-x86-Handle-errors-when-RIP-is-set-during-far-jum.patch
bugfix/x86/kvm-x86-fix-far-jump-to-non-canonical-check.patch
bugfix/parisc/parisc-reduce-sigrtmin-from-37-to-32-to-behave-like-.patch
bugfix/arm64/arm64-add-missing-dts-entry-for-X-Gene-platform.patch
bugfix/arm64/arm64-removed-using-of-the-mask-attribute-in-the-dts.patch
# Arch features
features/mips/MIPS-Support-hard-limit-of-cpu-count-nr_cpu_ids.patch