bridge: Fix ABI change in 4.6.4

This commit is contained in:
Ben Hutchings 2016-07-14 00:33:12 +01:00
parent f000506362
commit bd2f2b2ea4
3 changed files with 28 additions and 0 deletions

3
debian/changelog vendored
View File

@ -39,6 +39,9 @@ linux (4.6.4-1) UNRELEASED; urgency=medium
* apparmor: fix oops, validate buffer size in apparmor_setprocattr()
(CVE-2016-6187)
[ Ben Hutchings ]
* bridge: Fix ABI change in 4.6.4
-- Uwe Kleine-König <ukleinek@debian.org> Sun, 10 Jul 2016 15:25:48 +0200
linux (4.6.3-1) unstable; urgency=medium

View File

@ -0,0 +1,24 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 14 Jul 2016 00:30:57 +0100
Subject: bridge: Fix ABI change in 4.6.4
Forwarded: not-needed
Although this structure is private, it affects the symbol version for
br_deliver() which is called from a netfilter module
Hide the new bitfield from genksyms.
---
--- a/net/bridge/br_private.h
+++ b/net/bridge/br_private.h
@@ -304,7 +304,10 @@ struct net_bridge
u8 multicast_disabled:1;
u8 multicast_querier:1;
u8 multicast_query_use_ifaddr:1;
+#ifndef __GENKSYMS__
u8 has_ipv6_addr:1;
+ /* 4 bits padding */
+#endif
u32 hash_elasticity;
u32 hash_max;

View File

@ -119,6 +119,7 @@ bugfix/all/apparmor-fix-oops-validate-buffer-size-in-apparmor_s.patch
# ABI maintenance
debian/mips-siginfo-fix-abi-change-in-4.6.2.patch
debian/mips-libgcc-fix-abi-change-in-4.6.2.patch
debian/bridge-fix-abi-change-in-4.6.4.patch
# Tools bug fixes
bugfix/all/usbip-document-tcp-wrappers.patch