aufs: Update support patchset to aufs4.11.7+-20170703 (Closes: #867257)

This commit is contained in:
Ben Hutchings 2017-07-16 23:39:47 +01:00
parent abb94a6a73
commit bd04387e13
4 changed files with 37 additions and 37 deletions

1
debian/changelog vendored
View File

@ -270,6 +270,7 @@ linux (4.11.11-1) UNRELEASED; urgency=medium
* crypto: Enable CRYPTO_USER, CRYPTO_USER_API_RNG as modules (Closes: #868291)
* udeb: Add dm-raid to md-modules (Closes: #868251)
* [arm64] sound: Enable SND_HDA_INTEL as module (Closes: #867611)
* aufs: Update support patchset to aufs4.11.7+-20170703 (Closes: #867257)
[ Uwe Kleine-König ]
* [arm64] enable FB_SIMPLE

View File

@ -1,15 +1,15 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sun Apr 9 15:04:59 2017 +0900
Subject: aufs4.x-rcN base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b79654aa362e9dad036a99ccf5880bbea6d6db8
Date: Fri Jun 30 21:04:46 2017 +0900
Subject: aufs4.11.7+ base patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/71715aa10d57ea34fedae6c2aa1b7ab5a12fd967
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN base patch
aufs4.11.7+ base patch
diff --git a/MAINTAINERS b/MAINTAINERS
index 1b0a87f..76fd7cc 100644
index 38d3e4e..c2b31bf 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -2319,6 +2319,19 @@ F: include/linux/audit.h
@ -110,7 +110,7 @@ index 88110fd..9a9ba3a 100644
int (*update_time)(struct inode *, struct timespec *, int);
diff --git a/fs/read_write.c b/fs/read_write.c
index c4f88af..ac71b96 100644
index f77eb22..eba4e7e 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -513,6 +513,28 @@ ssize_t __vfs_write(struct file *file, const char __user *p, size_t count,
@ -196,7 +196,7 @@ index 61eb82c..e700888 100644
static inline void fput_light(struct file *file, int fput_needed)
{
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 7251f7b..3668627 100644
index 7415630..433e314 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -1246,6 +1246,7 @@ extern void fasync_free(struct fasync_struct *);

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sun Apr 9 15:04:59 2017 +0900
Subject: aufs4.x-rcN mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b79654aa362e9dad036a99ccf5880bbea6d6db8
Date: Fri Jun 30 21:04:46 2017 +0900
Subject: aufs4.11.7+ mmap patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/71715aa10d57ea34fedae6c2aa1b7ab5a12fd967
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN mmap patch
aufs4.11.7+ mmap patch
diff --git a/fs/proc/base.c b/fs/proc/base.c
index c87b6b9..6b71643 100644
@ -38,7 +38,7 @@ index 7563437..7c0dc0f 100644
ino = inode->i_ino;
}
diff --git a/fs/proc/task_mmu.c b/fs/proc/task_mmu.c
index f08bd31..e1b9a37 100644
index f401682..79ea96a 100644
--- a/fs/proc/task_mmu.c
+++ b/fs/proc/task_mmu.c
@@ -292,7 +292,10 @@ show_map_vma(struct seq_file *m, struct vm_area_struct *vma, int is_pid)
@ -53,7 +53,7 @@ index f08bd31..e1b9a37 100644
dev = inode->i_sb->s_dev;
ino = inode->i_ino;
pgoff = ((loff_t)vma->vm_pgoff) << PAGE_SHIFT;
@@ -1629,7 +1632,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
@@ -1632,7 +1635,7 @@ static int show_numa_map(struct seq_file *m, void *v, int is_pid)
struct proc_maps_private *proc_priv = &numa_priv->proc_maps;
struct vm_area_struct *vma = v;
struct numa_maps *md = &numa_priv->md;
@ -79,7 +79,7 @@ index 23266694..58e59b6 100644
ino = inode->i_ino;
pgoff = (loff_t)vma->vm_pgoff << PAGE_SHIFT;
diff --git a/include/linux/mm.h b/include/linux/mm.h
index 00a8fa7..a90742b 100644
index cec423b..b6b2f901 100644
--- a/include/linux/mm.h
+++ b/include/linux/mm.h
@@ -1294,6 +1294,28 @@ static inline int fixup_user_fault(struct task_struct *tsk,
@ -132,7 +132,7 @@ index f60f45f..38c5f76 100644
#ifndef CONFIG_MMU
diff --git a/kernel/fork.c b/kernel/fork.c
index 6c463c80..24ae37c 100644
index 4f7151d..ebe8415 100644
--- a/kernel/fork.c
+++ b/kernel/fork.c
@@ -641,7 +641,7 @@ static __latent_entropy int dup_mmap(struct mm_struct *mm,
@ -158,7 +158,7 @@ index 026f6a8..723da17 100644
obj-y += init-mm.o
diff --git a/mm/filemap.c b/mm/filemap.c
index 1694623..68cd758 100644
index 157c047..0cf15d2 100644
--- a/mm/filemap.c
+++ b/mm/filemap.c
@@ -2406,7 +2406,7 @@ int filemap_page_mkwrite(struct vm_fault *vmf)
@ -171,7 +171,7 @@ index 1694623..68cd758 100644
if (page->mapping != inode->i_mapping) {
unlock_page(page);
diff --git a/mm/mmap.c b/mm/mmap.c
index bfbe885..8bd32f9 100644
index cde1262..72ca169 100644
--- a/mm/mmap.c
+++ b/mm/mmap.c
@@ -170,7 +170,7 @@ static struct vm_area_struct *remove_vma(struct vm_area_struct *vma)
@ -183,7 +183,7 @@ index bfbe885..8bd32f9 100644
mpol_put(vma_policy(vma));
kmem_cache_free(vm_area_cachep, vma);
return next;
@@ -881,7 +881,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
@@ -895,7 +895,7 @@ int __vma_adjust(struct vm_area_struct *vma, unsigned long start,
if (remove_next) {
if (file) {
uprobe_munmap(next, next->vm_start, next->vm_end);
@ -192,7 +192,7 @@ index bfbe885..8bd32f9 100644
}
if (next->anon_vma)
anon_vma_merge(vma, next);
@@ -1731,8 +1731,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
@@ -1745,8 +1745,8 @@ unsigned long mmap_region(struct file *file, unsigned long addr,
return addr;
unmap_and_free_vma:
@ -202,7 +202,7 @@ index bfbe885..8bd32f9 100644
/* Undo any partial mapping done by a device driver. */
unmap_region(mm, vma, prev, vma->vm_start, vma->vm_end);
@@ -2537,7 +2537,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2571,7 +2571,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
goto out_free_mpol;
if (new->vm_file)
@ -211,7 +211,7 @@ index bfbe885..8bd32f9 100644
if (new->vm_ops && new->vm_ops->open)
new->vm_ops->open(new);
@@ -2556,7 +2556,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
@@ -2590,7 +2590,7 @@ int __split_vma(struct mm_struct *mm, struct vm_area_struct *vma,
if (new->vm_ops && new->vm_ops->close)
new->vm_ops->close(new);
if (new->vm_file)
@ -220,7 +220,7 @@ index bfbe885..8bd32f9 100644
unlink_anon_vmas(new);
out_free_mpol:
mpol_put(vma_policy(new));
@@ -2710,7 +2710,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2744,7 +2744,7 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
struct vm_area_struct *vma;
unsigned long populate = 0;
unsigned long ret = -EINVAL;
@ -229,7 +229,7 @@ index bfbe885..8bd32f9 100644
pr_warn_once("%s (%d) uses deprecated remap_file_pages() syscall. See Documentation/vm/remap_file_pages.txt.\n",
current->comm, current->pid);
@@ -2785,10 +2785,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
@@ -2819,10 +2819,27 @@ SYSCALL_DEFINE5(remap_file_pages, unsigned long, start, unsigned long, size,
}
}
@ -258,7 +258,7 @@ index bfbe885..8bd32f9 100644
out:
up_write(&mm->mmap_sem);
if (populate)
@@ -3079,7 +3096,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
@@ -3113,7 +3130,7 @@ struct vm_area_struct *copy_vma(struct vm_area_struct **vmap,
if (anon_vma_clone(new_vma, vma))
goto out_free_mempol;
if (new_vma->vm_file)
@ -313,18 +313,18 @@ index 2d131b9..5dc9a19 100644
diff --git a/mm/prfile.c b/mm/prfile.c
new file mode 100644
index 0000000..b323b8a
index 0000000..1ef053b
--- /dev/null
+++ b/mm/prfile.c
@@ -0,0 +1,86 @@
@@ -0,0 +1,85 @@
+/*
+ * Mainly for aufs which mmap(2) diffrent file and wants to print different path
+ * in /proc/PID/maps.
+ * Mainly for aufs which mmap(2) different file and wants to print different
+ * path in /proc/PID/maps.
+ * Call these functions via macros defined in linux/mm.h.
+ *
+ * See Documentation/filesystems/aufs/design/06mmap.txt
+ *
+ * Copyright (c) 2014 Junjro R. Okajima
+ * Copyright (c) 2014-2017 Junjro R. Okajima
+ * Copyright (c) 2014 Ian Campbell
+ */
+
@ -338,8 +338,7 @@ index 0000000..b323b8a
+{
+#ifdef PRFILE_TRACE
+ if (pr)
+ pr_info("%s:%d: %s, %s\n", func, line, func2,
+ f ? (char *)f->f_path.dentry->d_name.name : "(null)");
+ pr_info("%s:%d: %s, %pD2\n", func, line, func2, f);
+#endif
+}
+

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Wed Mar 8 01:39:21 2017 +0900
Subject: aufs4.x-rcN standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/8b79654aa362e9dad036a99ccf5880bbea6d6db8
Date: Fri Jun 30 21:04:46 2017 +0900
Subject: aufs4.11.7+ standalone patch
Origin: https://github.com/sfjro/aufs4-standalone/tree/71715aa10d57ea34fedae6c2aa1b7ab5a12fd967
Bug-Debian: https://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs4/gen-patch
aufs4.x-rcN standalone patch
aufs4.11.7+ standalone patch
diff --git a/fs/dcache.c b/fs/dcache.c
index 8ca5f09..b1ff5be 100644
@ -213,7 +213,7 @@ index 949cef2..9a892fb8 100644
static int do_dentry_open(struct file *f,
struct inode *inode,
diff --git a/fs/read_write.c b/fs/read_write.c
index ac71b96..b69e687 100644
index eba4e7e..ec9e88a 100644
--- a/fs/read_write.c
+++ b/fs/read_write.c
@@ -523,6 +523,7 @@ vfs_readf_t vfs_readf(struct file *file)
@ -265,7 +265,7 @@ index abf6a5d..c86fe9c 100644
/*
* Write out and wait upon all dirty data associated with this
diff --git a/fs/xattr.c b/fs/xattr.c
index 7e3317c..88910fe 100644
index 94f49a0..243f57e 100644
--- a/fs/xattr.c
+++ b/fs/xattr.c
@@ -296,6 +296,7 @@ vfs_getxattr_alloc(struct dentry *dentry, const char *name, char **xattr_value,