Initialise framebuffer console earlier. (Closes: #779935)

svn path=/dists/sid/linux/; revision=22454
This commit is contained in:
Ian Campbell 2015-03-20 19:38:48 +00:00
parent 8a01e20b3f
commit bcd1494cdf
3 changed files with 43 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.16.7-ckt7-2) UNRELEASED; urgency=medium
[ Ian Campbell ]
* Initialise framebuffer console earlier. (Closes: #779935)
-- Ian Campbell <ijc@debian.org> Wed, 18 Mar 2015 21:07:15 +0000
linux (3.16.7-ckt7-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,35 @@
From ba168a3c7ff6df2e346959445190484b8331eb3d Mon Sep 17 00:00:00 2001
From: Hans de Goede <hdegoede@redhat.com>
Date: Fri, 14 Nov 2014 13:26:54 +0100
Subject: [PATCH] fbcon: Change fbcon_init from module_init to fs_initcall
Origin: https://git.kernel.org/linus/ba168a3c7ff6df2e346959445190484b8331eb3d
Various fb drivers register themselves before module_init so as to have a
console as early as possible, this is of little use if fbcon does not
initialize early too.
Fbcon cannot initialize earlier then fs_initcall, because then the creation
of /sys/class/graphics/fbcon will fail.
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ti.com>
---
drivers/video/console/fbcon.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/video/console/fbcon.c b/drivers/video/console/fbcon.c
index eb976ee..ea43724 100644
--- a/drivers/video/console/fbcon.c
+++ b/drivers/video/console/fbcon.c
@@ -3624,7 +3624,7 @@ static int __init fb_console_init(void)
return 0;
}
-module_init(fb_console_init);
+fs_initcall(fb_console_init);
#ifdef MODULE
--
2.1.4

View File

@ -218,6 +218,7 @@ features/all/simplefb-Add-support-for-enumerating-simplefb-dt-nod.patch
features/all/simplefb-Change-simplefb_init-from-module_init-to-fs.patch
features/all/simplefb-Fix-build-errors-when-CONFIG_COMMON_CLK-is-.patch
features/all/simplefb-Fix-build-failure-on-Sparc.patch
features/all/fbcon-Change-fbcon_init-from-module_init-to-fs_initc.patch
# Update r8723au to 3.17
features/all/r8723au/0001-staging-rtl8723au-rtw_get_wps_ie23a-Remove-unused-de.patch