Fix vserver build on ia64, s390

svn path=/dists/trunk/linux-2.6/; revision=14831
This commit is contained in:
dann frazier 2009-12-29 20:10:32 +00:00
parent ac4d38726d
commit bb0756f7e7
3 changed files with 50 additions and 0 deletions

3
debian/changelog vendored
View File

@ -9,6 +9,9 @@ linux-2.6 (2.6.32-4) UNRELEASED; urgency=low
SCSI_BFA_FC, USB_GL860, USB_GSPCA_JEILINJ, I2C_SI4713, RADIO_SI4713,
RADIO_SI470X, DVB_USB_FRIIO.
[ dann frazier ]
* Fix vserver build on ia64, s390
-- Ben Hutchings <ben@decadent.org.uk> Tue, 29 Dec 2009 15:32:44 +0100
linux-2.6 (2.6.32-3) unstable; urgency=high

View File

@ -0,0 +1,46 @@
diff -urpN a/arch/s390/include/asm/unistd.h b/arch/s390/include/asm/unistd.h
--- a/arch/s390/include/asm/unistd.h 2009-12-03 03:51:21.000000000 +0000
+++ b/arch/s390/include/asm/unistd.h 2009-12-29 18:41:40.000000000 +0000
@@ -202,7 +202,7 @@
#define __NR_clock_gettime (__NR_timer_create+6)
#define __NR_clock_getres (__NR_timer_create+7)
#define __NR_clock_nanosleep (__NR_timer_create+8)
-/* Number 263 is reserved for vserver */
+#define __NR_vserver 263
#define __NR_statfs64 265
#define __NR_fstatfs64 266
#define __NR_remap_file_pages 267
diff -urpN a/fs/exec.c b/fs/exec.c
--- a/fs/exec.c 2009-12-29 17:57:12.000000000 +0000
+++ b/fs/exec.c 2009-12-29 18:46:32.000000000 +0000
@@ -56,6 +56,7 @@
#include <linux/fsnotify.h>
#include <linux/fs_struct.h>
#include <linux/pipe_fs_i.h>
+#include <linux/vs_memory.h>
#include <asm/uaccess.h>
#include <asm/mmu_context.h>
diff -urpN a/mm/memory.c b/mm/memory.c
--- a/mm/memory.c 2009-12-29 17:57:12.000000000 +0000
+++ b/mm/memory.c 2009-12-29 18:44:58.000000000 +0000
@@ -56,7 +56,7 @@
#include <linux/kallsyms.h>
#include <linux/swapops.h>
#include <linux/elf.h>
-// #include <linux/vs_memory.h>
+#include <linux/vs_memory.h>
#include <asm/io.h>
#include <asm/pgalloc.h>
diff -urpN a/mm/mmap.c b/mm/mmap.c
--- a/mm/mmap.c 2009-12-29 17:57:12.000000000 +0000
+++ b/mm/mmap.c 2009-12-29 18:45:42.000000000 +0000
@@ -29,6 +29,7 @@
#include <linux/rmap.h>
#include <linux/mmu_notifier.h>
#include <linux/perf_event.h>
+#include <linux/vs_memory.h>
#include <asm/uaccess.h>
#include <asm/cacheflush.h>

1
debian/patches/series/4-extra vendored Normal file
View File

@ -0,0 +1 @@
+ features/all/vserver/ia64-s390-buildfixes.patch featureset=vserver