[xen] Module autoprobing support for frontend drivers

add also this upstream xen patch for upcoming d-i beta2 xen support.
"it stops d-i from needing to prompt separately for the Xen frontend drivers to
find network and disks." Ian

svn path=/dists/trunk/linux-2.6/; revision=11156
This commit is contained in:
Maximilian Attems 2008-04-24 23:43:37 +00:00
parent 58b19969ea
commit ba78d1c30a
3 changed files with 96 additions and 0 deletions

1
debian/changelog vendored
View File

@ -42,6 +42,7 @@ linux-2.6 (2.6.25-1~experimental.1) UNRELEASED; urgency=low
* topconfig disable PATA_SIS as sis5513 enabled. (closes: #475525)
* [xen]: Support direct load of bzImage under Xen. (closes: #474509)
Thanks Ian Campbell <ijc@hellion.org.uk> for patches.
* [xen]: Module autoprobing support for frontend drivers.
[ Martin Michlmayr ]
* [arm/armel] Add a kernel for Orion based devices, such as the QNAP

View File

@ -0,0 +1,94 @@
From: Mark McLoughlin <markmc@redhat.com>
Date: Wed, 2 Apr 2008 17:54:05 +0000 (-0700)
Subject: xen: Module autoprobing support for frontend drivers
X-Git-Url: http://git.eu.kernel.org/?p=linux%2Fkernel%2Fgit%2Fx86%2Flinux-2.6-x86.git;a=commitdiff_plain;h=78f10294166f348730affacddb9aaac36511bdeb
xen: Module autoprobing support for frontend drivers
Add module aliases to support autoprobing modules
for xen frontend devices.
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
Signed-off-by: Ingo Molnar <mingo@elte.hu>
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
---
diff --git a/drivers/block/xen-blkfront.c b/drivers/block/xen-blkfront.c
index dfe61af..ffa0b43 100644
--- a/drivers/block/xen-blkfront.c
+++ b/drivers/block/xen-blkfront.c
@@ -1015,3 +1015,4 @@ module_exit(xlblk_exit);
MODULE_DESCRIPTION("Xen virtual block device frontend");
MODULE_LICENSE("GPL");
MODULE_ALIAS_BLOCKDEV_MAJOR(XENVBD_MAJOR);
+MODULE_ALIAS("xen:vbd");
diff --git a/drivers/net/xen-netfront.c b/drivers/net/xen-netfront.c
index 7483d45..b3fa27e 100644
--- a/drivers/net/xen-netfront.c
+++ b/drivers/net/xen-netfront.c
@@ -1809,3 +1809,4 @@ module_exit(netif_exit);
MODULE_DESCRIPTION("Xen virtual network device frontend");
MODULE_LICENSE("GPL");
+MODULE_ALIAS("xen:vif");
diff --git a/drivers/xen/xenbus/xenbus_probe.c b/drivers/xen/xenbus/xenbus_probe.c
index 88fc5ec..57ceb53 100644
--- a/drivers/xen/xenbus/xenbus_probe.c
+++ b/drivers/xen/xenbus/xenbus_probe.c
@@ -88,6 +88,16 @@ int xenbus_match(struct device *_dev, struct device_driver *_drv)
return match_device(drv->ids, to_xenbus_device(_dev)) != NULL;
}
+static int xenbus_uevent(struct device *_dev, struct kobj_uevent_env *env)
+{
+ struct xenbus_device *dev = to_xenbus_device(_dev);
+
+ if (add_uevent_var(env, "MODALIAS=xen:%s", dev->devicetype))
+ return -ENOMEM;
+
+ return 0;
+}
+
/* device/<type>/<id> => <type>-<id> */
static int frontend_bus_id(char bus_id[BUS_ID_SIZE], const char *nodename)
{
@@ -166,6 +176,7 @@ static struct xen_bus_type xenbus_frontend = {
.bus = {
.name = "xen",
.match = xenbus_match,
+ .uevent = xenbus_uevent,
.probe = xenbus_dev_probe,
.remove = xenbus_dev_remove,
.shutdown = xenbus_dev_shutdown,
@@ -438,6 +449,12 @@ static ssize_t xendev_show_devtype(struct device *dev,
}
DEVICE_ATTR(devtype, S_IRUSR | S_IRGRP | S_IROTH, xendev_show_devtype, NULL);
+static ssize_t xendev_show_modalias(struct device *dev,
+ struct device_attribute *attr, char *buf)
+{
+ return sprintf(buf, "xen:%s\n", to_xenbus_device(dev)->devicetype);
+}
+DEVICE_ATTR(modalias, S_IRUSR | S_IRGRP | S_IROTH, xendev_show_modalias, NULL);
int xenbus_probe_node(struct xen_bus_type *bus,
const char *type,
@@ -492,10 +509,16 @@ int xenbus_probe_node(struct xen_bus_type *bus,
err = device_create_file(&xendev->dev, &dev_attr_devtype);
if (err)
- goto fail_remove_file;
+ goto fail_remove_nodename;
+
+ err = device_create_file(&xendev->dev, &dev_attr_modalias);
+ if (err)
+ goto fail_remove_devtype;
return 0;
-fail_remove_file:
+fail_remove_devtype:
+ device_remove_file(&xendev->dev, &dev_attr_devtype);
+fail_remove_nodename:
device_remove_file(&xendev->dev, &dev_attr_nodename);
fail_unregister:
device_unregister(&xendev->dev);

View File

@ -48,3 +48,4 @@
+ features/all/xen-image-header.patch
+ features/all/xen-crc32-checksum-kernel-image.patch
+ features/all/xen-boot-protocol.patch
+ features/all/xen-module-autoloading.patch