aufs: Update to aufs3.10-20130805

svn path=/dists/sid/linux/; revision=20452
This commit is contained in:
Ben Hutchings 2013-08-07 13:30:23 +00:00
parent 7666bbcb16
commit b888e2c5a2
5 changed files with 358 additions and 358 deletions

1
debian/changelog vendored
View File

@ -80,6 +80,7 @@ linux (3.10.5-1) UNRELEASED; urgency=low
* [rt] genpatch.py: Accept missing series-rt
* [rt] Update to 3.10.4-rt1 and reenable
* [rt] genpatch.py: Fix parsing of upstream patches with no header
* aufs: Update to aufs3.10-20130805
-- Ben Hutchings <ben@decadent.org.uk> Tue, 30 Jul 2013 18:09:20 +0200

File diff suppressed because it is too large Load Diff

View File

@ -1,15 +1,15 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Sat May 18 10:36:30 2013 +0900
Subject: aufs3.x-rcN base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/4f14cef47eb7c23eda7198931fbab1040866b6ee/tree/
Date: Wed Jul 3 13:35:19 2013 +0900
Subject: aufs3.10 base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/a1069fdacd4c7e2650d1616c172465c74260600f/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN base patch
aufs3.10 base patch
diff --git a/fs/file_table.c b/fs/file_table.c
index cd4d87a..ca5948f 100644
index 485dc0e..8db8096 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -36,7 +36,7 @@ struct files_stat_struct files_stat = {
@ -35,7 +35,7 @@ index 00d5fc3..f324521 100644
if (inode->i_op->update_time)
return inode->i_op->update_time(inode, time, flags);
diff --git a/fs/splice.c b/fs/splice.c
index e6b2559..e4082c6 100644
index d37431d..987346f 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1093,8 +1093,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@ -63,10 +63,10 @@ index e6b2559..e4082c6 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/fs.h b/include/linux/fs.h
index 43db02e..59b6e6e 100644
index 65c2be2..0148214 100644
--- a/include/linux/fs.h
+++ b/include/linux/fs.h
@@ -2576,6 +2576,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
@@ -2574,6 +2574,7 @@ extern int inode_change_ok(const struct inode *, struct iattr *);
extern int inode_newsize_ok(const struct inode *, loff_t offset);
extern void setattr_copy(struct inode *inode, const struct iattr *attr);
@ -75,10 +75,10 @@ index 43db02e..59b6e6e 100644
extern int generic_show_options(struct seq_file *m, struct dentry *root);
diff --git a/include/linux/splice.h b/include/linux/splice.h
index 09a545a..1ac5727 100644
index 74575cb..bfc6fb6 100644
--- a/include/linux/splice.h
+++ b/include/linux/splice.h
@@ -91,4 +91,10 @@ extern void splice_shrink_spd(struct splice_pipe_desc *);
@@ -92,4 +92,10 @@ extern void splice_shrink_spd(struct splice_pipe_desc *);
extern void spd_release_page(struct splice_pipe_desc *, unsigned int);
extern const struct pipe_buf_operations page_cache_pipe_buf_ops;

View File

@ -1,12 +1,12 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri May 10 00:27:35 2013 +0900
Subject: aufs3.x-rcN kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/4f14cef47eb7c23eda7198931fbab1040866b6ee/tree/
Date: Wed Jul 3 13:35:19 2013 +0900
Subject: aufs3.10 kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/a1069fdacd4c7e2650d1616c172465c74260600f/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN kbuild patch
aufs3.10 kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index c229f82..397b473 100644
@ -30,7 +30,7 @@ index 4fe6df3..4a57676 100644
obj-$(CONFIG_EFIVAR_FS) += efivarfs/
+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/include/uapi/linux/Kbuild b/include/uapi/linux/Kbuild
index ab5d499..ed438c0 100644
index bdc6e87..349600c 100644
--- a/include/uapi/linux/Kbuild
+++ b/include/uapi/linux/Kbuild
@@ -56,6 +56,7 @@ header-y += atmppp.h

View File

@ -1,15 +1,15 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Fri May 10 00:27:35 2013 +0900
Subject: aufs3.x-rcN standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/4f14cef47eb7c23eda7198931fbab1040866b6ee/tree/
Date: Wed Jul 3 13:35:19 2013 +0900
Subject: aufs3.10 standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/a1069fdacd4c7e2650d1616c172465c74260600f/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch
aufs3.x-rcN standalone patch
aufs3.10 standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
index ca5948f..b553610 100644
index 8db8096..e271e28 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -37,6 +37,7 @@ struct files_stat_struct files_stat = {
@ -20,7 +20,7 @@ index ca5948f..b553610 100644
/* SLAB cache for file structures */
static struct kmem_cache *filp_cachep __read_mostly;
@@ -404,6 +405,8 @@ void file_sb_list_del(struct file *file)
@@ -405,6 +406,8 @@ void file_sb_list_del(struct file *file)
}
}
@ -162,7 +162,7 @@ index 8c74100..be563cd 100644
long vfs_truncate(struct path *path, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
index e4082c6..2d1a9fc 100644
index 987346f..8d6a045 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1120,6 +1120,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,