ia64: Include <linux/personality.h> header in <asm/fcntl.h>; fixes FTBFS

svn path=/dists/trunk/linux-2.6/; revision=14802
This commit is contained in:
Ben Hutchings 2009-12-19 16:19:24 +00:00
parent 918afa000c
commit b7bad86edf
3 changed files with 32 additions and 0 deletions

2
debian/changelog vendored
View File

@ -14,6 +14,8 @@ linux-2.6 (2.6.32-3) UNRELEASED; urgency=high
* Add stable release 2.6.32.2:
- KVM: x86 emulator: limit instructions to 15 bytes (CVE-2009-4031)
- hfs: fix a potential buffer overflow (CVE-2009-4020)
* ia64: Include <linux/personality.h> header in <asm/fcntl.h>; fixes
FTBFS
-- Martin Michlmayr <tbm@cyrius.com> Fri, 18 Dec 2009 15:34:01 +0000

View File

@ -0,0 +1,29 @@
From 566d4fd4a07a92fa0023d29d2ad5477bad537288 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 19 Dec 2009 14:51:09 +0000
Subject: [PATCH] ia64: Include <linux/personality.h> header in <asm/fcntl.h>
The definition of force_o_largefile() references personality, but this
header does not include <linux/personality.h>. This happens to work
for sys_open(), but may not for any other users. In particular, aufs2
now uses this macro and so fails to build on ia64.
---
arch/ia64/include/asm/fcntl.h | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/arch/ia64/include/asm/fcntl.h b/arch/ia64/include/asm/fcntl.h
index 1dd275d..3cac8f9 100644
--- a/arch/ia64/include/asm/fcntl.h
+++ b/arch/ia64/include/asm/fcntl.h
@@ -5,6 +5,8 @@
* David Mosberger-Tang <davidm@hpl.hp.com>, Hewlett-Packard Co.
*/
+#include <linux/personality.h>
+
#define force_o_largefile() \
(personality(current->personality) != PER_LINUX32)
--
1.6.5.7

View File

@ -6,3 +6,4 @@
+ features/all/sfc-2.6.33-rc1.patch
- bugfix/mips/drm-ttm-build-fix.patch
+ bugfix/all/stable/2.6.32.2.patch
+ bugfix/ia64/ia64-Include-linux-personality.h-header-in-asm-fcntl.patch