Revert "scsi: libsas: allow async aborts"

Fixes "Oops: NULL pointer dereference - RIP:
isci_task_abort_task+0x30/0x3e0 [isci]"

Closes: #882414
This commit is contained in:
Salvatore Bonaccorso 2018-01-05 13:40:56 +01:00
parent 96dad8ed7e
commit b64a1989ae
3 changed files with 30 additions and 0 deletions

3
debian/changelog vendored
View File

@ -50,6 +50,9 @@ linux (4.14.11-1) UNRELEASED; urgency=medium
[ Salvatore Bonaccorso ]
* [rt] Update to 4.14.8-rt9
* Bump ABI to 3
* Revert "scsi: libsas: allow async aborts"
Fixes "Oops: NULL pointer dereference - RIP:
isci_task_abort_task+0x30/0x3e0 [isci]" (Closes: #882414)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 28 Dec 2017 01:18:05 +0000

View File

@ -0,0 +1,26 @@
From: Salvatore Bonaccorso <carnil@debian.org>
Date: Fri, 5 Jan 2018 13:36:38 +0100
Subject: Revert "scsi: libsas: allow async aborts"
Bug-Debian: https://bugs.debian.org/882414
---
drivers/scsi/libsas/sas_scsi_host.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/drivers/scsi/libsas/sas_scsi_host.c b/drivers/scsi/libsas/sas_scsi_host.c
index ea8ad06ff582..e81c8590d254 100644
--- a/drivers/scsi/libsas/sas_scsi_host.c
+++ b/drivers/scsi/libsas/sas_scsi_host.c
@@ -491,6 +491,9 @@ int sas_eh_abort_handler(struct scsi_cmnd *cmd)
struct Scsi_Host *host = cmd->device->host;
struct sas_internal *i = to_sas_internal(host->transportt);
+ if (current != host->ehandler)
+ return FAILED;
+
if (!i->dft->lldd_abort_task)
return FAILED;
--
2.11.0

View File

@ -82,6 +82,7 @@ bugfix/all/i40e-i40evf-organize-and-re-number-feature-flags.patch
bugfix/all/i40e-fix-flags-declaration.patch
bugfix/all/xen-time-do-not-decrease-steal-time-after-live-migra.patch
bugfix/all/e1000e-fix-e1000_check_for_copper_link_ich8lan-return-value.patch
debian/revert-scsi-libsas-allow-async-aborts.patch
# Miscellaneous features