xen/netfront: teardown the device before unregistering it (Closes: #675190)

svn path=/dists/sid/linux/; revision=19222
This commit is contained in:
Ben Hutchings 2012-06-27 03:21:03 +00:00
parent d9047a7642
commit b31cabb10b
3 changed files with 52 additions and 0 deletions

1
debian/changelog vendored
View File

@ -5,6 +5,7 @@ linux (3.2.21-3) UNRELEASED; urgency=low
* i2400m: Disable I2400M_SDIO; hardware did not reach production
* apparmor: remove advertising the support of network rules from
compat iface (Closes: #676515)
* xen/netfront: teardown the device before unregistering it (Closes: #675190)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 27 Jun 2012 02:56:49 +0100

View File

@ -0,0 +1,49 @@
From: Ian Campbell <ian.campbell@citrix.com>
Date: Tue, 26 Jun 2012 09:48:41 +0100
Subject: xen/netfront: teardown the device before unregistering it.
Bug-Debian: http://bugs.debian.org/675190
Fixes:
[ 15.470311] WARNING: at /local/scratch/ianc/devel/kernels/linux/fs/sysfs/file.c:498 sysfs_attr_ns+0x95/0xa0()
[ 15.470326] sysfs: kobject eth0 without dirent
[ 15.470333] Modules linked in:
[ 15.470342] Pid: 12, comm: xenwatch Not tainted 3.4.0-x86_32p-xenU #93
and
[ 9.150554] BUG: unable to handle kernel paging request at 2b359000
[ 9.150577] IP: [<c1279561>] linkwatch_do_dev+0x81/0xc0
[ 9.150592] *pdpt = 000000002c3c9027 *pde = 0000000000000000
[ 9.150604] Oops: 0002 [#1] SMP
[ 9.150613] Modules linked in:
This is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=675190
Reported-by: George Shuklin <george.shuklin@gmail.com>
Signed-off-by: Ian Campbell <ian.campbell@citrix.com>
Tested-by: William Dauchy <wdauchy@gmail.com>
Cc: stable@kernel.org
Cc: 675190@bugs.debian.org
---
drivers/net/xen-netfront.c | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)
--- a/drivers/net/xen-netfront.c
+++ b/drivers/net/xen-netfront.c
@@ -1922,14 +1922,14 @@
dev_dbg(&dev->dev, "%s\n", dev->nodename);
- unregister_netdev(info->netdev);
-
xennet_disconnect_backend(info);
- del_timer_sync(&info->rx_refill_timer);
-
xennet_sysfs_delif(info->netdev);
+ unregister_netdev(info->netdev);
+
+ del_timer_sync(&info->rx_refill_timer);
+
free_percpu(info->stats);
free_netdev(info->netdev);

View File

@ -367,3 +367,5 @@ features/all/Input-add-Synaptics-USB-device-driver.patch
features/arm/ARM-7259-3-net-JIT-compiler-for-packet-filters.patch
features/arm/ARM-fix-Kconfig-warning-for-HAVE_BPF_JIT.patch
features/arm/net-drop-NET-dependency-from-HAVE_BPF_JIT.patch
bugfix/all/xen-netfront-teardown-the-device-before-unregistering-it.patch