ark3116: Fix initialisation order (Closes: #640391)

svn path=/dists/sid/linux-2.6/; revision=18186
This commit is contained in:
Ben Hutchings 2011-10-28 03:47:37 +00:00
parent f3929cc7ad
commit ace78f87fb
3 changed files with 55 additions and 0 deletions

1
debian/changelog vendored
View File

@ -27,6 +27,7 @@ linux-2.6 (3.0.0-6) UNRELEASED; urgency=low
For the complete list of changes, see:
http://www.kernel.org/pub/linux/kernel/v3.0/ChangeLog-3.0.8
* [{mips,mipsel}/{4,5}kc-malta] Disable X.25, as in all other configurations
* ark3116: Fix initialisation order (Closes: #640391)
-- Uwe Kleine-König <u.kleine-koenig@pengutronix.de> Fri, 07 Oct 2011 15:48:22 +0200

View File

@ -0,0 +1,53 @@
Date: Wed, 26 Oct 2011 13:29:42 +0200
From: Bart Hartgers <bart.hartgers@gmail.com>
Subject: [PATCH] ark3116 initialisation fix
Hi,
This patch for the usb serial ark3116 driver fixes an initialisation
ordering bug that gets triggered on hotplug when using at least recent
debian/ubuntu userspace. Without it, ark3116 serial cables don't work.
Patch is against 3.1.
Groeten,
Bart
Signed-off-by: Bart Hartgers <bart.hartgers@gmail.com>
Tested-by: law_ence.dev@ntlworld.com
---
diff -ur linux-3.1.orig//drivers/usb/serial/ark3116.c linux-3.1/drivers/usb/serial/ark3116.c
--- linux-3.1.orig//drivers/usb/serial/ark3116.c 2011-10-24 09:10:05.000000000 +0200
+++ linux-3.1/drivers/usb/serial/ark3116.c 2011-10-26 09:16:41.776874595 +0200
@@ -42,7 +42,7 @@
* Version information
*/
-#define DRIVER_VERSION "v0.6"
+#define DRIVER_VERSION "v0.7"
#define DRIVER_AUTHOR "Bart Hartgers <bart.hartgers+ark3116@gmail.com>"
#define DRIVER_DESC "USB ARK3116 serial/IrDA driver"
#define DRIVER_DEV_DESC "ARK3116 RS232/IrDA"
@@ -380,10 +380,6 @@
goto err_out;
}
- /* setup termios */
- if (tty)
- ark3116_set_termios(tty, port, NULL);
-
/* remove any data still left: also clears error state */
ark3116_read_reg(serial, UART_RX, buf);
@@ -406,6 +402,10 @@
/* enable DMA */
ark3116_write_reg(port->serial, UART_FCR, UART_FCR_DMA_SELECT);
+ /* setup termios */
+ if (tty)
+ ark3116_set_termios(tty, port, NULL);
+
err_out:
kfree(buf);
return result;

View File

@ -1,3 +1,4 @@
+ bugfix/all/stable/3.0.7.patch
- bugfix/all/uvcvideo-Fix-crash-when-linking-entities.patch
+ bugfix/all/stable/3.0.8.patch
+ bugfix/all/ark3116-initialisation-fix.patch