[mips/sb1-91250a] Backport from upstream additional build flags

to fix excessive kernel warnings.

svn path=/dists/sid/linux/; revision=21587
This commit is contained in:
Aurelien Jarno 2014-07-20 15:24:22 +00:00
parent c4ff6fcad8
commit ac399e34fe
3 changed files with 42 additions and 0 deletions

2
debian/changelog vendored
View File

@ -60,6 +60,8 @@ linux (3.14.13-1) UNRELEASED; urgency=medium
* [mips,mipsel] Add mips64 and mips64el support (Closes: #749688).
* [mips/octeon] Backport from upstream PCIe2 support and interface
mode detection for Octeon.
* [mips/sb1-91250a] Backport from upstream additional build flags
to fix excessive kernel warnings.
[ Ben Hutchings ]
* net/l2tp: don't fall back on UDP [get|set]sockopt (CVE-2014-4943)

View File

@ -0,0 +1,39 @@
From: Ralf Baechle <ralf@linux-mips.org>
Date: Wed, 28 May 2014 08:36:23 +0200
Subject: MIPS: SB1: Fix excessive kernel warnings.
Origin: https://git.kernel.org/linus/bb6c0bd3fdb67c8a1fceea1d4700b9ee593309f9
A kernel build with binutils 2.24 is going to emit warnings like
CC kernel/sys.o
{standard input}: Assembler messages:
{standard input}:701: Warning: the 32-bit MIPS architecture does not support the `mdmx' extension
{standard input}:701: Warning: the `mdmx' extension requires 64-bit FPRs
{standard input}:701: Warning: the `mips3d' extension requires MIPS32 revision 2 or greater
{standard input}:701: Warning: the `mips3d' extension requires 64-bit FPRs
for almost every file. This is caused by changes to gas' interpretation
of .set semantics. Fixed by explicitly disabling MIPS3D and MDMX for
Sibyte builds.
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
---
arch/mips/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/mips/Makefile b/arch/mips/Makefile
index 1a5b403..60a359c 100644
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -151,7 +151,7 @@ cflags-$(CONFIG_CPU_NEVADA) += $(call cc-option,-march=rm5200,-march=r5000) \
-Wa,--trap
cflags-$(CONFIG_CPU_RM7000) += $(call cc-option,-march=rm7000,-march=r5000) \
-Wa,--trap
-cflags-$(CONFIG_CPU_SB1) += $(call cc-option,-march=sb1,-march=r5000) \
+cflags-$(CONFIG_CPU_SB1) += $(call cc-option,-march=sb1 -mno-mdmx -mno-mips3d,-march=r5000) \
-Wa,--trap
cflags-$(CONFIG_CPU_R8000) += -march=r8000 -Wa,--trap
cflags-$(CONFIG_CPU_R10000) += $(call cc-option,-march=r10000,-march=r8000) \
--
2.0.0

View File

@ -61,6 +61,7 @@ bugfix/arm/ixp4xx_iobe.patch
bugfix/m68k/ethernat-kconfig.patch
bugfix/arm/bfa-Replace-large-udelay-with-mdelay.patch
bugfix/powerpc/ppc64el-powernv-calls-to-support-little-endian.patch
bugfix/mips/MIPS-SB1-Fix-excessive-kernel-warnings.patch
# Miscellaneous bug fixes
bugfix/all/misc-bmp085-Enable-building-as-a-module.patch