Add stable release 2.6.32.4

Fix conflict between 2.6.32.4 and vserver in mm/mremap.c by making some
cosmetic changes on top of 2.6.32.4.


svn path=/dists/trunk/linux-2.6/; revision=14953
This commit is contained in:
Ben Hutchings 2010-01-18 22:50:09 +00:00
parent 491d6bfd34
commit ab1a7a99b1
4 changed files with 4698 additions and 10 deletions

18
debian/changelog vendored
View File

@ -13,14 +13,22 @@ linux-2.6 (2.6.32-6) UNRELEASED; urgency=low
* saa7134: Add device id and description for Asus Europa DVB-T card
* x86/iTCO-wdt: Add device ids for Intel 'Ibex Peak' PCH
* Documentation/3c509: document ethtool support (Closes: #564743)
* Fix DMA mapping for i915 driver (Closes: #558237)
- agp/intel-agp: Clear entire GTT on startup
- drm: remove address mask param for drm_pci_alloc()
* Add MODULE_FIRMWARE declarations to several drivers that lacked them
* [x86] Update rt2860sta/rt2870sta firmware loader patch
- Accept 8K versions of rt2870.bin
- Fix hang on resume
* [x86] Enable rt3090sta using firmware loader
* Add stable release 2.6.32.4:
- fasync: split 'fasync_helper()' into separate add/remove functions
(CVE-2009-4141)
- netfilter: ebtables: enforce CAP_NET_ADMIN (CVE-2010-0007)
- audit: Fix memory management bugs (Closes: #562815)
+ fix braindamage in audit_tree.c untag_chunk()
+ fix more leaks in audit_tree.c tag_chunk()
- ipv6: skb_dst() can be NULL in ipv6_hop_jumbo(). (CVE-2010-0006)
- Fix DMA mapping for i915 driver (Closes: #558237)
+ drm: remove address mask param for drm_pci_alloc()
+ agp/intel-agp: Clear entire GTT on startup
[ Ian Campbell ]
* xen: Enable up to 32G of guest memory on i386.
@ -28,10 +36,6 @@ linux-2.6 (2.6.32-6) UNRELEASED; urgency=low
[ Julien Cristau ]
* drm/i915: disable powersave by default (closes: #564807)
[ dann frazier ]
* fasync: split 'fasync_helper()' into separate add/remove functions
(CVE-2009-4141)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 10 Jan 2010 17:38:50 +0000
linux-2.6 (2.6.32-5) unstable; urgency=low

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,32 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: [PATCH] mm/mremap: Fix conflict between 2.6.32.4 and vserver
Make some cosmetic changes to the reworked mremap in 2.6.32.4 so that
the vserver patch will still apply (with fuzz 1).
--- a/mm/mremap.c
+++ b/mm/mremap.c
@@ -288,11 +288,11 @@
lock_limit = current->signal->rlim[RLIMIT_MEMLOCK].rlim_cur;
locked += new_len - old_len;
if (locked > lock_limit && !capable(CAP_IPC_LOCK))
- goto Eagain;
+ goto out;
}
-
- if (!may_expand_vm(mm, (new_len - old_len) >> PAGE_SHIFT))
+ if (!may_expand_vm(mm, (new_len - old_len) >> PAGE_SHIFT)) {
goto Enomem;
+ }
if (vma->vm_flags & VM_ACCOUNT) {
unsigned long charged = (new_len - old_len) >> PAGE_SHIFT;
@@ -309,7 +309,7 @@
return ERR_PTR(-EINVAL);
Enomem:
return ERR_PTR(-ENOMEM);
-Eagain:
+out:
return ERR_PTR(-EAGAIN);
}

View File

@ -12,9 +12,6 @@
+ features/x86/iTCO_wdt-Add-support-for-Intel-Ibex-Peak.patch
+ bugfix/all/Documentation-3c509-document-ethtool-support.patch
+ bugfix/all/drm-i915-disable-powersave.patch
+ bugfix/all/intel-agp-Clear-entire-GTT-on-startup.patch
+ bugfix/all/drm-remove-address-mask-param-for-drm_pci_alloc.patch
+ bugfix/all/fasync-split-fasync_helper.patch
+ features/all/module-firmware/0025-tty-declare-MODULE_FIRMWARE-in-various-drivers.patch
+ features/all/module-firmware/0026-staging-declare-MODULE_FIRMWARE-in-various-drivers.patch
+ features/all/module-firmware/0027-sep-include-driver-name-in-firmware-filenames.patch
@ -25,3 +22,7 @@
+ features/all/rt28x0sta-constify-RTUSBMultiWrite-RTUSBFirmwareWrite.patch
+ features/all/rt28x0sta-use-request_firmware.patch
+ features/all/rt3090sta-use-request_firmware.patch
- bugfix/all/modules-Skip-empty-section-notes.patch
- bugfix/all/ath5k-Fix-eeprom-checksum-check-for-custom-sized-eeproms.patch
+ bugfix/all/stable/2.6.32.4.patch
+ debian/mremap-fix-conflict-between-2.6.32.4-and-vserver.patch