[powerpcspe] xmon: Don't use ld on 32-bit (Closes: #836741)

This commit is contained in:
Ben Hutchings 2016-09-12 20:38:54 +01:00
parent 1dda9dd218
commit ab1157972f
3 changed files with 43 additions and 0 deletions

1
debian/changelog vendored
View File

@ -123,6 +123,7 @@ linux (4.7.3-1) UNRELEASED; urgency=medium
(regression in 4.7)
* [arm64] pinctrl: Enable PINCTRL_SINGLE as built-in, needed for HiKey SoCs
* [hppa] Disable FTRACE due to huge size cost (Closes: #837588)
* [powerpcspe] xmon: Don't use ld on 32-bit (Closes: #836741)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 03 Sep 2016 18:34:31 +0100

View File

@ -0,0 +1,41 @@
From: Michael Ellerman <mpe@ellerman.id.au>
Date: Fri Sep 9 15:54:37 AEST 2016
Subject: powerpc/xmon: Don't use ld on 32-bit
Origin: https://lists.ozlabs.org/pipermail/linuxppc-dev/2016-September/148424.html
Bug-Debian: https://bugs.debian.org/836741
In commit 31cdd0c39c75 ("powerpc/xmon: Fix SPR read/write commands and
add command to dump SPRs") I added two uses of the "ld" instruction in
spr_access.S. "ld" is a 64-bit instruction, so shouldn't be used on
32-bit CPUs.
Replace it with PPC_LL which is a macro that gives us either "ld" or
"lwz" depending on whether we're 64 or 32-bit.
Fixes: 31cdd0c39c75 ("powerpc/xmon: Fix SPR read/write commands and add command to dump SPRs")
Cc: stable@vger.kernel.org # v4.7+
Reported-by: John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
Signed-off-by: Michael Ellerman <mpe@ellerman.id.au>
---
arch/powerpc/xmon/spr_access.S | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/powerpc/xmon/spr_access.S b/arch/powerpc/xmon/spr_access.S
index 84ad74213c83..7d8b0e8ed6d9 100644
--- a/arch/powerpc/xmon/spr_access.S
+++ b/arch/powerpc/xmon/spr_access.S
@@ -2,12 +2,12 @@
/* unsigned long xmon_mfspr(sprn, default_value) */
_GLOBAL(xmon_mfspr)
- ld r5, .Lmfspr_table@got(r2)
+ PPC_LL r5, .Lmfspr_table@got(r2)
b xmon_mxspr
/* void xmon_mtspr(sprn, new_value) */
_GLOBAL(xmon_mtspr)
- ld r5, .Lmtspr_table@got(r2)
+ PPC_LL r5, .Lmtspr_table@got(r2)
b xmon_mxspr
/*

View File

@ -45,6 +45,7 @@ bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
debian/fanotify-taint-on-use-of-fanotify_access_permissions.patch
# Arch bug fixes
bugfix/powerpc/powerpc-xmon-don-t-use-ld-on-32-bit.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch