bfq: Enable auto-loading when built as a module

This commit is contained in:
Ben Hutchings 2017-08-12 22:36:27 +01:00
parent bea6941301
commit aa404ad63b
3 changed files with 25 additions and 0 deletions

1
debian/changelog vendored
View File

@ -40,6 +40,7 @@ linux (4.12.6-1) UNRELEASED; urgency=medium
* blk-mq: Change MQ_IOSCHED_KYBER from built-in to module
* blk-mq: Enable IOSCHED_BFQ as module (Closes: #869028); enable
BFQ_GROUP_IOSCHED
* bfq: Enable auto-loading when built as a module
[ Salvatore Bonaccorso ]
* packet: fix tp_reserve race in packet_set_ring (CVE-2017-1000111)

View File

@ -0,0 +1,23 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 12 Aug 2017 22:27:06 +0100
Subject: bfq: Re-enable auto-loading when built as a module
The block core requests modules with the "-iosched" name suffix, but
bfq no longer has that suffix. Add an alias.
Fixes: ea25da48086d ("block, bfq: split bfq-iosched.c into multiple ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
block/bfq-iosched.c | 1 +
1 file changed, 1 insertion(+)
--- a/block/bfq-iosched.c
+++ b/block/bfq-iosched.c
@@ -4974,6 +4974,7 @@ static struct elevator_type iosched_bfq_
.elevator_name = "bfq",
.elevator_owner = THIS_MODULE,
};
+MODULE_ALIAS("bfq-iosched");
static int __init bfq_init(void)
{

View File

@ -85,6 +85,7 @@ bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
bugfix/all/rtlwifi-fix-memory-leak-when-firmware-request-fails.patch
bugfix/all/rtlwifi-fix-fallback-firmware-loading.patch
bugfix/all/bfq-re-enable-auto-loading-when-built-as-a-module.patch
# Miscellaneous features