mvsas: Recognise device/subsystem 9485/9485 as 88SE9485

svn path=/dists/sid/linux/; revision=20637
This commit is contained in:
Ben Hutchings 2013-09-16 02:38:57 +00:00
parent 7c11cab253
commit a9e300f8fb
3 changed files with 45 additions and 0 deletions

1
debian/changelog vendored
View File

@ -27,6 +27,7 @@ linux (3.10.12-1) UNRELEASED; urgency=low
[ Ben Hutchings ]
* Revert "genl: Hold reference on correct module while netlink-dump."
from 3.10.12 to avoid an ABI change
* mvsas: Recognise device/subsystem 9485/9485 as 88SE9485
-- Ben Hutchings <ben@decadent.org.uk> Sat, 14 Sep 2013 19:58:07 +0100

View File

@ -0,0 +1,43 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 16 Sep 2013 03:26:32 +0100
Subject: mvsas: Recognise device/subsystem 9485/9485 as 88SE9485
Forwarded: http://mid.gmane.org/1379298957.23881.10.camel@deadeye.wl.decadent.org.uk
Matt Taggart reported that mvsas didn't bind to the Marvell
SAS controller on a Supermicro AOC-SAS2LP-MV8 board.
lspci reports it as:
01:00.0 RAID bus controller [0104]: Marvell Technology Group Ltd. Device [1b4b:9485] (rev 03)
Subsystem: Marvell Technology Group Ltd. Device [1b4b:9485]
[...]
Add it to the device table as chip_9485.
Reported-by: Matt Taggart <taggart@debian.org>
Tested-by: Matt Taggart <taggart@debian.org>
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/scsi/mvsas/mv_init.c | 9 +++++++++
1 file changed, 9 insertions(+)
diff --git a/drivers/scsi/mvsas/mv_init.c b/drivers/scsi/mvsas/mv_init.c
index 7b7381d..83fa5f8 100644
--- a/drivers/scsi/mvsas/mv_init.c
+++ b/drivers/scsi/mvsas/mv_init.c
@@ -729,6 +729,15 @@ static struct pci_device_id mvs_pci_table[] = {
.class_mask = 0,
.driver_data = chip_9485,
},
+ {
+ .vendor = PCI_VENDOR_ID_MARVELL_EXT,
+ .device = 0x9485,
+ .subvendor = PCI_ANY_ID,
+ .subdevice = 0x9485,
+ .class = 0,
+ .class_mask = 0,
+ .driver_data = chip_9485,
+ },
{ PCI_VDEVICE(OCZ, 0x1021), chip_9485}, /* OCZ RevoDrive3 */
{ PCI_VDEVICE(OCZ, 0x1022), chip_9485}, /* OCZ RevoDrive3/zDriveR4 (exact model unknown) */
{ PCI_VDEVICE(OCZ, 0x1040), chip_9485}, /* OCZ RevoDrive3/zDriveR4 (exact model unknown) */

View File

@ -127,3 +127,4 @@ bugfix/all/HID-check-for-NULL-field-when-setting-values.patch
# ABI stability
debian/net-sched-avoid-abi-change-in-3.10.12.patch
debian/revert-genl-hold-reference-on-correct-module.patch
features/all/mvsas-Recognise-device-subsystem-9485-9485-as-88SE94.patch