Update to 3.12.8

Drop one patch that was included in it.
Revert one of the fixes, which would cause an ABI change.

svn path=/dists/sid/linux/; revision=20979
This commit is contained in:
Ben Hutchings 2014-01-19 19:06:59 +00:00
parent c97abbac79
commit a899464afd
4 changed files with 117 additions and 38 deletions

44
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.12.7-1) UNRELEASED; urgency=low
linux (3.12.8-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.12.7
@ -65,6 +65,46 @@ linux (3.12.7-1) UNRELEASED; urgency=low
- aio/migratepages: make aio migrate pages sane
- ACPIPHP / radeon / nouveau: Fix VGA switcheroo problem related to hotplug
(regression in 3.12)
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.12.8
- IPv6: Fixed support for blackhole and prohibit routes
- net: do not pretend FRAGLIST support
- tun: unbreak truncated packet signalling
- macvtap: signal truncated packets
- br: fix use of ->rx_handler_data in code executed on non-rx_handler path
- inet: fix NULL pointer Oops in fib(6)_rule_suppress
- vxlan: release rt when found circular route
- ipv6: fix illegal mac_header comparison on 32bit
- ip_gre: fix msg_name parsing for recvfrom/recvmsg
- net: inet_diag: zero out uninitialized idiag_{src,dst} fields
- drivers/net/hamradio: Integer overflow in hdlcdrv_ioctl()
- hamradio/yam: fix info leak in ioctl
- net: fec: fix potential use after free
- rds: prevent dereference of a NULL device
- arc_emac: fix potential use after free
- net: rose: restore old recvmsg behavior (regression in 3.12.4)
- vlan: Fix header ops passthru when doing TX VLAN offload.
- virtio-net: fix refill races during restore
- net: llc: fix use after free in llc_ui_recvmsg
- netpoll: Fix missing TXQ unlock and and OOPS.
- bridge: use spin_lock_bh() in br_multicast_set_hash_max
- sfc: Add length checks to efx_xmit_with_hwtstamp() and
efx_ptp_is_ptp_tx()
- sfc: PTP: Moderate log message on event queue overflow
- sfc: Rate-limit log message for PTP packets without a matching timestamp
event
- [arm] fix "bad mode in ... handler" message for undefined instructions
- [arm] 7923/1: mm: fix dcache flush logic for compound high pages
- [hppa] Ensure full cache coherency for kmap/kunmap
- clk: clk-divider: fix divisor > 255 bug
- mfd: rtsx_pcr: Disable interrupts before cancelling delayed works
- netfilter: fix wrong byte order in nf_ct_seqadj_set internal information
(regression in 3.12)
- netfilter: nf_nat: fix access to uninitialized buffer in IRC NAT helper
- x86, fpu, amd: Clear exceptions in AMD FXSAVE workaround
(CVE-2014-1438) (Closes: #733551)
- sched: Fix race on toggling cfs_bandwidth_used
- sched: Fix cfs_bandwidth misuse of hrtimer_expires_remaining
- sched: Fix hrtimer_cancel()/rq->lock deadlock
[ Ben Hutchings ]
* [hppa] Update configuration, thanks to Helge Deller (Closes: #733895)
@ -93,6 +133,8 @@ linux (3.12.7-1) UNRELEASED; urgency=low
- rcu: Don't activate RCU core on NO_HZ_FULL CPUs
- timers: do not raise softirq unconditionally
- rcutree/rcu_bh_qs: disable irq while calling rcu_preempt_qs()
* Revert "net: unix: allow set_peek_off to fail", included in 3.12.8,
as it would cause an ABI change
[ Ian Campbell ]
* [armel/kirkwood] Fix interrupt handling on non-DT platforms (Closes: #735172)

View File

@ -1,36 +0,0 @@
Subject: rds: prevent BUG_ON triggered on congestion update to loopback
From: Venkat Venkatsubra <venkat.x.venkatsubra@oracle.com>
Date: Mon, 25 Nov 2013 09:47:34 +0300
Origin: http://patchwork.ozlabs.org/patch/293827/
After congestion update on a local connection, when rds_ib_xmit returns
less bytes than that are there in the message, rds_send_xmit calls
back rds_ib_xmit with an offset that causes BUG_ON(off & RDS_FRAG_SIZE)
to trigger.
Reported-by: Josh Hunt <joshhunt00@gmail.com>
Tested-by: Honggang Li <honli@redhat.com>
Acked-by: Bang Nguyen <bang.nguyen@oracle.com>
Signed-off-by: Venkat Venkatsubra <venkat.x.venkatsubra@oracle.com>
Signed-off-by: Dan Carpenter <dan.carpenter@oracle.com>
---
net/rds/ib_send.c | 5 ++---
1 files changed, 2 insertions(+), 3 deletions(-)
diff --git a/net/rds/ib_send.c b/net/rds/ib_send.c
index e590949..37be6e2 100644
--- a/net/rds/ib_send.c
+++ b/net/rds/ib_send.c
@@ -552,9 +552,8 @@ int rds_ib_xmit(struct rds_connection *conn, struct rds_message *rm,
&& rm->m_inc.i_hdr.h_flags & RDS_FLAG_CONG_BITMAP) {
rds_cong_map_updated(conn->c_fcong, ~(u64) 0);
scat = &rm->data.op_sg[sg];
- ret = sizeof(struct rds_header) + RDS_CONG_MAP_BYTES;
- ret = min_t(int, ret, scat->length - conn->c_xmit_data_off);
- return ret;
+ ret = max_t(int, RDS_CONG_MAP_BYTES, scat->length);
+ return sizeof(struct rds_header) + ret;
}
/* FIXME we may overallocate here */

View File

@ -0,0 +1,73 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 19 Jan 2014 18:59:53 +0000
Subject: Revert "net: unix: allow set_peek_off to fail"
This reverts commit 12663bfc97c8b3fdb292428105dd92d563164050
which was backported into 3.12.8 and would cause an ABI change.
--- a/include/linux/net.h
+++ b/include/linux/net.h
@@ -180,7 +180,7 @@ struct proto_ops {
int offset, size_t size, int flags);
ssize_t (*splice_read)(struct socket *sock, loff_t *ppos,
struct pipe_inode_info *pipe, size_t len, unsigned int flags);
- int (*set_peek_off)(struct sock *sk, int val);
+ void (*set_peek_off)(struct sock *sk, int val);
};
#define DECLARE_SOCKADDR(type, dst, src) \
--- a/net/core/sock.c
+++ b/net/core/sock.c
@@ -888,7 +888,7 @@ set_rcvbuf:
case SO_PEEK_OFF:
if (sock->ops->set_peek_off)
- ret = sock->ops->set_peek_off(sk, val);
+ sock->ops->set_peek_off(sk, val);
else
ret = -EOPNOTSUPP;
break;
--- a/net/unix/af_unix.c
+++ b/net/unix/af_unix.c
@@ -530,17 +530,13 @@ static int unix_seqpacket_sendmsg(struct
static int unix_seqpacket_recvmsg(struct kiocb *, struct socket *,
struct msghdr *, size_t, int);
-static int unix_set_peek_off(struct sock *sk, int val)
+static void unix_set_peek_off(struct sock *sk, int val)
{
struct unix_sock *u = unix_sk(sk);
- if (mutex_lock_interruptible(&u->readlock))
- return -EINTR;
-
+ mutex_lock(&u->readlock);
sk->sk_peek_off = val;
mutex_unlock(&u->readlock);
-
- return 0;
}
@@ -718,9 +714,7 @@ static int unix_autobind(struct socket *
int err;
unsigned int retries = 0;
- err = mutex_lock_interruptible(&u->readlock);
- if (err)
- return err;
+ mutex_lock(&u->readlock);
err = 0;
if (u->addr)
@@ -879,9 +873,7 @@ static int unix_bind(struct socket *sock
goto out;
addr_len = err;
- err = mutex_lock_interruptible(&u->readlock);
- if (err)
- goto out;
+ mutex_lock(&u->readlock);
err = -EINVAL;
if (u->addr)

View File

@ -76,7 +76,6 @@ features/all/mvsas-Recognise-device-subsystem-9485-9485-as-88SE94.patch
bugfix/all/kbuild-use-nostdinc-in-compile-tests.patch
debian/add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by-default.patch
bugfix/all/UAPI-include-asm-byteorder.h-in-linux-raid-md_p.h.patch
bugfix/all/rds-prevent-bug_on-triggered-by-congestion-update-to-loopback.patch
bugfix/all/disable-some-marvell-phys.patch
features/all/media-az6007-support-Technisat-Cablestar-Combo-HDCI-.patch
bugfix/all/alpha-Prevent-a-NULL-ptr-dereference-in-csum_partial.patch
@ -88,3 +87,4 @@ debian/acpi-avoid-abi-change-in-3.12.7.patch
debian/mm-avoid-abi-change-in-3.12.7.patch
debian/net-avoid-abi-change-in-3.12.7.patch
debian/mm-migrate-avoid-abi-change-in-3.12.7.patch
debian/revert-net-unix-allow-set_peek_off-to-fail.patch