[x86] dell-laptop: Terminate quirks list properly

svn path=/dists/trunk/linux-2.6/; revision=18967
This commit is contained in:
Ben Hutchings 2012-05-01 00:23:51 +00:00
parent 0049362186
commit a6ec1f7cdf
3 changed files with 36 additions and 0 deletions

3
debian/changelog vendored
View File

@ -4,6 +4,9 @@ linux-2.6 (3.3.4-1~experimental.1) UNRELEASED; urgency=low
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.3.3
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.3.4
[ Ben Hutchings ]
* [x86] dell-laptop: Terminate quirks list properly
-- Ben Hutchings <ben@decadent.org.uk> Mon, 30 Apr 2012 04:02:33 +0100
linux-2.6 (3.3.2-1~experimental.1) experimental; urgency=low

View File

@ -0,0 +1,32 @@
From d62d421b071b08249361044d8e56c8b5c3ed6aa7 Mon Sep 17 00:00:00 2001
From: Martin Nyhus <martin.nyhus@gmx.com>
Date: Thu, 15 Mar 2012 18:25:48 +0100
Subject: dell-laptop: Terminate quirks list properly
From: Martin Nyhus <martin.nyhus@gmx.com>
commit d62d421b071b08249361044d8e56c8b5c3ed6aa7 upstream.
Add missing DMI_NONE entry to end of the quirks list so
dmi_check_system() won't read past the end of the list.
Signed-off-by: Martin Nyhus <martin.nyhus@gmx.com>
Signed-off-by: Matthew Garrett <mjg@redhat.com>
Cc: Guenter Roeck <guenter.roeck@ericsson.com>
Tested-by: Jens Gustedt <Jens.Gustedt@loria.fr>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
drivers/platform/x86/dell-laptop.c | 1 +
1 file changed, 1 insertion(+)
--- a/drivers/platform/x86/dell-laptop.c
+++ b/drivers/platform/x86/dell-laptop.c
@@ -211,6 +211,7 @@ static struct dmi_system_id __devinitdat
},
.driver_data = &quirk_dell_vostro_v130,
},
+ { }
};
static struct calling_interface_buffer *buffer;

View File

@ -110,3 +110,4 @@
+ bugfix/x86/drm-i915-fix-integer-overflow-in-i915_gem_execbuffer2.patch
+ bugfix/x86/drm-i915-fix-integer-overflow-in-i915_gem_do_execbuffer.patch
+ bugfix/all/revert-autofs-work-around-unhappy-compat-problem-on-.patch
+ bugfix/x86/dell-laptop-terminate-quirks-list-properly.patch