Update to 4.0.4

Drop patches that were applied upstream.

Changelog still needs trimming.

svn path=/dists/sid/linux/; revision=22662
This commit is contained in:
Ben Hutchings 2015-05-20 00:22:50 +00:00
parent e0fa49030a
commit a6e1905b8a
5 changed files with 131 additions and 102 deletions

133
debian/changelog vendored
View File

@ -1,8 +1,137 @@
linux (4.0.2-2) UNRELEASED; urgency=medium
linux (4.0.4-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.3
- bpf: fix 64-bit divide
- route: Use ipv4_mtu instead of raw rt_pmtu
- mlx4: Fix tx ring affinity_mask creation
- cxgb4: Fix MC1 memory offset calculation
- net/mlx4_en: Schedule napi when RX buffers allocation fails
- [mips*] BCM63xx: Move bcm63xx_gpio_init() to bcm63xx_register_devices().
- [mips*] OCTEON: dma-octeon: fix OHCI USB config check
- [mips*] OCTEON: Use correct CSR to soft reset
- [mips*] Revert "MIPS: Remove race window in page fault handling"
- [mips*] Fix race condition in lazy cache flushing.
- [mips*] Octeon: Remove udelay() causing huge IRQ latency
- [mips*] OCTEON: fix PCI interrupt mapping for D-Link DSR-1000N
- [mips*] Netlogic: Fix for SATA PHY init
- [mips*] Kconfig: Fix typo for the r2-to-r6 emulator kernel parameter
- [mips*] r4kcache: Use correct base register for MIPS R6 cache flushes
- [mips*] asm: spinlock: Fix addiu instruction for R10000_LLSC_WAR case
- [mips*] kernel: entry.S: Set correct ISA level for mips_ihb
- [mips*] Fix cpu_has_mips_r2_exec_hazard.
- [mips*] Octeon: Delete override of cpu_has_mips_r2_exec_hazard.
- [mips*] Revert "MIPS: Avoid pipeline stalls on some MIPS32R2 cores."
- SSB: fix Kconfig dependencies
- [mips*] ralink: Fix bad config symbol in PCI makefile.
- [mips*] ralink: add missing symbol for RALINK_ILL_ACC
- [mips*] smp-cps: cpu_set FPU mask if FPU present
- [mips*] Kconfig: Disable SMP/CPS for 64-bit
- [mips*] BCM47XX: Fix detecting Microsoft MN-700 & Asus WL500G
- [mips*] asm: elf: Set O32 default FPU flags
- [mips*] Makefile: Fix MIPS ASE detection code
- ALSA: emux: Fix mutex deadlock at unloading
- ALSA: emux: Fix mutex deadlock in OSS emulation
- ALSA: emu10k1: Fix card shortname string buffer overflow
- ALSA: emu10k1: Emu10k2 32 bit DMA mode
- ALSA: hda - Fix mute-LED fixed mode
- ALSA: hda - Add mute-LED mode control to Thinkpad
- cdc-acm: prevent infinite loop when parsing CDC headers.
- serial: of-serial: Remove device_type = "serial" registration
- serial: xilinx: Use platform_get_irq to get irq description structure
- [arm64] dma-mapping: always clear allocated buffers
- [arm64] add missing PAGE_ALIGN() to __dma_free()
- usb: chipidea: otg: remove mutex unlock and lock while stop and start role
- ASoC: samsung: s3c24xx-i2s: Fix return value check in
s3c24xx_iis_dev_probe()
- ASoC: tfa9879: Fix return value check in tfa9879_i2c_probe()
- ASoC: rt5677: add register patch for PLL
- ASoC: dapm: Enable autodisable on SOC_DAPM_SINGLE_TLV_AUTODISABLE
- ASoC: rt5677: fixed wrong DMIC ref clock
- btrfs: unlock i_mutex after attempting to delete subvolume during send
- ACPI / SBS: Enable battery manager when present
- tty/serial: at91: maxburst was missing for dma transfers
- rbd: end I/O the entire obj_request on error
- ext4: fix data corruption caused by unwritten and delayed extents
(Closes: #785672)
- ext4: move check under lock scope to close a race.
- SCSI: add 1024 max sectors black list flag
- 3w-xxxx: fix command completion race
- 3w-9xxx: fix command completion race
- 3w-sas: fix command completion race
- drm/radeon: fix ordering of AVI packet setup
- drm/radeon: drop dce6_dp_enable
- drm/radeon/audio: don't enable packets until the end
- drm/radeon: only mark audio as connected if the monitor supports it (v3)
- drm/radeon: only enable audio streams if the monitor supports it
- drm/radeon: Use drm_calloc_ab for CS relocs
- drm/radeon: adjust pll when audio is not enabled
- drm/radeon: add SI DPM quirk for Sapphire R9 270 Dual-X 2G GDDR5
- drm/radeon: fix lockup when BOs aren't part of the VM on release
- drm/radeon: reset BOs address after clearing it.
- drm/radeon: check new address before removing old one
- hfsplus: don't store special "osx" xattr prefix on-disk
- [x86] Drivers: hv: vmbus: Don't wait after requesting offers
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.4
- [x86] spinlocks: Fix regression in spinlock contention detection
- [x86] ACPI / SBS: Add 5 us delay to fix SBS hangs on MacBook
- [x86] PCI/ACPI: Make all resources except [io 0xcf8-0xcff] available on
PCI bus
- ACPI / PNP: add two IDs to list for PNPACPI device enumeration
- ocfs2: dlm: fix race between purge and get lock resource
- rtc: armada38x: fix concurrency access in armada38x_rtc_set_time
- nilfs2: fix sanity check of btree level in nilfs_btree_root_broken()
- RDMA/CMA: Canonize IPv4 on IPV6 sockets properly
- gpio: sysfs: fix memory leaks and device hotplug
- mnt: Fix fs_fully_visible to verify the root directory is visible
- mm/memory-failure: call shake_page() when error hits thp tail page
- writeback: use |1 instead of +1 to protect against div by zero
- mm: soft-offline: fix num_poisoned_pages counting on concurrent events
- marvell-ccic: fix Y'CbCr ordering
- vfio: Fix runaway interruptible timeout
- xen/events: Clear cpu_evtchn_mask before resuming
- xen/xenbus: Update xenbus event channel on resume
- xen/console: Update console event channel on resume
- xen/events: Set irq_info->evtchn before binding the channel to CPU in
__startup_pirq()
- xen-pciback: Add name prefix to global 'permissive' variable
- Revert "dm crypt: fix deadlock when async crypto algorithm returns -EBUSY"
- block: destroy bdi before blockdev is unregistered.
- blk-mq: fix race between timeout and CPU hotplug
- blk-mq: fix CPU hotplug handling
- [armhf] dts: OMAP3-N900: Add microphone bias voltages
- [armhf] dts: imx6: phyFLEX: USB VBUS control is active-high
- [armhf] mvebu: armada-xp-openblocks-ax3-4: Disable internal RTC
- [armhf] OMAP2+: Fix omap off idle power consumption creeping up
- [armel,armhf] net fix emit_udiv() for BPF_ALU | BPF_DIV | BPF_K intruction.
- drm: Zero out invalid vblank timestamp in drm_update_vblank_count.
- [x86] drm/i915: Assume dual channel LVDS if pixel clock necessitates it
- [x86] drm/i915: Add missing MacBook Pro models with dual channel LVDS
- [x86] drm/i915/dp: there is no audio on port A
- [x86] drm/amdkfd: allow unregister process with queues
- [x86] drm/amdkfd: Initialize sdma vm when creating sdma queue
- drm/radeon: disable semaphores for UVD V1 (v2)
- drm/radeon: don't setup audio on asics that don't support it
- drm/radeon: fix userptr BO unpin bug v3
- drm/radeon: make VCE handle check more strict
- drm/radeon: make UVD handle checking more strict
- drm/radeon: more strictly validate the UVD codec
- pinctrl: Don't just pretend to protect pinctrl_maps, do it for real
- mmc: card: Don't access RPMB partitions for normal read/write
- mmc: core: add missing pm event in mmc_pm_notify to fix hib restore
- [armhf] 8307/1: psci: move psci firmware calls out of line
- sound/oss: fix deadlock in sequencer_ioctl(SNDCTL_SEQ_OUTOFBAND)
- coredump: accept any write method
- ACPICA: Tables: Change acpi_find_root_pointer() to use
acpi_physical_address.
- ACPICA: Utilities: Cleanup to enforce ACPI_PHYSADDR_TO_PTR()/
ACPI_PTR_TO_PHYSADDR().
- ACPICA: Utilities: Cleanup to convert physical address printing formats.
- ACPICA: Utilities: Cleanup to remove useless ACPI_PRINTF/FORMAT_xxx
helpers.
[ Ben Hutchings ]
* Fix error messages at boot on systems without an RTC (Closes: #784146):
- [armhf] mvebu: armada-xp-openblocks-ax3-4: Disable internal RTC
- rtc: hctosys: do not treat lack of RTC device as error
- rtc: hctosys: use function name in the error log

View File

@ -1,29 +0,0 @@
From: "David S. Miller" <davem@davemloft.net>
Date: Fri, 1 May 2015 22:02:47 -0400
Subject: ipv4: Missing sk_nulls_node_init() in ping_unhash().
Origin: https://git.kernel.org/linus/a134f083e79fb4c3d0a925691e732c56911b4326
If we don't do that, then the poison value is left in the ->pprev
backlink.
This can cause crashes if we do a disconnect, followed by a connect().
Tested-by: Linus Torvalds <torvalds@linux-foundation.org>
Reported-by: Wen Xu <hotdog3645@gmail.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/ipv4/ping.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/net/ipv4/ping.c b/net/ipv4/ping.c
index a93f260..05ff44b 100644
--- a/net/ipv4/ping.c
+++ b/net/ipv4/ping.c
@@ -158,6 +158,7 @@ void ping_unhash(struct sock *sk)
if (sk_hashed(sk)) {
write_lock_bh(&ping_table.lock);
hlist_nulls_del(&sk->sk_nulls_node);
+ sk_nulls_node_init(&sk->sk_nulls_node);
sock_put(sk);
isk->inet_num = 0;
isk->inet_sport = 0;

View File

@ -1,34 +0,0 @@
From: Al Viro <viro@zeniv.linux.org.uk>
Date: Fri, 8 May 2015 22:53:15 -0400
Subject: path_openat(): fix double fput()
Origin: https://git.kernel.org/linus/f15133df088ecadd141ea1907f2c96df67c729f0
path_openat() jumps to the wrong place after do_tmpfile() - it has
already done path_cleanup() (as part of path_lookupat() called by
do_tmpfile()), so doing that again can lead to double fput().
Cc: stable@vger.kernel.org # v3.11+
Signed-off-by: Al Viro <viro@zeniv.linux.org.uk>
---
fs/namei.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -3228,7 +3228,7 @@ static struct file *path_openat(int dfd,
if (unlikely(file->f_flags & __O_TMPFILE)) {
error = do_tmpfile(dfd, pathname, nd, flags, op, file, &opened);
- goto out;
+ goto out2;
}
error = path_init(dfd, pathname->name, flags, nd);
@@ -3258,6 +3258,7 @@ static struct file *path_openat(int dfd,
}
out:
path_cleanup(nd);
+out2:
if (!(opened & FILE_OPENED)) {
BUG_ON(!error);
put_filp(file);

View File

@ -1,34 +0,0 @@
From: Gregory CLEMENT <gregory.clement@free-electrons.com>
Date: Tue, 14 Apr 2015 11:50:13 +0200
Subject: ARM: mvebu: armada-xp-openblocks-ax3-4: Disable internal RTC
Origin: https://git.kernel.org/linus/750e30d4076ae5e02ad13a376e96c95a2627742c
Bug-Debian: https://bugs.debian.org/784146
There is no crystal connected to the internal RTC on the Open Block
AX3. So let's disable it in order to prevent the kernel probing the
driver uselessly. Eventually this patches removes the following
warning message from the boot log:
"rtc-mv d0010300.rtc: internal RTC not ticking"
Acked-by: Andrew Lunn <andrew@lunn.ch>
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
Cc: <stable@vger.kernel.org> # v3.8 +
---
arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts b/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts
index e3b08fb..990e8a2 100644
--- a/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts
+++ b/arch/arm/boot/dts/armada-xp-openblocks-ax3-4.dts
@@ -105,6 +105,10 @@
};
internal-regs {
+ rtc@10300 {
+ /* No crystal connected to the internal RTC */
+ status = "disabled";
+ };
serial@12000 {
status = "okay";
};

View File

@ -64,10 +64,7 @@ debian/emmc-don-t-initialize-partitions-on-rpmb-flagged-areas.patch
# Miscellaneous features
features/all/efi-autoload-efi-pstore.patch
bugfix/all/ipv4-missing-sk_nulls_node_init-in-ping_unhash.patch
bugfix/all/path_openat-fix-double-fput.patch
bugfix/all/mnt-fail-collect_mounts-when-applied-to-unmounted-mo.patch
bugfix/all/fs_pin-allow-for-the-possibility-that-m_list-or-s_li.patch
bugfix/arm/arm-mvebu-armada-xp-openblocks-ax3-4-disable-interna.patch
bugfix/all/rtc-hctosys-do-not-treat-lack-of-rtc-device-as-error.patch
bugfix/all/rtc-hctosys-use-function-name-in-the-error-log.patch