* net-ipconntrack-nat-fix.patch - fix compilation of

ip_conntrack_helper_pptp.c when NAT is disabled. (Closes: #336431)

svn path=/dists/sid/linux-2.6/; revision=4727
This commit is contained in:
dann frazier 2005-11-04 04:24:17 +00:00
parent 032be5ae05
commit a6c5933820
3 changed files with 43 additions and 1 deletions

6
debian/changelog vendored
View File

@ -22,7 +22,11 @@ linux-2.6 (2.6.14-3) UNRELEASED; urgency=low
all sorts of weird stuff happens which is hard for the inird builders to
automatically compenste for. (Closes: #336450)
-- Simon Horman <horms@debian.org> Fri, 4 Nov 2005 13:03:49 +0900
[ dann frazier ]
* net-ipconntrack-nat-fix.patch - fix compilation of
ip_conntrack_helper_pptp.c when NAT is disabled. (Closes: #336431)
-- dann frazier <dannf@debian.org> Thu, 3 Nov 2005 21:20:29 -0700
linux-2.6 (2.6.14-2) unstable; urgency=low

View File

@ -0,0 +1,37 @@
diff --git a/net/ipv4/netfilter/ip_conntrack_helper_pptp.c b/net/ipv4/netfilter/ip_conntrack_helper_pptp.c
--- a/net/ipv4/netfilter/ip_conntrack_helper_pptp.c
+++ b/net/ipv4/netfilter/ip_conntrack_helper_pptp.c
@@ -270,14 +270,10 @@ exp_gre(struct ip_conntrack *master,
exp_orig->expectfn = pptp_expectfn;
exp_orig->flags = 0;
- exp_orig->dir = IP_CT_DIR_ORIGINAL;
-
/* both expectations are identical apart from tuple */
memcpy(exp_reply, exp_orig, sizeof(*exp_reply));
memcpy(&exp_reply->tuple, &exp_tuples[1], sizeof(exp_reply->tuple));
- exp_reply->dir = !exp_orig->dir;
-
if (ip_nat_pptp_hook_exp_gre)
ret = ip_nat_pptp_hook_exp_gre(exp_orig, exp_reply);
else {
diff --git a/net/ipv4/netfilter/ip_nat_helper_pptp.c b/net/ipv4/netfilter/ip_nat_helper_pptp.c
--- a/net/ipv4/netfilter/ip_nat_helper_pptp.c
+++ b/net/ipv4/netfilter/ip_nat_helper_pptp.c
@@ -216,6 +216,7 @@ pptp_exp_gre(struct ip_conntrack_expect
expect_orig->saved_proto.gre.key = htons(nat_pptp_info->pac_call_id);
expect_orig->tuple.src.u.gre.key = htons(nat_pptp_info->pns_call_id);
expect_orig->tuple.dst.u.gre.key = htons(ct_pptp_info->pac_call_id);
+ expect_orig->dir = IP_CT_DIR_ORIGINAL;
inv_t.src.ip = reply_t->src.ip;
inv_t.dst.ip = reply_t->dst.ip;
inv_t.src.u.gre.key = htons(nat_pptp_info->pac_call_id);
@@ -233,6 +234,7 @@ pptp_exp_gre(struct ip_conntrack_expect
expect_reply->saved_proto.gre.key = htons(nat_pptp_info->pns_call_id);
expect_reply->tuple.src.u.gre.key = htons(nat_pptp_info->pac_call_id);
expect_reply->tuple.dst.u.gre.key = htons(ct_pptp_info->pns_call_id);
+ expect_reply->dir = IP_CT_DIR_REPLY;
inv_t.src.ip = orig_t->src.ip;
inv_t.dst.ip = orig_t->dst.ip;
inv_t.src.u.gre.key = htons(nat_pptp_info->pns_call_id);

1
debian/patches-debian/series/2.6.14-3 vendored Normal file
View File

@ -0,0 +1 @@
+ net-ipconntrack-nat-fix.patch