KVM: nVMX: Don't emulate instructions in guest mode (CVE-2020-2732)

This commit is contained in:
Salvatore Bonaccorso 2020-04-26 20:31:39 +02:00
parent 5cdd44bf16
commit a688ee48fb
3 changed files with 42 additions and 0 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux (4.19.98-1+deb10u1) UNRELEASED; urgency=medium
* [x86] KVM: nVMX: Don't emulate instructions in guest mode (CVE-2020-2732)
-- Salvatore Bonaccorso <carnil@debian.org> Sun, 26 Apr 2020 20:32:58 +0200
linux (4.19.98-1) buster; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,35 @@
From: Paolo Bonzini <pbonzini@redhat.com>
Date: Tue, 4 Feb 2020 15:26:29 -0800
Subject: KVM: nVMX: Don't emulate instructions in guest mode
Origin: https://git.kernel.org/linus/07721feee46b4b248402133228235318199b05ec
Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2020-2732
vmx_check_intercept is not yet fully implemented. To avoid emulating
instructions disallowed by the L1 hypervisor, refuse to emulate
instructions by default.
Cc: stable@vger.kernel.org
[Made commit, added commit msg - Oliver]
Signed-off-by: Oliver Upton <oupton@google.com>
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
[Salvatore Bonaccorso: Backport to 4.19: Adjust filename to arch/x86/kvm/vmx.c]
---
arch/x86/kvm/vmx/vmx.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/kvm/vmx.c b/arch/x86/kvm/vmx.c
index dcca514ffd42..5801a86f9c24 100644
--- a/arch/x86/kvm/vmx.c
+++ b/arch/x86/kvm/vmx.c
@@ -7164,7 +7164,7 @@ static int vmx_check_intercept(struct kvm_vcpu *vcpu,
}
/* TODO: check more intercepts... */
- return X86EMUL_CONTINUE;
+ return X86EMUL_UNHANDLEABLE;
}
#ifdef CONFIG_X86_64
--
2.26.2

View File

@ -304,6 +304,7 @@ debian/ntfs-mark-it-as-broken.patch
bugfix/all/libertas-fix-two-buffer-overflows-at-parsing-bss-descriptor.patch
bugfix/all/wimax-i2400-fix-memory-leak.patch
bugfix/all/wimax-i2400-fix-memory-leak-in-i2400m_op_rfkill_sw_toggle.patch
bugfix/x86/KVM-nVMX-Don-t-emulate-instructions-in-guest-mode.patch
# Backported change to provide boot-time entropy
bugfix/all/random-try-to-actively-add-entropy-rather-than-passi.patch