QNAP TS-419P: Export GPIO indicating jumper setting of JP1.

svn path=/dists/sid/linux-2.6/; revision=15773
This commit is contained in:
Martin Michlmayr 2010-05-26 10:11:47 +00:00
parent 156ced5744
commit a53b205604
3 changed files with 40 additions and 0 deletions

3
debian/changelog vendored
View File

@ -30,6 +30,9 @@ linux-2.6 (2.6.32-14) UNRELEASED; urgency=low
* Add drm changes from stable 2.6.33.5.
* Update openvz patch to 509eb1f29c43.
[ Martin Michlmayr ]
* QNAP TS-419P: Export GPIO indicating jumper setting of JP1.
-- Ben Hutchings <ben@decadent.org.uk> Tue, 18 May 2010 02:13:44 +0100
linux-2.6 (2.6.32-13) unstable; urgency=low

View File

@ -0,0 +1,36 @@
Kirkwood: Export GPIO indicating jumper setting of JP1
Export GPIO 45 which is used to indicate the setting of the JP1
jumper. This is useful for userland tools, such as qcontrol, to
see whether the LCD or a serial console is connected.
Signed-off-by: Martin Michlmayr <tbm@cyrius.com>
--- a/arch/arm/mach-kirkwood/ts41x-setup.c 2010-05-21 19:27:57.000000000 +0000
+++ b/arch/arm/mach-kirkwood/ts41x-setup.c 2010-05-21 19:28:34.000000000 +0000
@@ -21,6 +21,7 @@
#include <linux/i2c.h>
#include <linux/mv643xx_eth.h>
#include <linux/ata_platform.h>
+#include <linux/gpio.h>
#include <linux/gpio_keys.h>
#include <linux/input.h>
#include <linux/timex.h>
@@ -32,6 +33,8 @@
#include "common.h"
#include "mpp.h"
+#define QNAP_TS41X_JUMPER_JP1 45
+
/****************************************************************************
* 16 MiB NOR flash. The struct mtd_partition is not in the same order as the
* partitions on the device because we want to keep compatability with
@@ -230,6 +233,8 @@
pm_power_off = qnap_ts41x_power_off;
+ if (gpio_request(QNAP_TS41X_JUMPER_JP1, "JP1") == 0)
+ gpio_export(QNAP_TS41X_JUMPER_JP1, 0);
}
static int __init ts41x_pci_init(void)

View File

@ -19,3 +19,4 @@
+ bugfix/all/ext4-Conditionally-define-compat-ioctl-numbers.patch
+ bugfix/all/ext4-Fix-compat-EXT4_IOC_ADD_GROUP.patch
+ bugfix/all/net-sysfs-ethtool_ops-can-be-NULL.patch
+ features/arm/ts41x-export-jp1.patch