Update to 3.16.7

svn path=/dists/sid/linux/; revision=21983
This commit is contained in:
Ben Hutchings 2014-10-31 00:14:51 +00:00
parent e503206b31
commit a2ba347d6d
3 changed files with 109 additions and 36 deletions

112
debian/changelog vendored
View File

@ -1,8 +1,114 @@
linux (3.16.5-2) UNRELEASED; urgency=medium
linux (3.16.7-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.16.6
- rtnetlink: fix VF info size (regression in 3.11)
- myri10ge: check for DMA mapping errors
- Revert "macvlan: simplify the structure port" (regression in 3.16)
- tcp: don't use timestamp from repaired skb-s to calculate RTT (v2)
(regression in 3.15)
- tcp: fix tcp_release_cb() to dispatch via address family for
mtu_reduced()
- tipc: fix message importance range check (regression in 3.15)
- packet: handle too big packets for PACKET_V3
- bnx2x: Revert UNDI flushing mechanism (regression in 3.14)
- net: ipv6: fib: don't sleep inside atomic lock (regression in 3.15)
- openvswitch: fix panic with multiple vlan headers
- ipv6: fix rtnl locking in setsockopt for anycast and multicast
- l2tp: fix race while getting PMTU on PPP pseudo-wire (regression in 3.15)
- ipv6: restore the behavior of ipv6_sock_ac_drop()
- bonding: fix div by zero while enslaving and transmitting
(regression in 3.12)
- net: filter: fix possible use after free (regression in 3.15)
- net: allow macvlans to move to net namespace (regression in 3.13)
- macvlan: allow to enqueue broadcast pkt on virtual device
(regression in 3.16)
- xfrm: Generate blackhole routes only from route lookup functions
- xfrm: Generate queueing routes only from route lookup functions
- macvtap: Fix race between device delete and open.
- net/mlx4_core: Allow not to specify probe_vf in SRIOV IB mode
(regression in 3.15)
- net/mlx4: Correctly configure single ported VFs from the host
(regression in 3.15)
- gro: fix aggregation for skb using frag_list (regression in 3.13)
- hyperv: Fix bug in netvsc_start_xmit() (potential use-after-free)
- team: avoid race condition in scheduling delayed work
- hyperv: Fix bug in netvsc_send() (potential use-after-free)
- sctp: handle association restarts when the socket is closed.
- net_sched: copy exts->type in tcf_exts_change() (regression in 3.14)
- crypto: caam - fix addressing of struct member
- driver/base/node: remove unnecessary kfree of node struct from
unregister_one_node (regression in 3.15)
https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.16.7
- btrfs: wake up transaction thread from SYNC_FS ioctl
- Btrfs: fix up bounds checking in lseek
- Btrfs: don't do async reclaim during log replay
- Btrfs: cleanup error handling in build_backref_tree
- Btrfs: fix build_backref_tree issue with multiple shared blocks
- Btrfs: fix race in WAIT_SYNC ioctl
- fs: Add a missing permission check to do_umount (CVE-2014-7975)
- kvm: fix potentially corrupt mmio cache
- [x86] kvm,vmx: Preserve CR4 across VM entry (CVE-2014-3690)
- be2iscsi: check ip buffer before copying (stack buffer overflow)
- mptfusion: enable no_write_same for vmware scsi disks
- qla2xxx: fix kernel NULL pointer access (regression in 3.16)
(Closes: #764804)
- qla2xxx: Fix shost use-after-free on device removal (regression in 3.14)
- dmaengine: fix xor sources continuation
- [arm64] debug: don't re-enable debug exceptions on return from el1_dbg
- mei: bus: fix possible boundaries violation
- nfsv4: Fixing lease renewal (regression in 3.13)
- lzo: check for length overrun in variable length encoding.
- [armhf] tty: omap-serial: fix division by zero
- NFSv4: Fix lock recovery when CREATE_SESSION/SETCLIENTID_CONFIRM fails
- NFSv4: fix open/lock state recovery error handling
- NFSv4.1: Fix an NFSv4.1 state renewal regression
- nfsd4: reserve adequate space for LOCK op (regression in 3.16)
- NFS: Fix an uninitialised pointer Oops in the writeback error path
- NFS: Fix a bogus warning in nfs_generic_pgio (regression in 3.16.4)
- iwlwifi: mvm: disable BT Co-running by default
- [armel,armhf] PCI: mvebu: Fix uninitialized variable in
mvebu_get_tgt_attr()
- Revert "ath9k_hw: reduce ANI firstep range for older chips"
(regression in 3.15)
- fanotify: enable close-on-exec on events' fd when requested in
fanotify_init()
- futex: Ensure get_futex_key_refs() always implies a barrier
(regression in 3.14)
- [ppc64el] iommu/ddw: Fix endianness
- [arm64] compat: fix compat types affecting struct compat_elf_prpsinfo
- ALSA: emu10k1: Fix deadlock in synth voice lookup
- ALSA: hda - Add missing terminating entry to SND_HDA_PIN_QUIRK macro
- [armhf] mvebu: Netgear RN104: Use Hardware BCH ECC
- [armhf] mvebu: Netgear RN2120: Use Hardware BCH ECC
- [armhf] mvebu: Netgear RN102: Use Hardware BCH ECC
- ecryptfs: avoid to access NULL pointer when write metadata in xattr
- xfs: ensure WB_SYNC_ALL writeback handles partial pages correctly
- [sparc*] Do not disable interrupts in nmi_cpu_busy()
- [sparc*] Fix pcr_ops initialization and usage bugs.
- [sparc*] sun4v TLB error power off events
- [sparc*] Fix corrupted thread fault code.
- [sparc*] find_node adjustment
- [sparc*] Let memset return the address argument
- [sparc*] bpf_jit: fix support for ldx/stx mem and SKF_AD_VLAN_TAG
- [sparc*] bpf_jit: fix loads from negative offsets
- [sparc*] Fix FPU register corruption with AES crypto offload.
- [sparc*] Do not define thread fpregs save area as zero-length array.
- [sparc*] Fix hibernation code refrence to PAGE_OFFSET.
- [sparc*] correctly recognise M6 and M7 cpu type
- [sparc*] T5 PMU
- [sparc*] Switch to 4-level page tables.
- [sparc*] Adjust KTSB assembler to support larger physical addresses.
- [sparc*] Fix physical memory management regressions with large
max_phys_bits.
- [sparc*] Use kernel page tables for vmemmap.
- [sparc*] Increase MAX_PHYS_ADDRESS_BITS to 53.
- [sparc*] sparse irq
- [sparc*] Fix register corruption in top-most kernel stack frame during
boot.
- [sparc*] Implement __get_user_pages_fast().
[ Ben Hutchings ]
* qla2xxx: fix kernel NULL pointer access (regression in 3.16)
(Closes: #764804)
* [i386/486] Update description to say that the processor must have a TSC
(see #766105)
* [x86] r8723au: Backport changes up to Linux 3.17 (Closes: #765685)

View File

@ -1,32 +0,0 @@
From: Himanshu Madhani <himanshu.madhani@qlogic.com>
Date: Thu, 25 Sep 2014 06:14:44 -0400
Subject: qla2xxx: fix kernel NULL pointer access
Origin: https://git.kernel.org/linus/78c2106a50e067f7168ee8c0944baaeb0e988272
This patch is to fix regression added by commit id
51a07f84649d2be206c4c2ad9a612956db0c2f8c.
When allocating memory for new session original patch does
not assign vha to op->vha resulting into NULL pointer
access during qlt_create_sess_from_atio().
Cc: <stable@vger.kernel.org>
Signed-off-by: Himanshu Madhani <himanshu.madhani@qlogic.com>
Signed-off-by: Saurav Kashyap <saurav.kashyap@qlogic.com>
Signed-off-by: Christoph Hellwig <hch@lst.de>
---
drivers/scsi/qla2xxx/qla_target.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/scsi/qla2xxx/qla_target.c b/drivers/scsi/qla2xxx/qla_target.c
index aebe62c..43f9177 100644
--- a/drivers/scsi/qla2xxx/qla_target.c
+++ b/drivers/scsi/qla2xxx/qla_target.c
@@ -3277,6 +3277,7 @@ static int qlt_handle_cmd_for_atio(struct scsi_qla_host *vha,
return -ENOMEM;
memcpy(&op->atio, atio, sizeof(*atio));
+ op->vha = vha;
INIT_WORK(&op->work, qlt_create_sess_from_atio);
queue_work(qla_tgt_wq, &op->work);
return 0;

View File

@ -389,7 +389,6 @@ features/all/r8723au/0249-staging-rtl8723au-Fix-static-symbol-sparse-warning.pat
bugfix/s390/s390-3215-fix-tty-output-containing-tabs.patch
bugfix/all/fold-swapping-d_name.hash-into-switch_names.patch
bugfix/all/vfs-Don-t-exchange-short-filenames-unconditionally.patch
bugfix/all/qla2xxx-fix-kernel-NULL-pointer-access.patch
features/all/mmc_block-increase-max_devices.patch
bugfix/x86/drm-i915-initialise-userptr-mmu_notifier-serial-to-1.patch
bugfix/all/rtsx_usb_ms-use-msleep_interruptible-in-polling-loop.patch