swap: Avoid ABI change in 4.13.12

This commit is contained in:
Ben Hutchings 2017-11-12 01:09:18 +00:00
parent 86b8621ec9
commit a2708107ce
3 changed files with 33 additions and 0 deletions

1
debian/changelog vendored
View File

@ -90,6 +90,7 @@ linux (4.13.12-1) UNRELEASED; urgency=medium
* linux-image: Recommend apparmor, as systemd units with an AppArmor
profile will fail without it (Closes: #880441)
* [powerpc*] kvm: Ignore ABI change in 4.13.6 (fixes FTBFS)
* swap: Avoid ABI change in 4.13.12
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 04 Nov 2017 09:54:41 +0100

View File

@ -0,0 +1,31 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sun, 12 Nov 2017 01:03:55 +0000
Subject: swap: Avoid ABI change in 4.13.12
Forwarded: not-neede
Commit 2628bd6fc052 "mm, swap: fix race between swap count
continuation operations" added a field to struct swap_info_struct.
swap_info_struct is always allocated in built-in code and modules
won't use this new field, so move it to the end of the structure and
hide it from genksyms.
---
--- a/include/linux/swap.h
+++ b/include/linux/swap.h
@@ -246,12 +246,14 @@ struct swap_info_struct {
* both locks need hold, hold swap_lock
* first.
*/
+ struct work_struct discard_work; /* discard worker */
+ struct swap_cluster_list discard_clusters; /* discard clusters list */
+#ifndef __GENKSYMS__
spinlock_t cont_lock; /*
* protect swap count continuation page
* list.
*/
- struct work_struct discard_work; /* discard worker */
- struct swap_cluster_list discard_clusters; /* discard clusters list */
+#endif
};
/* linux/mm/workingset.c */

View File

@ -137,3 +137,4 @@ debian/dax-avoid-abi-change-in-4.13.5.patch
debian/revert-bpf-one-perf-event-close-won-t-free-bpf-program-atta.patch
debian/mac80211-avoid-abi-change-in-4.13.5.patch
debian/keys-limit-abi-change-in-4.13.10.patch
debian/swap-avoid-abi-change-in-4.13.12.patch