tracing/mm: Move include of trace/events/kmem.h out of header into slab.c

svn path=/dists/sid/linux/; revision=19186
This commit is contained in:
Ben Hutchings 2012-06-23 22:29:25 +00:00
parent 6eb32a96cc
commit a21b0afd1f
3 changed files with 57 additions and 1 deletions

4
debian/changelog vendored
View File

@ -1,7 +1,9 @@
linux (3.2.21-2) UNRELEASED; urgency=low
* [i386] cpufreq/gx: Fix the compile error
* [powerpc] Enable PPC_DISABLE_WERROR
* [powerpc] Enable PPC_DISABLE_WERROR (fixes FTBFS)
* tracing/mm: Move include of trace/events/kmem.h out of header into slab.c
(fixes FTBFS on sparc)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 23 Jun 2012 20:19:15 +0100

View File

@ -0,0 +1,53 @@
From: Steven Rostedt <rostedt@goodmis.org>
Date: Mon, 9 Jan 2012 17:15:42 -0500
Subject: tracing/mm: Move include of trace/events/kmem.h out of header into
slab.c
commit 4dee6b64ee7cfef94b47733c6d9fef07f8051c7c upstream.
Including trace/events/*.h TRACE_EVENT() macro headers in other headers
can cause strange side effects if another trace/event/*.h header
includes that header. Having trace/events/kmem.h inside slab_def.h
caused a compile error in sparc64 when changes were done to some header
files. Moving the kmem.h trace header out of slab.h and into slab.c
fixes the problem.
Note, both slub.c and slob.c already include the trace/events/kmem.h
file. Only slab.c had it missing.
Link: http://lkml.kernel.org/r/20120105190405.1e3191fb5a43b2a0f1655e1f@canb.auug.org.au
Reported-by: Stephen Rothwell <sfr@canb.auug.org.au>
Signed-off-by: Steven Rostedt <rostedt@goodmis.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
include/linux/slab_def.h | 2 --
mm/slab.c | 2 ++
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/include/linux/slab_def.h b/include/linux/slab_def.h
index d00e0ba..fbd1117 100644
--- a/include/linux/slab_def.h
+++ b/include/linux/slab_def.h
@@ -15,8 +15,6 @@
#include <asm/cache.h> /* kmalloc_sizes.h needs L1_CACHE_BYTES */
#include <linux/compiler.h>
-#include <trace/events/kmem.h>
-
/*
* struct kmem_cache
*
diff --git a/mm/slab.c b/mm/slab.c
index 83311c9a..2acfa0d 100644
--- a/mm/slab.c
+++ b/mm/slab.c
@@ -121,6 +121,8 @@
#include <asm/tlbflush.h>
#include <asm/page.h>
+#include <trace/events/kmem.h>
+
/*
* DEBUG - 1 for kmem_cache_create() to honour; SLAB_RED_ZONE & SLAB_POISON.
* 0 for faster, smaller code (especially in the critical paths).

View File

@ -341,6 +341,7 @@ features/all/cpu-devices/powernow-k6-Really-enable-auto-loading.patch
features/all/cpu-devices/intel_idle-Revert-change-of-auto_demotion_disable_fl.patch
features/all/cpu-devices/Partially-revert-cpufreq-Add-support-for-x86-cpuinfo.patch
features/all/cpu-devices/cpufreq-gx-Fix-the-compile-error.patch
features/all/cpu-devices/tracing-mm-Move-include-of-trace-events-kmem.h-out-o.patch
features/arm/kirkwood-add-dreamplug-fdt-support.patch
features/arm/kirkwood-fdt-convert-uart0-to-devicetree.patch