[mips,mipsel] Add dependencies for HAVE_ARCH_TRANSPARENT_HUGEPAGE (fixes FTBFS)

svn path=/dists/trunk/linux/; revision=19899
This commit is contained in:
Ben Hutchings 2013-03-04 04:18:32 +00:00
parent 533dace9d4
commit a1184cd476
3 changed files with 27 additions and 0 deletions

2
debian/changelog vendored
View File

@ -11,6 +11,8 @@ linux (3.8.1-1~experimental.1) UNRELEASED; urgency=low
* net: Enable USB_NET_CDC_MBIM as module (Closes: #701869)
* mfd,mmc,memstick: Enable MFD_RTSX_PCI, MMC_REALTEK_PCI and
MEMSTICK_REALTEK_PCI as modules, replacing RTS_PSTOR (Closes: #702108)
* [mips,mipsel] Add dependencies for HAVE_ARCH_TRANSPARENT_HUGEPAGE
(fixes FTBFS)
[ Aurelien Jarno ]
* [mips/octeon] Change HW_RANDOM and HW_RANDOM_OCTEON to modules.

View File

@ -0,0 +1,24 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: MIPS: Add dependencies for HAVE_ARCH_TRANSPARENT_HUGEPAGE
Date: Mon, 04 Mar 2013 03:54:29 +0000
The MIPS implementation of transparent huge-pages (THP) is 64-bit only,
and of course also requires that the CPU supports huge-pages.
Currently it's entirely possible to enable THP in other configurations,
which then fail to build due to pfn_pmd() not being defined.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Cc: David Daney <david.daney@cavium.com>
---
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -19,7 +19,7 @@ config MIPS
select HAVE_KRETPROBES
select HAVE_DEBUG_KMEMLEAK
select ARCH_BINFMT_ELF_RANDOMIZE_PIE
- select HAVE_ARCH_TRANSPARENT_HUGEPAGE
+ select HAVE_ARCH_TRANSPARENT_HUGEPAGE if CPU_SUPPORTS_HUGEPAGES && 64BIT
select RTC_LIB if !MACH_LOONGSON
select GENERIC_ATOMIC64 if !64BIT
select ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE

View File

@ -79,3 +79,4 @@ bugfix/x86/drm-i915-add-quirk-to-invert-brightness-on-packard-bell-ncl20.patch
bugfix/all/mm-Try-harder-to-allocate-vmemmap-blocks.patch
bugfix/x86/x86-efi-Make-noefi-really-disable-EFI-runtime-serivc.patch
features/all/alx/alx-update-for-3.8.patch
bugfix/mips/mips-add-dependencies-for-have_arch_transparent_hugepage.patch