xen: microcode: update to latest API.

svn path=/dists/trunk/linux/; revision=19736
This commit is contained in:
Ian Campbell 2013-01-16 19:52:23 +00:00
parent 5d1f93eb6a
commit a070f9769f
3 changed files with 33 additions and 0 deletions

3
debian/changelog vendored
View File

@ -16,6 +16,9 @@ linux (3.7.2-1~experimental.1) UNRELEASED; urgency=low
* udeb: Remove ipv6-modules on all architectures/flavours except for
armel/iop32x (fixes FTBFS)
[ Ian Campbell ]
* [x86/xen] Update microcode driver to use new API.
-- Ben Hutchings <ben@decadent.org.uk> Sun, 06 Jan 2013 04:39:12 +0000
linux (3.7.1-1~experimental.2) experimental; urgency=low

View File

@ -0,0 +1,27 @@
From 7a02502f75547538eb4e99273f1fe2b8d797fbb3 Mon Sep 17 00:00:00 2001
From: Ian Campbell <ijc@hellion.org.uk>
Date: Wed, 16 Jan 2013 13:38:20 +0000
Subject: [PATCH] microcode_xen: update for changed core API
Signed-off-by: Ian Campbell <ijc@hellion.org.uk>
---
arch/x86/kernel/microcode_xen.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/arch/x86/kernel/microcode_xen.c b/arch/x86/kernel/microcode_xen.c
index 9e50566..6b7aa48 100644
--- a/arch/x86/kernel/microcode_xen.c
+++ b/arch/x86/kernel/microcode_xen.c
@@ -56,7 +56,8 @@ static int xen_microcode_update(int cpu)
return err;
}
-static enum ucode_state xen_request_microcode_fw(int cpu, struct device *device)
+static enum ucode_state xen_request_microcode_fw(int cpu, struct device *device,
+ bool refresh_fw)
{
char name[36];
struct cpuinfo_x86 *c = &cpu_data(cpu);
--
1.7.2.5

View File

@ -68,3 +68,6 @@ debian/ast-disable-autoload.patch
debian/mgag200-disable-autoload.patch
clean-modules-without-link-vmlinux.sh.patch
bugfix/all/ath6kl-do-not-use-virt_addr_valid.patch
features/all/xen/microcode-api-update.patch