MIPS: libgcc: Fix ABI change in 4.6.2

This commit is contained in:
Ben Hutchings 2016-06-17 01:50:50 +01:00
parent 966488336f
commit 9edbacb8a5
4 changed files with 110 additions and 3 deletions

2
debian/changelog vendored
View File

@ -1,6 +1,6 @@
linux (4.6.2-2) UNRELEASED; urgency=medium
* [mips*] Fix ABI change in 4.6.2
* [mips*] Fix ABI changes in 4.6.2
-- Ben Hutchings <ben@decadent.org.uk> Thu, 16 Jun 2016 12:37:27 +0100

View File

@ -0,0 +1,106 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 17 Jun 2016 01:46:59 +0100
Subject: MIPS: libgcc: Fix ABI change in 4.6.2
Forwarded: not-needed
Commit aedcfbe06558 ("MIPS: lib: Mark intrinsics notrace") causes the
hashes of these functions to change, even though their ABI hasn't.
Hide the 'notrace' from genksyms.
---
--- a/arch/mips/lib/ashldi3.c
+++ b/arch/mips/lib/ashldi3.c
@@ -2,6 +2,11 @@
#include "libgcc.h"
+#ifdef __GENKSYMS__
+#undef notrace
+#define notrace
+#endif
+
long long notrace __ashldi3(long long u, word_type b)
{
DWunion uu, w;
--- a/arch/mips/lib/ashrdi3.c
+++ b/arch/mips/lib/ashrdi3.c
@@ -2,6 +2,11 @@
#include "libgcc.h"
+#ifdef __GENKSYMS__
+#undef notrace
+#define notrace
+#endif
+
long long notrace __ashrdi3(long long u, word_type b)
{
DWunion uu, w;
--- a/arch/mips/lib/bswapdi.c
+++ b/arch/mips/lib/bswapdi.c
@@ -1,5 +1,10 @@
#include <linux/module.h>
+#ifdef __GENKSYMS__
+#undef notrace
+#define notrace
+#endif
+
unsigned long long notrace __bswapdi2(unsigned long long u)
{
return (((u) & 0xff00000000000000ull) >> 56) |
--- a/arch/mips/lib/bswapsi.c
+++ b/arch/mips/lib/bswapsi.c
@@ -1,5 +1,10 @@
#include <linux/module.h>
+#ifdef __GENKSYMS__
+#undef notrace
+#define notrace
+#endif
+
unsigned int notrace __bswapsi2(unsigned int u)
{
return (((u) & 0xff000000) >> 24) |
--- a/arch/mips/lib/cmpdi2.c
+++ b/arch/mips/lib/cmpdi2.c
@@ -2,6 +2,11 @@
#include "libgcc.h"
+#ifdef __GENKSYMS__
+#undef notrace
+#define notrace
+#endif
+
word_type notrace __cmpdi2(long long a, long long b)
{
const DWunion au = {
--- a/arch/mips/lib/lshrdi3.c
+++ b/arch/mips/lib/lshrdi3.c
@@ -2,6 +2,11 @@
#include "libgcc.h"
+#ifdef __GENKSYMS__
+#undef notrace
+#define notrace
+#endif
+
long long notrace __lshrdi3(long long u, word_type b)
{
DWunion uu, w;
--- a/arch/mips/lib/ucmpdi2.c
+++ b/arch/mips/lib/ucmpdi2.c
@@ -2,6 +2,11 @@
#include "libgcc.h"
+#ifdef __GENKSYMS__
+#undef notrace
+#define notrace
+#endif
+
word_type notrace __ucmpdi2(unsigned long long a, unsigned long long b)
{
const DWunion au = {.ll = a};

View File

@ -1,6 +1,6 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 16 Jun 2016 11:32:49 +0100
Subject: MIPS: Fix ABI change in 4.6.2
Subject: MIPS: siginfo: Fix ABI change in 4.6.2
Forwarded: not-needed
genksyms only looks at the (preprocessed) token stream of a struct

View File

@ -114,7 +114,8 @@ bugfix/all/tipc-fix-an-infoleak-in-tipc_nl_compat_link_dump.patch
bugfix/all/rds-fix-an-infoleak-in-rds_inc_info_copy.patch
# ABI maintenance
debian/mips-fix-abi-change-in-4.6.2.patch
debian/mips-siginfo-fix-abi-change-in-4.6.2.patch
debian/mips-libgcc-fix-abi-change-in-4.6.2.patch
# Tools bug fixes
bugfix/all/usbip-document-tcp-wrappers.patch