aufs: Update to aufs3.x-rcN-20111114

svn path=/dists/trunk/linux-2.6/; revision=18298
This commit is contained in:
Ben Hutchings 2011-11-19 23:53:33 +00:00
parent 69a34a2626
commit 9d96b925c8
5 changed files with 314 additions and 269 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux-2.6 (3.2~rc2-1~experimental.1) UNRELEASED; urgency=low
[ Ben Hutchings ]
* New upstream release candidate
* aufs: Update to aufs3.x-rcN-20111114
[ Uwe Kleine-König ]
* [amd64] reenable rt featureset with 3.2-rc1-52e4c2a05-rt2

File diff suppressed because it is too large Load Diff

View File

@ -1,10 +1,10 @@
aufs3.1 base patch
aufs3.x-rcN base patch
diff --git a/fs/namei.c b/fs/namei.c
index 0b3138d..8edad02 100644
index ac6d214..f72b667 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1748,7 +1748,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
@@ -1750,7 +1750,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@ -42,10 +42,10 @@ index fa2defa..e3569b0 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index 409328d..40afdc0 100644
index ffc0213..ef35a31 100644
--- a/include/linux/namei.h
+++ b/include/linux/namei.h
@@ -84,6 +84,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
@@ -85,6 +85,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
int (*open)(struct inode *, struct file *));

View File

@ -1,7 +1,7 @@
aufs3.1 kbuild patch
aufs3.x-rcN kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index 9fe0b34..c4311f8 100644
index 5f4c45d..357a8a6 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -215,6 +215,7 @@ source "fs/pstore/Kconfig"
@ -13,11 +13,11 @@ index 9fe0b34..c4311f8 100644
endif # MISC_FILESYSTEMS
diff --git a/fs/Makefile b/fs/Makefile
index afc1096..5c5ac76 100644
index d2c3353..680ad8a 100644
--- a/fs/Makefile
+++ b/fs/Makefile
@@ -123,3 +123,4 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
obj-$(CONFIG_EXOFS_FS) += exofs/
obj-y += exofs/ # Multiple modules
obj-$(CONFIG_CEPH_FS) += ceph/
obj-$(CONFIG_PSTORE) += pstore/
+obj-$(CONFIG_AUFS_FS) += aufs/

View File

@ -1,4 +1,4 @@
aufs3.1 standalone patch
aufs3.x-rcN standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
index c322794..2aad244 100644
@ -14,7 +14,7 @@ index c322794..2aad244 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
index ec79246..46ac6f9 100644
index ee4e66b..728042b 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -65,6 +65,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
@ -26,10 +26,10 @@ index ec79246..46ac6f9 100644
/*
* Empty aops. Can be used for the cases where the user does not
diff --git a/fs/namei.c b/fs/namei.c
index 8edad02..50e8718 100644
index f72b667..7a58222 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1752,6 +1752,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
@@ -1754,6 +1754,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@ -38,10 +38,10 @@ index 8edad02..50e8718 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index b4febb2..598a308 100644
index e5e1c7d..344999b 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1508,6 +1508,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@@ -1509,6 +1509,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
}
return 0;
}
@ -111,7 +111,7 @@ index e14587d..be6533b 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index f711921..d742fc0 100644
index 22c41b5..33b4033 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -143,10 +143,10 @@ index e3569b0..9dc07b7 100644
/**
* splice_direct_to_actor - splices data directly between two non-pipes
diff --git a/security/commoncap.c b/security/commoncap.c
index a93b3b7..024282c 100644
index ee4f848..611fd70 100644
--- a/security/commoncap.c
+++ b/security/commoncap.c
@@ -971,3 +971,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
@@ -975,3 +975,4 @@ int cap_file_mmap(struct file *file, unsigned long reqprot,
}
return ret;
}
@ -164,10 +164,10 @@ index 4450fbe..2c437e5 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index d9e1533..466ee5c 100644
index 0c6cc69..d58ba1b 100644
--- a/security/security.c
+++ b/security/security.c
@@ -373,6 +373,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
@@ -411,6 +411,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
return 0;
return security_ops->path_rmdir(dir, dentry);
}
@ -175,7 +175,7 @@ index d9e1533..466ee5c 100644
int security_path_unlink(struct path *dir, struct dentry *dentry)
{
@@ -389,6 +390,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
@@ -427,6 +428,7 @@ int security_path_symlink(struct path *dir, struct dentry *dentry,
return 0;
return security_ops->path_symlink(dir, dentry, old_name);
}
@ -183,7 +183,7 @@ index d9e1533..466ee5c 100644
int security_path_link(struct dentry *old_dentry, struct path *new_dir,
struct dentry *new_dentry)
@@ -397,6 +399,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
@@ -435,6 +437,7 @@ int security_path_link(struct dentry *old_dentry, struct path *new_dir,
return 0;
return security_ops->path_link(old_dentry, new_dir, new_dentry);
}
@ -191,7 +191,7 @@ index d9e1533..466ee5c 100644
int security_path_rename(struct path *old_dir, struct dentry *old_dentry,
struct path *new_dir, struct dentry *new_dentry)
@@ -415,6 +418,7 @@ int security_path_truncate(struct path *path)
@@ -453,6 +456,7 @@ int security_path_truncate(struct path *path)
return 0;
return security_ops->path_truncate(path);
}
@ -199,7 +199,7 @@ index d9e1533..466ee5c 100644
int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
mode_t mode)
@@ -423,6 +427,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
@@ -461,6 +465,7 @@ int security_path_chmod(struct dentry *dentry, struct vfsmount *mnt,
return 0;
return security_ops->path_chmod(dentry, mnt, mode);
}
@ -207,7 +207,7 @@ index d9e1533..466ee5c 100644
int security_path_chown(struct path *path, uid_t uid, gid_t gid)
{
@@ -430,6 +435,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
@@ -468,6 +473,7 @@ int security_path_chown(struct path *path, uid_t uid, gid_t gid)
return 0;
return security_ops->path_chown(path, uid, gid);
}
@ -215,7 +215,7 @@ index d9e1533..466ee5c 100644
int security_path_chroot(struct path *path)
{
@@ -506,6 +512,7 @@ int security_inode_readlink(struct dentry *dentry)
@@ -544,6 +550,7 @@ int security_inode_readlink(struct dentry *dentry)
return 0;
return security_ops->inode_readlink(dentry);
}
@ -223,7 +223,7 @@ index d9e1533..466ee5c 100644
int security_inode_follow_link(struct dentry *dentry, struct nameidata *nd)
{
@@ -520,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
@@ -558,6 +565,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask);
}
@ -231,7 +231,7 @@ index d9e1533..466ee5c 100644
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -619,6 +627,7 @@ int security_file_permission(struct file *file, int mask)
@@ -673,6 +681,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -239,7 +239,7 @@ index d9e1533..466ee5c 100644
int security_file_alloc(struct file *file)
{
@@ -646,6 +655,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
@@ -700,6 +709,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
return ret;
return ima_file_mmap(file, prot);
}