Fix a boot crash on the Kurobox Pro.

svn path=/dists/trunk/linux-2.6/; revision=11865
This commit is contained in:
Martin Michlmayr 2008-07-21 08:51:57 +00:00
parent cd119e1b94
commit 9d669683f4
3 changed files with 18 additions and 0 deletions

1
debian/changelog vendored
View File

@ -99,6 +99,7 @@ linux-2.6 (2.6.26-1~experimental.1) UNRELEASED; urgency=low
* [arm/ixp4xx] Enable CONFIG_MACH_DSMG600.
* [arm/iop32x] Unset NET_DMA since it actually leads to worse network
performance.
* [arm/orion5x] Fix a boot crash on the Kurobox Pro.
[ Ian Campbell ]
* Readme.build updated on how to generate orig tarballs.

View File

@ -0,0 +1,16 @@
Otherwise the machine won't boot because of problems with PCI
initalization.
diff --git a/arch/arm/mach-orion5x/kurobox_pro-setup.c b/arch/arm/mach-orion5x/kurobox_pro-setup.c
index 84feac4..35706b4 100644
--- a/arch/arm/mach-orion5x/kurobox_pro-setup.c
+++ b/arch/arm/mach-orion5x/kurobox_pro-setup.c
@@ -137,7 +137,7 @@ static int __init kurobox_pro_pci_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
}
static struct hw_pci kurobox_pro_pci __initdata = {
- .nr_controllers = 2,
+ .nr_controllers = 1,
.swizzle = pci_std_swizzle,
.setup = orion5x_pci_sys_setup,
.scan = orion5x_pci_sys_scan_bus,

View File

@ -33,6 +33,7 @@
+ bugfix/arm/disable-ath5k.patch
+ bugfix/arm/disable-r6040.patch
+ bugfix/arm/ixp4xx_napi_fix.patch
+ bugfix/arm/kurobox_fix_nr_controllers.patch
+ features/arm/speed_flush_cache.patch
+ features/arm/5281d0.patch
+ features/arm/fix_cache_alignment.patch