nuke patch that landed anyway in 2.6.29.1

svn path=/dists/sid/linux-2.6/; revision=13313
This commit is contained in:
Maximilian Attems 2009-04-01 19:09:04 +00:00
parent cbc146ddec
commit 9cc7ec0009
3 changed files with 1 additions and 37 deletions

2
debian/changelog vendored
View File

@ -6,7 +6,7 @@ linux-2.6 (2.6.29-2) UNRELEASED; urgency=low
[ maximilian attems ]
* linux-libc-dev: Bump versioned replaces libdrm-dev.
* Add drivers-net-dnet.c-needs-linux-io.h.patch.
* parisc: hardcode gcc-4.3 usage.
[ Bastian Blank ]
* Install all needed Makefiles into common headers package.

View File

@ -1,35 +0,0 @@
From 142071b83426674ef2dab98cf2a6627328d0988e Mon Sep 17 00:00:00 2001
From: Geert Uytterhoeven <geert@linux-m68k.org>
Date: Tue, 24 Mar 2009 13:19:50 -0700
Subject: [PATCH] dnet: drivers/net/dnet.c needs <linux/io.h>
On m68k:
| drivers/net/dnet.c: In function 'dnet_readw_mac':
| drivers/net/dnet.c:36: error: implicit declaration of function 'writel'
| drivers/net/dnet.c:43: error: implicit declaration of function 'readl'
| drivers/net/dnet.c: In function 'dnet_probe':
| drivers/net/dnet.c:873: error: implicit declaration of function 'ioremap'
| drivers/net/dnet.c:873: warning: assignment makes pointer from integer without a cast
| drivers/net/dnet.c:939: error: implicit declaration of function 'iounmap'
Signed-off-by: Geert Uytterhoeven <geert@linux-m68k.org>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
drivers/net/dnet.c | 1 +
1 files changed, 1 insertions(+), 0 deletions(-)
diff --git a/drivers/net/dnet.c b/drivers/net/dnet.c
index 1b40632..edf23c9 100644
--- a/drivers/net/dnet.c
+++ b/drivers/net/dnet.c
@@ -9,6 +9,7 @@
* published by the Free Software Foundation.
*/
#include <linux/version.h>
+#include <linux/io.h>
#include <linux/module.h>
#include <linux/moduleparam.h>
#include <linux/kernel.h>
--
1.6.2.1

View File

@ -1,2 +1 @@
+ debian/dfsg/drivers-net-bnx2-fw-verfix.patch
+ bugfix/all/drivers-net-dnet.c-needs-linux-io.h.patch