[armhf] rtc-twl: Switch to using threaded irq

svn path=/dists/sid/linux-2.6/; revision=17729
This commit is contained in:
Ben Hutchings 2011-06-26 02:47:41 +00:00
parent a4dc1b0a81
commit 9b3391d3cd
3 changed files with 31 additions and 0 deletions

1
debian/changelog vendored
View File

@ -8,6 +8,7 @@ linux-2.6 (2.6.39-3) UNRELEASED; urgency=low
* linux-source-<version>: Suggest libqt4-dev (for 'make xconfig')
instead of libqt3-mt-dev (Closes: #631666)
* [armhf] Add omap flavour, thanks to Sebastian Reichel
* [armhf] rtc-twl: Switch to using threaded irq
[ maximilian attems ]
* Add stable 2.6.39.2, including:

View File

@ -0,0 +1,29 @@
From: Ilkka Koskinen <ilkka.koskinen@nokia.com>
Subject: [PATCH] rtc-twl: Switch to using threaded irq
Date: Wed, 16 Mar 2011 18:07:14 +0200
The driver is accessing to i2c bus in interrupt handler.
Therefore, it should use threaded irq.
Signed-off-by: Ilkka Koskinen <ilkka.koskinen@nokia.com>
Acked-by: Balaji T K <balajitk@ti.com>
---
drivers/rtc/rtc-twl.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/rtc/rtc-twl.c b/drivers/rtc/rtc-twl.c
index ed1b868..2715b96 100644
--- a/drivers/rtc/rtc-twl.c
+++ b/drivers/rtc/rtc-twl.c
@@ -475,7 +475,7 @@ static int __devinit twl_rtc_probe(struct platform_device *pdev)
if (ret < 0)
goto out1;
- ret = request_irq(irq, twl_rtc_interrupt,
+ ret = request_threaded_irq(irq, NULL, twl_rtc_interrupt,
IRQF_TRIGGER_RISING,
dev_name(&rtc->dev), rtc);
if (ret < 0) {
--
1.7.0.4

View File

@ -1,2 +1,3 @@
+ bugfix/x86/Revert-drm-i915-Enable-GMBUS-for-post-gen2-chipsets.patch
+ bugfix/all/stable/2.6.39.2
+ bugfix/arm/rtc-twl-Switch-to-using-threaded_irq.patch