Update to 4.14.13

This commit is contained in:
Salvatore Bonaccorso 2018-01-10 09:59:02 +01:00
parent d9bec081bc
commit 9a41499923
3 changed files with 46 additions and 45 deletions

46
debian/changelog vendored
View File

@ -1,3 +1,49 @@
linux (4.14.13-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.13
- [x86] mm: Set MODULES_END to 0xffffffffff000000
- [x86] mm: Map cpu_entry_area at the same place on 4/5 level
- [x86] kaslr: Fix the vaddr_end mess
- [x86] events/intel/ds: Use the proper cache flush method for mapping ds
buffers
- [x86] alternatives: Add missing '\n' at end of ALTERNATIVE inline asm
- [x86] pti: Rename BUG_CPU_INSECURE to BUG_CPU_MELTDOWN
- kernel/acct.c: fix the acct->needcheck check in check_free_space()
- mm/mprotect: add a cond_resched() inside change_pmd_range()
- mm/sparse.c: wrong allocation for mem_section
- userfaultfd: clear the vma->vm_userfaultfd_ctx if UFFD_EVENT_FORK fails
- btrfs: fix refcount_t usage when deleting btrfs_delayed_nodes
- efi/capsule-loader: Reinstate virtual capsule mapping
- [sparc*] crypto: n2 - cure use after free
- crypto: chacha20poly1305 - validate the digest size
- crypto: pcrypt - fix freeing pcrypt instances
- crypto: chelsio - select CRYPTO_GF128MUL
- [x86] drm/i915: Disable DC states around GMBUS on GLK
- [x86] drm/i915: Apply Display WA #1183 on skl, kbl, and cfl
- fscache: Fix the default for fscache_maybe_release_page()
- [x86] CPU: Avoid unnecessary IPIs in arch_freq_get_on_cpu()
- [x86] CPU: Always show current CPU frequency in /proc/cpuinfo
- kernel/signal.c: protect the traced SIGNAL_UNKILLABLE tasks from SIGKILL
- kernel/signal.c: protect the SIGNAL_UNKILLABLE tasks from
!sig_kernel_only() signals
- kernel/signal.c: remove the no longer needed SIGNAL_UNKILLABLE check in
complete_signal()
- [arm64] iommu/arm-smmu-v3: Don't free page table ops twice
- [arm64] iommu/arm-smmu-v3: Cope with duplicated Stream IDs
- [powerpc* ]mm: Fix SEGV on mapped region to return SEGV_ACCERR
- Input: elantech - add new icbody type 15
- [x86] microcode/AMD: Add support for fam17h microcode loading
- apparmor: fix regression in mount mediation when feature set is pinned
- [hppa/parisc] Fix alignment of pa_tlb_lock in assembly on 32-bit SMP
kernel
- [hppa/parisc] qemu idle sleep support
- mtd: nand: pxa3xx: Fix READOOB implementation
- [s390x] KVM: fix cmma migration for multiple memory slots
- [s390x] KVM: prevent buffer overrun on memory hotplug during migration
-- Salvatore Bonaccorso <carnil@debian.org> Wed, 10 Jan 2018 09:58:46 +0100
linux (4.14.12-2) unstable; urgency=medium
[ Ben Hutchings ]

View File

@ -1,44 +0,0 @@
From: Thomas Gleixner <tglx@linutronix.de>
Date: Thu, 4 Jan 2018 22:19:04 +0100
Subject: x86/tlb: Drop the _GPL from the cpu_tlbstate export
Origin: https://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git/commit/?id=1e5476815fd7f98b888e01a0f9522b63085f96c9
The recent changes for PTI touch cpu_tlbstate from various tlb_flush
inlines. cpu_tlbstate is exported as GPL symbol, so this causes a
regression when building out of tree drivers for certain graphics cards.
Aside of that the export was wrong since it was introduced as it should
have been EXPORT_PER_CPU_SYMBOL_GPL().
Use the correct PER_CPU export and drop the _GPL to restore the previous
state which allows users to utilize the cards they payed for.
As always I'm really thrilled to make this kind of change to support the
#friends (or however the hot hashtag of today is spelled) from that closet
sauce graphics corp.
Fixes: 1e02ce4cccdc ("x86: Store a per-cpu shadow copy of CR4")
Fixes: 6fd166aae78c ("x86/mm: Use/Fix PCID to optimize user/kernel switches")
Reported-by: Kees Cook <keescook@google.com>
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Peter Zijlstra <peterz@infradead.org>
Cc: Andy Lutomirski <luto@kernel.org>
Cc: stable@vger.kernel.org
---
arch/x86/mm/init.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/x86/mm/init.c b/arch/x86/mm/init.c
index 80259ad..6b462a4 100644
--- a/arch/x86/mm/init.c
+++ b/arch/x86/mm/init.c
@@ -870,7 +870,7 @@ __visible DEFINE_PER_CPU_SHARED_ALIGNED(struct tlb_state, cpu_tlbstate) = {
.next_asid = 1,
.cr4 = ~0UL, /* fail hard if we screw up cr4 shadow initialization */
};
-EXPORT_SYMBOL_GPL(cpu_tlbstate);
+EXPORT_PER_CPU_SYMBOL(cpu_tlbstate);
void update_cache_mode_entry(unsigned entry, enum page_cache_mode cache)
{

View File

@ -83,7 +83,6 @@ bugfix/all/i40e-fix-flags-declaration.patch
bugfix/all/xen-time-do-not-decrease-steal-time-after-live-migra.patch
bugfix/all/e1000e-fix-e1000_check_for_copper_link_ich8lan-return-value.patch
debian/revert-scsi-libsas-allow-async-aborts.patch
bugfix/all/x86-tlb-Drop-the-_GPL-from-the-cpu_tlbstate-export.patch
# Miscellaneous features