* debian/changelog: Update.

* debian/patches/features/all/vserver/bindmount-dev.patch: Add.
* debian/patches/series/3-extra: Add all/vserver/bindmount-dev.patch.

svn path=/dists/trunk/linux-2.6/; revision=7599
This commit is contained in:
Bastian Blank 2006-10-11 22:07:30 +00:00
parent 1cb7f248c5
commit 98250c4530
3 changed files with 46 additions and 2 deletions

5
debian/changelog vendored
View File

@ -4,7 +4,8 @@ linux-2.6 (2.6.18-3) UNRELEASED; urgency=low
* Fix home of patch apply script.
* Unify CPUSET option. (closes: #391931)
* Support xen version 3.0.3-1 and 3.0.3-rc1.
* Add AHCI suspend support.
* Add AHCI suspend support.
* Add patch to support bindmount without nodev on vserver.
[ Steve Langasek ]
* [alpha] restore alpha-prctl.patch, which keeps disappearing every time
@ -35,7 +36,7 @@ linux-2.6 (2.6.18-3) UNRELEASED; urgency=low
* [powerpc] Added AMD74xx driver module to the powerpc64 flavour
(Closes: #391861).
-- Bastian Blank <waldi@debian.org> Tue, 10 Oct 2006 16:40:26 +0200
-- Bastian Blank <waldi@debian.org> Thu, 12 Oct 2006 00:06:53 +0200
linux-2.6 (2.6.18-2) unstable; urgency=low

View File

@ -0,0 +1,42 @@
diff -ur source-s390-vserver.orig/fs/namespace.c source-s390-vserver/fs/namespace.c
--- source-s390-vserver.orig/fs/namespace.c 2006-08-12 16:51:51.000000000 +0200
+++ source-s390-vserver/fs/namespace.c 2006-08-12 16:53:26.000000000 +0200
@@ -986,6 +986,9 @@
if (!mnt)
goto out;
+ if (!capable(CAP_SYS_ADMIN) && (old_nd.mnt->mnt_flags & MNT_NODEV))
+ mnt_flags |= MNT_NODEV;
+
mnt->mnt_flags = mnt_flags;
if (flags & MS_XID) {
mnt->mnt_xid = xid;
@@ -1028,6 +1031,9 @@
if (nd->dentry != nd->mnt->mnt_root)
return -EINVAL;
+ if (!capable(CAP_SYS_ADMIN))
+ mnt_flags |= MNT_NODEV;
+
down_write(&sb->s_umount);
err = do_remount_sb(sb, flags, data, 0);
if (!err)
@@ -1136,6 +1142,9 @@
if (!vx_capable(CAP_SYS_ADMIN, VXC_SECURE_MOUNT))
return -EPERM;
+ if (!capable(CAP_SYS_ADMIN))
+ mnt_flags |= MNT_NODEV;
+
mnt = do_kern_mount(type, flags, name, data);
if (IS_ERR(mnt))
return PTR_ERR(mnt);
@@ -1409,8 +1418,6 @@
if (flags & MS_NODIRATIME)
mnt_flags |= MNT_NODIRATIME;
- if (!capable(CAP_SYS_ADMIN))
- mnt_flags |= MNT_NODEV;
flags &= ~(MS_NOSUID | MS_NOEXEC | MS_NODEV | MS_ACTIVE |
MS_NOATIME | MS_NODIRATIME);

1
debian/patches/series/3-extra vendored Normal file
View File

@ -0,0 +1 @@
+ features/all/vserver/bindmount-dev.patch *_vserver *_xen-vserver