[sparc64] topology_64.h: Fix condition for including cpudata.h

This might fix the FTBFS, but as I can't currently do a test build
I'm not sure.
This commit is contained in:
Ben Hutchings 2017-02-01 22:47:43 +00:00
parent cebb2af7dd
commit 9805479fdb
3 changed files with 33 additions and 0 deletions

2
debian/changelog vendored
View File

@ -2,6 +2,8 @@ linux (4.10~rc6-1~exp2) UNRELEASED; urgency=medium
* [s390x] Un-revert upstream change moving exports to assembly sources
(fixes FTBFS)
* [sparc64] topology_64.h: Fix condition for including cpudata.h
(might fix FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 01 Feb 2017 22:13:06 +0000

View File

@ -0,0 +1,30 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 01 Feb 2017 22:45:06 +0000
Subject: sparc: topology_64.h: Fix condition for including cpudata.h
We currently define macros referring to cpu_data if CONFIG_SMP is
defined, but only include the declaration if CONFIG_NUMA is defined.
Fixes: 541cc39433a8 ("sparc: fix a building error reported by kbuild")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/arch/sparc/include/asm/topology_64.h
+++ b/arch/sparc/include/asm/topology_64.h
@@ -4,7 +4,6 @@
#ifdef CONFIG_NUMA
#include <asm/mmzone.h>
-#include <asm/cpudata.h>
static inline int cpu_to_node(int cpu)
{
@@ -42,6 +41,9 @@ int __node_distance(int, int);
#endif /* !(CONFIG_NUMA) */
#ifdef CONFIG_SMP
+
+#include <asm/cpudata.h>
+
#define topology_physical_package_id(cpu) (cpu_data(cpu).proc_id)
#define topology_core_id(cpu) (cpu_data(cpu).core_id)
#define topology_core_cpumask(cpu) (&cpu_core_sib_map[cpu])

View File

@ -47,6 +47,7 @@ debian/fanotify-taint-on-use-of-fanotify_access_permissions.patch
# Arch bug fixes
bugfix/x86/asoc-intel-select-dw_dmac_core-since-it-s-mandatory.patch
bugfix/sparc/sparc-topology_64.h-fix-condition-for-including-cpudata.h.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch