drm/i915: disable powersave by default (closes: #564807)

svn path=/dists/trunk/linux-2.6/; revision=14939
This commit is contained in:
dann frazier 2010-01-13 19:17:02 +00:00
parent 4f0498a82e
commit 97bb1382fa
3 changed files with 32 additions and 0 deletions

3
debian/changelog vendored
View File

@ -17,6 +17,9 @@ linux-2.6 (2.6.32-6) UNRELEASED; urgency=low
[ Ian Campbell ]
* xen: Enable up to 32G of guest memory on i386.
[ Julien Cristau ]
* drm/i915: disable powersave by default (closes: #564807)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 10 Jan 2010 17:38:50 +0000
linux-2.6 (2.6.32-5) unstable; urgency=low

View File

@ -0,0 +1,28 @@
From 3d8aef4fa23bfed8ba72442eb2845d3ee17dcdf5 Mon Sep 17 00:00:00 2001
From: Julien Cristau <jcristau@debian.org>
Date: Wed, 13 Jan 2010 18:56:00 +0000
Subject: [PATCH] i915: disable powersave by default
It's b0rked in 2.6.32, at least on 945GM.
Fixes http://bugs.debian.org/564807 among others.
---
drivers/gpu/drm/i915/i915_drv.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
index 7f436ec..8ac8abc 100644
--- a/drivers/gpu/drm/i915/i915_drv.c
+++ b/drivers/gpu/drm/i915/i915_drv.c
@@ -43,7 +43,7 @@ module_param_named(modeset, i915_modeset, int, 0400);
unsigned int i915_fbpercrtc = 0;
module_param_named(fbpercrtc, i915_fbpercrtc, int, 0400);
-unsigned int i915_powersave = 1;
+unsigned int i915_powersave = 0;
module_param_named(powersave, i915_powersave, int, 0400);
static struct drm_driver driver;
--
1.6.6

View File

@ -11,3 +11,4 @@
+ features/all/saa7134-Add-support-for-Asus-Europa-Hybrid-DVB.patch
+ features/x86/iTCO_wdt-Add-support-for-Intel-Ibex-Peak.patch
+ bugfix/all/Documentation-3c509-document-ethtool-support.patch
+ bugfix/all/drm-i915-disable-powersave.patch