* Fix build failure of hugetlbfs (closes: #397139).

svn path=/dists/trunk/linux-2.6/; revision=7697
This commit is contained in:
Thiemo Seufer 2006-11-05 22:26:56 +00:00
parent 8dccc8a21a
commit 95a27fcb56
3 changed files with 41 additions and 3 deletions

10
debian/changelog vendored
View File

@ -1,11 +1,15 @@
linux-2.6 (2.6.18-5) UNRELEASE; urgency=low
linux-2.6 (2.6.18-5) UNRELEASED; urgency=low
* [s390] readd the fix for ""S390: user readable uninitialised kernel memory
[ maximilian attems ]
* [s390] readd the fix for "S390: user readable uninitialised kernel memory
(CVE-2006-5174)"
* [s390] temorarly add patch queued for 2.6.18.3 fixing 32 bit opcodes and
instructions.
-- maximilian attems <maks@sternwelten.at> Sun, 5 Nov 2006 20:26:11 +0100
[ Thiemo Seufer ]
* Fix build failure of hugetlbfs (closes: #397139).
-- Thiemo Seufer <ths@debian.org> Sun, 05 Nov 2006 21:29:05 +0000
linux-2.6 (2.6.18-4) unstable; urgency=low

View File

@ -0,0 +1,33 @@
Adjust copy_user_highpage callers to match new signature
Signed-off-by: Thiemo Seufer <ths@networkno.de>
--- a/mm/hugetlb.c
+++ b/mm/hugetlb.c
@@ -44,14 +44,14 @@ static void clear_huge_page(struct page
}
static void copy_huge_page(struct page *dst, struct page *src,
- unsigned long addr)
+ unsigned long addr, struct vm_area_struct *vma)
{
int i;
might_sleep();
for (i = 0; i < HPAGE_SIZE/PAGE_SIZE; i++) {
cond_resched();
- copy_user_highpage(dst + i, src + i, addr + i*PAGE_SIZE);
+ copy_user_highpage(dst + i, src + i, addr + i*PAGE_SIZE, vma);
}
}
@@ -417,7 +417,7 @@ static int hugetlb_cow(struct mm_struct
}
spin_unlock(&mm->page_table_lock);
- copy_huge_page(new_page, old_page, address);
+ copy_huge_page(new_page, old_page, address, vma);
spin_lock(&mm->page_table_lock);
ptep = huge_pte_offset(mm, address & HPAGE_MASK);

View File

@ -1,2 +1,3 @@
- bugfix/s390-ftbfs-2.6.18.1.patch
+ bugfix/s390-copy_from_user_padding_take2.patch
+ bugfix/copy-user-highpage-2.patch