Update to 4.13.12

This commit is contained in:
Salvatore Bonaccorso 2017-11-11 08:22:06 +01:00
parent f13763371c
commit 95757c39a8
3 changed files with 36 additions and 46 deletions

39
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.13.11-1) UNRELEASED; urgency=medium
linux (4.13.12-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.13.11
@ -47,10 +47,43 @@ linux (4.13.11-1) UNRELEASED; urgency=medium
- [armhf] regulator: fan53555: fix I2C device ids (Closes: #879768)
- [powerpc*] xive: Fix the size of the cpumask used in
xive_find_target_in_mask()
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.13.12
- ALSA: timer: Add missing mutex lock for compat ioctls
- ALSA: seq: Fix nested rwsem annotation for lockdep splat
- cifs: check MaxPathNameComponentLength != 0 before using it
(Closes: #880504)
- KEYS: return full count in keyring_read() if buffer is too small
- KEYS: trusted: fix writing past end of buffer in trusted_read()
- KEYS: fix out-of-bounds read during ASN.1 parsing
- ASoC: adau17x1: Workaround for noise bug in ADC
- virtio_blk: Fix an SG_IO regression
- [arm64] ensure __dump_instr() checks addr_limit
- [arm64] KVM: its: Fix missing dynamic allocation check in scan_its_table
- [armhf, arm64] KVM: set right LR register value for 32 bit guest when
inject abort
- [armhf,arm64] kvm: Disable branch profiling in HYP code
- [armhf] dts: mvebu: pl310-cache disable double-linefill
- drm/amdgpu: return -ENOENT from uvd 6.0 early init for harvesting
- drm/amdgpu: allow harvesting check for Polaris VCE
- userfaultfd: hugetlbfs: prevent UFFDIO_COPY to fill beyond the end of
i_size
- ocfs2: fstrim: Fix start offset of first cluster group during fstrim
- fs/hugetlbfs/inode.c: fix hwpoison reserve accounting
- mm, swap: fix race between swap count continuation operations
- [x86] drm/i915: Do not rely on wm preservation for ILK watermarks
- [x86] drm/i915/edp: read edp display control registers unconditionally
- [mips*] bpf: Fix a typo in build_one_insn()
- [mips*] smp-cmp: Use right include for task_struct
- [mips*] SMP: Fix deadlock & online race
- Revert "x86: do not use cpufreq_quick_get() for /proc/cpuinfo "cpu MHz""
- [x86] CPU: Fix up "cpu MHz" in /proc/cpuinfo
- [powerpc*] kprobes: Dereference function pointers only if the address
does not belong to kernel text
- futex: Fix more put_pi_state() vs. exit_pi_state_list() races
- perf/cgroup: Fix perf cgroup hierarchy support
- [x86] mcelog: Get rid of RCU remnants
[ Salvatore Bonaccorso ]
* cifs: check MaxPathNameComponentLength != 0 before using it.
Thanks to Andrew Chadwick (Closes: #880504)
* netfilter: nft_set_hash: disable fast_ops for 2-len keys (Closes: #880145)
[ Ben Hutchings ]

View File

@ -1,42 +0,0 @@
From: Ronnie Sahlberg <lsahlber@redhat.com>
Date: Mon, 30 Oct 2017 13:28:03 +1100
Subject: cifs: check MaxPathNameComponentLength != 0 before using it
Origin: https://git.kernel.org/linus/f74bc7c6679200a4a83156bb89cbf6c229fe8ec0
Bug-Debian: https://bugs.debian.org/880504
And fix tcon leak in error path.
Signed-off-by: Ronnie Sahlberg <lsahlber@redhat.com>
Signed-off-by: Steve French <smfrench@gmail.com>
CC: Stable <stable@vger.kernel.org>
Reviewed-by: David Disseldorp <ddiss@samba.org>
---
fs/cifs/dir.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/fs/cifs/dir.c b/fs/cifs/dir.c
index e702d48bd023..81ba6e0d88d8 100644
--- a/fs/cifs/dir.c
+++ b/fs/cifs/dir.c
@@ -204,7 +204,8 @@ check_name(struct dentry *direntry, struct cifs_tcon *tcon)
struct cifs_sb_info *cifs_sb = CIFS_SB(direntry->d_sb);
int i;
- if (unlikely(direntry->d_name.len >
+ if (unlikely(tcon->fsAttrInfo.MaxPathNameComponentLength &&
+ direntry->d_name.len >
le32_to_cpu(tcon->fsAttrInfo.MaxPathNameComponentLength)))
return -ENAMETOOLONG;
@@ -520,7 +521,7 @@ cifs_atomic_open(struct inode *inode, struct dentry *direntry,
rc = check_name(direntry, tcon);
if (rc)
- goto out_free_xid;
+ goto out;
server = tcon->ses->server;
--
2.11.0

View File

@ -78,7 +78,6 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
bugfix/all/bfq-re-enable-auto-loading-when-built-as-a-module.patch
bugfix/all/cifs-check-MaxPathNameComponentLength-0-before-using.patch
bugfix/all/netfilter-nft_set_hash-disable-fast_ops-for-2-len-ke.patch
# Miscellaneous features