ALSA: hda: Fix oops caused by "Fix internal mic for Lenovo Ideapad U300s" in 3.2.32

svn path=/dists/sid/linux/; revision=19445
This commit is contained in:
Ben Hutchings 2012-10-22 03:56:20 +00:00
parent b43df3a51b
commit 93fccf5956
3 changed files with 34 additions and 0 deletions

2
debian/changelog vendored
View File

@ -97,6 +97,8 @@ linux (3.2.32-1) UNRELEASED; urgency=low
* fs: handle failed audit_log_start properly
* fs: prevent use after free in auditing when symlink following was denied
* kernel/sys.c: fix stack memory content leak via UNAME26 (CVE-2012-0957)
* ALSA: hda: Fix oops caused by "Fix internal mic for Lenovo Ideapad U300s"
in 3.2.32
-- Ben Hutchings <ben@decadent.org.uk> Sat, 29 Sep 2012 14:19:46 +0200

View File

@ -0,0 +1,31 @@
From: David Henningsson <david.henningsson@canonical.com>
Date: Tue, 10 Apr 2012 13:05:29 +0200
Subject: ALSA: hda - Fix oops caused by recent commit "Fix internal mic for
Lenovo Ideapad U300s"
commit 83b0c6ba999643ee8ad6329f26e1cdc870e1a920 upstream.
Make sure we don't dereference the "quirk" pointer when it is null.
Reported-by: Dan Carpenter <dan.carpenter@oracle.com>
Signed-off-by: David Henningsson <david.henningsson@canonical.com>
Signed-off-by: Takashi Iwai <tiwai@suse.de>
---
sound/pci/hda/patch_conexant.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/sound/pci/hda/patch_conexant.c b/sound/pci/hda/patch_conexant.c
index cbe115b..abb59f4 100644
--- a/sound/pci/hda/patch_conexant.c
+++ b/sound/pci/hda/patch_conexant.c
@@ -4441,7 +4441,9 @@ static void apply_fixup(struct hda_codec *codec,
struct conexant_spec *spec = codec->spec;
quirk = snd_pci_quirk_lookup(codec->bus->pci, quirk);
- if (quirk && table[quirk->value]) {
+ if (!quirk)
+ return;
+ if (table[quirk->value]) {
snd_printdd(KERN_INFO "hda_codec: applying pincfg for %s\n",
quirk->name);
apply_pincfg(codec, table[quirk->value]);

View File

@ -406,3 +406,4 @@ debian/xfrm-avoid-ABI-change-in-3.2.31.patch
bugfix/x86/SCSI-storvsc-Account-for-in-transit-packets-in-the-R.patch
bugfix/all/kernel-sys.c-fix-stack-memory-content-leak-via-UNAME.patch
bugfix/all/use-clamp_t-in-UNAME26-fix.patch
bugfix/x86/ALSA-hda-Fix-oops-caused-by-recent-commit-Fix-intern.patch