Update to 4.9.13

This commit is contained in:
Ben Hutchings 2017-02-26 20:10:47 +00:00
parent 5d326c4855
commit 93819d25f0
3 changed files with 28 additions and 52 deletions

32
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.9.12-1) UNRELEASED; urgency=medium
linux (4.9.13-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.11
@ -55,6 +55,33 @@ linux (4.9.12-1) UNRELEASED; urgency=medium
- timekeeping: Use deferred printk() in debug code
- bcache: Make gc wakeup sane, remove set_task_state()
- videodev2.h: go back to limited range Y'CbCr for SRGB and, ADOBERGB
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.13
- net/mlx5e: Disable preemption when doing TC statistics upcall
- net/llc: avoid BUG_ON() in skb_orphan()
- net: ethernet: ti: cpsw: fix cpsw assignment in resume
(regression in 4.9)
- packet: fix races in fanout_add()
- packet: Do not call fanout_release from atomic contexts
(regression in 4.9)
- net: neigh: Fix netevent NETEVENT_DELAY_PROBE_TIME_UPDATE notification
- dccp: fix freeing skb too early for IPV6_RECVPKTINFO (CVE-2017-6074)
- vxlan: fix oops in dev_fill_metadata_dst (regression in 4.6)
- irda: Fix lockdep annotations in hashbin_delete().
- ptr_ring: fix race conditions when resizing
- ip: fix IP_CHECKSUM handling (regression in 4.0)
- net: socket: fix recvmmsg not returning error from sock_error
(regression in 4.6)
- USB: serial: mos7840: fix another NULL-deref at open
- USB: serial: ftdi_sio: fix modem-status error handling
- USB: serial: ftdi_sio: fix extreme low-latency setting
- USB: serial: ftdi_sio: fix line-status over-reporting
- USB: serial: spcp8x5: fix modem-status handling
- USB: serial: opticon: fix CTS retrieval at open
- USB: serial: ark3116: fix register-accessor error handling
- netfilter: nf_ct_helper: warn when not applying default helper assignment
- block: fix double-free in the failure path of cgwb_bdi_init()
- rtlwifi: rtl_usb: Fix for URB leaking when doing ifconfig up/down
- xfs: clear delalloc and cache on buffered write failure
[ Ben Hutchings ]
* [armel] dts: kirkwood: Fix SATA pinmux-ing for TS419 (Closes: #855017)
@ -65,9 +92,6 @@ linux (4.9.12-1) UNRELEASED; urgency=medium
* udeb: Add more USB host and dual-role drivers to usb-modules
(Closes: #856111)
[ Salvatore Bonaccorso ]
* dccp: fix freeing skb too early for IPV6_RECVPKTINFO (CVE-2017-6074)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 18 Feb 2017 00:38:10 +0000
linux (4.9.10-1) unstable; urgency=medium

View File

@ -1,47 +0,0 @@
From: Andrey Konovalov <andreyknvl@google.com>
Date: Thu, 16 Feb 2017 17:22:46 +0100
Subject: dccp: fix freeing skb too early for IPV6_RECVPKTINFO
Origin: https://git.kernel.org/linus/5edabca9d4cff7f1f2b68f0bac55ef99d9798ba4
In the current DCCP implementation an skb for a DCCP_PKT_REQUEST packet
is forcibly freed via __kfree_skb in dccp_rcv_state_process if
dccp_v6_conn_request successfully returns.
However, if IPV6_RECVPKTINFO is set on a socket, the address of the skb
is saved to ireq->pktopts and the ref count for skb is incremented in
dccp_v6_conn_request, so skb is still in use. Nevertheless, it gets freed
in dccp_rcv_state_process.
Fix by calling consume_skb instead of doing goto discard and therefore
calling __kfree_skb.
Similar fixes for TCP:
fb7e2399ec17f1004c0e0ccfd17439f8759ede01 [TCP]: skb is unexpectedly freed.
0aea76d35c9651d55bbaf746e7914e5f9ae5a25d tcp: SYN packets are now
simply consumed
Signed-off-by: Andrey Konovalov <andreyknvl@google.com>
Acked-by: Eric Dumazet <edumazet@google.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
net/dccp/input.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/net/dccp/input.c b/net/dccp/input.c
index ba34718..8fedc2d 100644
--- a/net/dccp/input.c
+++ b/net/dccp/input.c
@@ -606,7 +606,8 @@ int dccp_rcv_state_process(struct sock *sk, struct sk_buff *skb,
if (inet_csk(sk)->icsk_af_ops->conn_request(sk,
skb) < 0)
return 1;
- goto discard;
+ consume_skb(skb);
+ return 0;
}
if (dh->dccph_type == DCCP_PKT_RESET)
goto discard;
--
2.1.4

View File

@ -108,7 +108,6 @@ features/all/securelevel/arm64-add-kernel-config-option-to-set-securelevel-wh.pa
# Security fixes
debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/dccp-fix-freeing-skb-too-early-for-IPV6_RECVPKTINFO.patch
# Fix exported symbol versions
bugfix/ia64/revert-ia64-move-exports-to-definitions.patch