[armhf] Increase Ethernet phy startup delay on Banana-Pi.

Patch from Karsten Merker (Closes: 767042)

svn path=/dists/sid/linux/; revision=22064
This commit is contained in:
Ian Campbell 2014-11-13 21:38:54 +00:00
parent c58f0350f9
commit 9245309dcf
3 changed files with 38 additions and 0 deletions

2
debian/changelog vendored
View File

@ -9,6 +9,8 @@ linux (3.16.7-3) UNRELEASED; urgency=medium
* [xen] Backport various netback fixes (Closes: #767261).
* Backport fix for TSO with mv643xx_eth driver, replacing previous workaround
(#764162)
* [armhf] Increase Ethernet phy startup delay on Banana-Pi. Patch from
Karsten Merker (Closes: #767042)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 09 Nov 2014 10:13:09 +0000

View File

@ -0,0 +1,35 @@
From f82f99afaa65fd28d0f8409c50e8fcc65ee5e15b Mon Sep 17 00:00:00 2001
From: Karsten Merker <merker@debian.org>
Date: Wed, 12 Nov 2014 00:01:46 +0100
Subject: ARM: dts: sunxi: Banana Pi: increase startup-delay for the GMAC PHY regulator
Origin: https://git.kernel.org/cgit/linux/kernel/git/mripard/linux.git/commit/?h=sunxi/dt-for-3.19&id=f82f99afaa65fd28d0f8409c50e8fcc65ee5e15b
On the LeMaker Banana Pi, probing the external ethernet PHY connected
to the SoC's internal GMAC module sometimes fails. The PHY power
supply is handled via a GPIO-controlled regulator, and the existing
regulator startup-delay of 50000us is too short to make sure that the
PHY is always fully powered up when it is queried by phylib. Tests
have shown that to provide a reliable PHY detection, the startup-delay
has to be increased to at least 60000us. To have a certain safety margin
and to cater for manufacturing variations between different boards,
the delay gets set to 100000us as discussed on the linux-arm-kernel
mailinglist.
Signed-off-by: Karsten Merker <merker@debian.org>
Acked-by: Hans de Goede <hdegoede@redhat.com>
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
diff --git a/arch/arm/boot/dts/sun7i-a20-bananapi.dts b/arch/arm/boot/dts/sun7i-a20-bananapi.dts
index 3de847d..1cf1214 100644
--- a/arch/arm/boot/dts/sun7i-a20-bananapi.dts
+++ b/arch/arm/boot/dts/sun7i-a20-bananapi.dts
@@ -207,7 +207,7 @@
regulator-name = "gmac-3v3";
regulator-min-microvolt = <3300000>;
regulator-max-microvolt = <3300000>;
- startup-delay-us = <50000>;
+ startup-delay-us = <100000>;
enable-active-high;
gpio = <&pio 7 23 0>;
};

View File

@ -113,6 +113,7 @@ features/arm/dts-sunxi-Add-pins-for-IR-controller-on-A20-to-dtsi.patch
features/arm/dts-sun7i-Add-spi0_pins_a-pinctrl-setting.patch
features/arm/dts-sun7i-Add-uart3_pins_b-pinctrl-setting.patch
features/arm/dts-sun7i-Add-Banana-Pi-board.patch
features/arm/dts-sunxi-Banana-Pi-increase-startup-delay-for-the-GMAC-PHY-regulator.patch
features/arm/dts-sun7i-Add-support-for-Olimex-A20-OLinuXino-LIME.patch
features/arm64/drivers-net-Add-APM-X-Gene-SoC-ethernet-driver-suppo.patch
features/arm64/drivers-net-NET_XGENE-should-depend-on-HAS_DMA.patch