aufs: Update to aufs3 for Linux 3.1 (Closes: #644687)

svn path=/dists/trunk/linux-2.6/; revision=18203
This commit is contained in:
Ben Hutchings 2011-10-29 11:00:42 +00:00
parent eabdd7ab9f
commit 91b0f2c5df
8 changed files with 679 additions and 381 deletions

1
debian/changelog vendored
View File

@ -11,6 +11,7 @@ linux-2.6 (3.1.0-1~experimental.1) UNRELEASED; urgency=low
* [powerpc/powerpc64] Add missing #include to LPAR console selection fix
* Make kernel-wedge package checks non-fatal in experimental builds
* [x86/!486] Enable INTEL_IDLE
* aufs: Update to aufs3 for Linux 3.1 (Closes: #644687)
[ Bastian Blank ]
* Use xz compression for debug packages.

View File

@ -1,10 +1,10 @@
aufs2.1 base patch for linux-2.6.
aufs3.x-rcN base patch
diff --git a/fs/namei.c b/fs/namei.c
index 0223c41..cc5dc02 100644
index 0b3138d..8edad02 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -1690,7 +1690,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
@@ -1748,7 +1748,7 @@ static struct dentry *__lookup_hash(struct qstr *name,
* needs parent already locked. Doesn't follow mounts.
* SMP-safe.
*/
@ -14,7 +14,7 @@ index 0223c41..cc5dc02 100644
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
diff --git a/fs/splice.c b/fs/splice.c
index aa866d3..19afec6 100644
index fa2defa..e3569b0 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1085,8 +1085,8 @@ EXPORT_SYMBOL(generic_splice_sendpage);
@ -42,10 +42,10 @@ index aa866d3..19afec6 100644
ssize_t (*splice_read)(struct file *, loff_t *,
struct pipe_inode_info *, size_t, unsigned int);
diff --git a/include/linux/namei.h b/include/linux/namei.h
index eba45ea..21ed6c9 100644
index 409328d..40afdc0 100644
--- a/include/linux/namei.h
+++ b/include/linux/namei.h
@@ -82,6 +82,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
@@ -84,6 +84,7 @@ extern int vfs_path_lookup(struct dentry *, struct vfsmount *,
extern struct file *lookup_instantiate_filp(struct nameidata *nd, struct dentry *dentry,
int (*open)(struct inode *, struct file *));
@ -54,17 +54,17 @@ index eba45ea..21ed6c9 100644
extern int follow_down_one(struct path *);
diff --git a/include/linux/splice.h b/include/linux/splice.h
index 997c3b4..be9a153 100644
index 26e5b61..3ffef2f 100644
--- a/include/linux/splice.h
+++ b/include/linux/splice.h
@@ -89,4 +89,10 @@ extern int splice_grow_spd(struct pipe_inode_info *, struct splice_pipe_desc *);
extern void splice_shrink_spd(struct pipe_inode_info *,
struct splice_pipe_desc *);
@@ -91,4 +91,10 @@ extern void splice_shrink_spd(struct pipe_inode_info *,
extern void spd_release_page(struct splice_pipe_desc *, unsigned int);
extern const struct pipe_buf_operations page_cache_pipe_buf_ops;
+
+extern long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
+ loff_t *ppos, size_t len, unsigned int flags);
+extern long do_splice_to(struct file *in, loff_t *ppos,
+ struct pipe_inode_info *pipe, size_t len,
+ unsigned int flags);
+
#endif

View File

@ -1,10 +1,10 @@
aufs2.1 kbuild patch for linux-2.6.
aufs3.x-rcN kbuild patch
diff --git a/fs/Kconfig b/fs/Kconfig
index 19891aa..b660b64 100644
index 9fe0b34..c4311f8 100644
--- a/fs/Kconfig
+++ b/fs/Kconfig
@@ -208,6 +208,7 @@ source "fs/pstore/Kconfig"
@@ -215,6 +215,7 @@ source "fs/pstore/Kconfig"
source "fs/sysv/Kconfig"
source "fs/ufs/Kconfig"
source "fs/exofs/Kconfig"
@ -13,16 +13,16 @@ index 19891aa..b660b64 100644
endif # MISC_FILESYSTEMS
diff --git a/fs/Makefile b/fs/Makefile
index fb68c2b..c031a85 100644
index afc1096..5c5ac76 100644
--- a/fs/Makefile
+++ b/fs/Makefile
@@ -124,3 +124,4 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
@@ -123,3 +123,4 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
obj-$(CONFIG_EXOFS_FS) += exofs/
obj-$(CONFIG_CEPH_FS) += ceph/
obj-$(CONFIG_PSTORE) += pstore/
+obj-$(CONFIG_AUFS_FS) += aufs/
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
index 01f6362..8b3b9f1 100644
index 619b565..29f386b 100644
--- a/include/linux/Kbuild
+++ b/include/linux/Kbuild
@@ -65,6 +65,7 @@ header-y += atmppp.h

View File

@ -1,7 +1,7 @@
aufs2.1 standalone patch for linux-2.6.
aufs3.x-rcN standalone patch
diff --git a/fs/file_table.c b/fs/file_table.c
index 01e4c1e..0e800e2 100644
index c322794..2aad244 100644
--- a/fs/file_table.c
+++ b/fs/file_table.c
@@ -443,6 +443,8 @@ void file_sb_list_del(struct file *file)
@ -14,30 +14,22 @@ index 01e4c1e..0e800e2 100644
/*
diff --git a/fs/inode.c b/fs/inode.c
index 43566d1..4291eae 100644
index ec79246..46ac6f9 100644
--- a/fs/inode.c
+++ b/fs/inode.c
@@ -69,6 +69,7 @@ static DEFINE_SPINLOCK(inode_lru_lock);
@@ -65,6 +65,7 @@ static struct hlist_head *inode_hashtable __read_mostly;
static __cacheline_aligned_in_smp DEFINE_SPINLOCK(inode_hash_lock);
__cacheline_aligned_in_smp DEFINE_SPINLOCK(inode_sb_list_lock);
__cacheline_aligned_in_smp DEFINE_SPINLOCK(inode_wb_list_lock);
+EXPORT_SYMBOL_GPL(inode_sb_list_lock);
/*
* iprune_sem provides exclusion between the icache shrinking and the
* Empty aops. Can be used for the cases where the user does not
diff --git a/fs/namei.c b/fs/namei.c
index cc5dc02..121d5ba 100644
index 8edad02..50e8718 100644
--- a/fs/namei.c
+++ b/fs/namei.c
@@ -365,6 +365,7 @@ int deny_write_access(struct file * file)
return 0;
}
+EXPORT_SYMBOL_GPL(deny_write_access);
/**
* path_get - get a reference to a path
@@ -1694,6 +1695,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
@@ -1752,6 +1752,7 @@ struct dentry *lookup_hash(struct nameidata *nd)
{
return __lookup_hash(&nd->last, nd->path.dentry, nd);
}
@ -46,7 +38,7 @@ index cc5dc02..121d5ba 100644
/**
* lookup_one_len - filesystem helper to lookup single pathname component
diff --git a/fs/namespace.c b/fs/namespace.c
index fe59bd1..7d3843f 100644
index b4febb2..598a308 100644
--- a/fs/namespace.c
+++ b/fs/namespace.c
@@ -1508,6 +1508,7 @@ int iterate_mounts(int (*f)(struct vfsmount *, void *), void *arg,
@ -58,7 +50,7 @@ index fe59bd1..7d3843f 100644
static void cleanup_group_ids(struct vfsmount *mnt, struct vfsmount *end)
{
diff --git a/fs/notify/group.c b/fs/notify/group.c
index d309f38..f0e9568 100644
index 63fc294..6f4adca 100644
--- a/fs/notify/group.c
+++ b/fs/notify/group.c
@@ -22,6 +22,7 @@
@ -83,7 +75,7 @@ index d309f38..f0e9568 100644
}
+EXPORT_SYMBOL_GPL(fsnotify_alloc_group);
diff --git a/fs/notify/mark.c b/fs/notify/mark.c
index 252ab1f..2199b9b 100644
index e14587d..be6533b 100644
--- a/fs/notify/mark.c
+++ b/fs/notify/mark.c
@@ -112,6 +112,7 @@ void fsnotify_put_mark(struct fsnotify_mark *mark)
@ -119,7 +111,7 @@ index 252ab1f..2199b9b 100644
static int fsnotify_mark_destroy(void *ignored)
{
diff --git a/fs/open.c b/fs/open.c
index b52cf01..c1b341c 100644
index f711921..d742fc0 100644
--- a/fs/open.c
+++ b/fs/open.c
@@ -60,6 +60,7 @@ int do_truncate(struct dentry *dentry, loff_t length, unsigned int time_attrs,
@ -131,7 +123,7 @@ index b52cf01..c1b341c 100644
static long do_sys_truncate(const char __user *pathname, loff_t length)
{
diff --git a/fs/splice.c b/fs/splice.c
index 19afec6..11f07f8 100644
index e3569b0..9dc07b7 100644
--- a/fs/splice.c
+++ b/fs/splice.c
@@ -1109,6 +1109,7 @@ long do_splice_from(struct pipe_inode_info *pipe, struct file *out,
@ -160,10 +152,10 @@ index a93b3b7..024282c 100644
}
+EXPORT_SYMBOL_GPL(cap_file_mmap);
diff --git a/security/device_cgroup.c b/security/device_cgroup.c
index 1be6826..215278c 100644
index 4450fbe..2c437e5 100644
--- a/security/device_cgroup.c
+++ b/security/device_cgroup.c
@@ -508,6 +508,7 @@ found:
@@ -500,6 +500,7 @@ found:
return -EPERM;
}
@ -172,7 +164,7 @@ index 1be6826..215278c 100644
int devcgroup_inode_mknod(int mode, dev_t dev)
{
diff --git a/security/security.c b/security/security.c
index 4ba6d4c..9f64bb8 100644
index d9e1533..466ee5c 100644
--- a/security/security.c
+++ b/security/security.c
@@ -373,6 +373,7 @@ int security_path_rmdir(struct path *dir, struct dentry *dentry)
@ -233,13 +225,13 @@ index 4ba6d4c..9f64bb8 100644
{
@@ -520,6 +527,7 @@ int security_inode_permission(struct inode *inode, int mask)
return 0;
return security_ops->inode_permission(inode, mask, 0);
return security_ops->inode_permission(inode, mask);
}
+EXPORT_SYMBOL_GPL(security_inode_permission);
int security_inode_exec_permission(struct inode *inode, unsigned int flags)
int security_inode_setattr(struct dentry *dentry, struct iattr *attr)
{
@@ -626,6 +634,7 @@ int security_file_permission(struct file *file, int mask)
@@ -619,6 +627,7 @@ int security_file_permission(struct file *file, int mask)
return fsnotify_perm(file, mask);
}
@ -247,7 +239,7 @@ index 4ba6d4c..9f64bb8 100644
int security_file_alloc(struct file *file)
{
@@ -653,6 +662,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
@@ -646,6 +655,7 @@ int security_file_mmap(struct file *file, unsigned long reqprot,
return ret;
return ima_file_mmap(file, prot);
}

View File

@ -2,9 +2,9 @@
aufs_dir="$1"
for patch in aufs2-{base,kbuild,standalone}.patch; do
for patch in aufs3-{base,kbuild,standalone}.patch; do
sed 's/^+.*EXPORT_SYMBOL\b/&_GPL/' < "$aufs_dir"/"$patch" \
> debian/patches/features/all/aufs2/"$patch"
> debian/patches/features/all/aufs3/"$patch"
done
{
@ -14,4 +14,4 @@ done
while read file; do
diff -uN a/"$file" "$file" | filterdiff --addnewprefix=b/
done
} > debian/patches/features/all/aufs2/aufs2-add.patch
} > debian/patches/features/all/aufs3/aufs3-add.patch

View File

@ -6,14 +6,14 @@
+ features/all/sound-pci-cs46xx-request_firmware.patch
# Patches and source files from aufs2 repository, imported with
# debian/patches/features/all/aufs2/gen-patch.
#+ features/all/aufs2/aufs2-base.patch
#+ features/all/aufs2/aufs2-standalone.patch
#+ features/all/aufs2/aufs2-kbuild.patch
#+ features/all/aufs2/aufs2-add.patch
# Patches and source files from aufs3 repository, imported with
# debian/patches/features/all/aufs3/gen-patch.
+ features/all/aufs3/aufs3-base.patch
+ features/all/aufs3/aufs3-standalone.patch
+ features/all/aufs3/aufs3-kbuild.patch
+ features/all/aufs3/aufs3-add.patch
# mark as staging/crap
#+ features/all/aufs2/mark-as-staging.patch
+ features/all/aufs3/mark-as-staging.patch
+ bugfix/ia64/hardcode-arch-script-output.patch
+ bugfix/mips/disable-advansys.patch