Update metadata for "kbuild: Do not use hyphen in exported variable name"

I updated the commit message and re-submitted it after further
investigation.
This commit is contained in:
Ben Hutchings 2017-08-19 22:35:50 +01:00
parent 2b5b06c960
commit 918dc43e46
1 changed files with 11 additions and 5 deletions

View File

@ -1,17 +1,18 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 26 Aug 2016 01:31:28 +0100
Date: Sat, 19 Aug 2017 21:37:18 +0100
Subject: kbuild: Do not use hyphen in exported variable name
Bug-Debian: https://bugs.debian.org/833561
Forwarded: https://marc.info/?l=linux-kbuild&m=141523555023625
Forwarded: https://marc.info/?l=linux-kbuild&m=150317820622984&w=2
This definition in Makefile.dtbinst:
export dtbinst-root ?= $(obj)
should define and export dtbinst-root when handling the root dts
directory, and do nothing in the subdirectories. However, the
variable does not reliably get exported to the environment, perhaps
because its name contains a hyphen.
directory, and do nothing in the subdirectories. However some shells,
including dash, will not pass through environment variables whose name
includes a hyphen. Usually GNU make does not use a shell to recurse,
but if e.g. $(srctree) contains '~' it will use a shell here.
Rename the variable to dtbinst_root.
@ -19,6 +20,11 @@ References: https://bugs.debian.org/833561
Fixes: 323a028d39cdi ("dts, kbuild: Implement support for dtb vendor subdirs")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
scripts/Makefile.dtbinst | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/scripts/Makefile.dtbinst b/scripts/Makefile.dtbinst
index 34614a48b717..993fb85982df 100644
--- a/scripts/Makefile.dtbinst
+++ b/scripts/Makefile.dtbinst
@@ -14,7 +14,7 @@ src := $(obj)