dns323-setup.c: fix WARN() when booting (Arnaud Patard).

svn path=/dists/sid/linux-2.6/; revision=15513
This commit is contained in:
Martin Michlmayr 2010-04-13 16:24:21 +00:00
parent 2e7b72b161
commit 90dc9f7b65
3 changed files with 35 additions and 0 deletions

3
debian/changelog vendored
View File

@ -27,6 +27,9 @@ linux-2.6 (2.6.32-12) UNRELEASED; urgency=low
[ Aurelien Jarno ]
* [sh4] Add a sh7751r flavour.
[ Martin Michlmayr ]
* dns323-setup.c: fix WARN() when booting (Arnaud Patard).
-- Ben Hutchings <ben@decadent.org.uk> Tue, 06 Apr 2010 02:26:51 +0100
linux-2.6 (2.6.32-11) unstable; urgency=low

View File

@ -0,0 +1,31 @@
From: Arnaud Patard <arnaud.patard@rtp-net.org>
Date: Sat, 3 Apr 2010 08:31:33 +0000 (+0200)
Subject: [ARM] dns323-setup.c: fix WARN() when booting
X-Git-Url: http://git.marvell.com/?p=orion.git;a=commitdiff_plain;h=5efda86f74aa62f589297d0638c400b3f3fc6c64
[ARM] dns323-setup.c: fix WARN() when booting
Since commit b2a731aa5cbca7e0252da75e16de7ae5feb1313a, dns323_init() is
setting the power led gpio direction with gpio_direction_output() but
doesn't request the gpio before (which is not permitted by the gpio
layer afaik). This behaviour is triggering a WARN() at boot time.
Tested-by: Christian Samsel <csamsel@gmxpro.de>
Cc: Martin Michlmayr <tbm@cyrius.com>
Signed-off-by: Arnaud Patard <arnaud.patard@rtp-net.org>
Signed-off-by: Nicolas Pitre <nico@marvell.com>
[ Part 2: "Attached Text" ]
---
diff --git a/arch/arm/mach-orion5x/dns323-setup.c b/arch/arm/mach-orion5x/dns323-setup.c
index 421b82f..685f34a 100644
--- a/arch/arm/mach-orion5x/dns323-setup.c
+++ b/arch/arm/mach-orion5x/dns323-setup.c
@@ -439,6 +439,7 @@ static void __init dns323_init(void)
*/
if (dns323_dev_id() == MV88F5181_DEV_ID) {
dns323_leds[0].active_low = 1;
+ gpio_request(DNS323_GPIO_LED_POWER1, "Power Led Enable");
gpio_direction_output(DNS323_GPIO_LED_POWER1, 0);
}

View File

@ -3,3 +3,4 @@
+ features/all/drivers-block-drbd-add.patch
+ bugfix/all/phylib-fix-typo-in-bcm6xx-PHY-driver-table.patch
+ bugfix/all/ACPI-EC-Allow-multibyte-access-to-EC.patch
+ features/arm/dns323-rev-a1-gpio-request.patch