i40e: Add kconfig dependency to ensure cmpxchg64() is available

This should fix FTBFS on architectures where it isn't.
This commit is contained in:
Ben Hutchings 2018-03-15 19:07:24 +00:00
parent ee1a4b08d6
commit 90520391a2
3 changed files with 29 additions and 0 deletions

2
debian/changelog vendored
View File

@ -10,6 +10,8 @@ linux (4.16~rc5-1~exp2) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* udeb: Add dependency from nic-modules to zlib-modules (fixes FTBFS on
some architectures)
* i40e: Add kconfig dependency to ensure cmpxchg64() is available
(fixes FTBFS on some architectures)
-- Ben Hutchings <ben@decadent.org.uk> Tue, 13 Mar 2018 16:12:54 +0000

View File

@ -0,0 +1,26 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 15 Mar 2018 19:02:28 +0000
Subject: i40e: Add kconfig dependency to ensure cmpxchg64() is available
i40e again uses cmpxchg64(), which isn't available in some 32-bit SMP
configurations. It seems reasonable to expect that 40G hardware is
not used on 32-bit systems.
Fixes: 60f481b97038 ("i40e: change flags to use 64 bits")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
drivers/net/ethernet/intel/Kconfig | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/net/ethernet/intel/Kconfig b/drivers/net/ethernet/intel/Kconfig
index 1feb54b6d92e..dd17bdf5561e 100644
--- a/drivers/net/ethernet/intel/Kconfig
+++ b/drivers/net/ethernet/intel/Kconfig
@@ -215,6 +215,7 @@ config I40E
tristate "Intel(R) Ethernet Controller XL710 Family support"
imply PTP_1588_CLOCK
depends on PCI
+ depends on 64BIT || X86_CMPXCHG64
---help---
This driver supports Intel(R) Ethernet Controller XL710 Family of
devices. For more information on how to identify your adapter, go

View File

@ -78,6 +78,7 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/i40e-build-for-64-bit-targets-only.patch
# Miscellaneous features